It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
avatar
xmorphyx: Hi there,

I got Settler IV running with DXGL on Win10 without any other applied "Fix Patches" for the
3D Initialisation Error messages.
I've attached my actual settings. S4 is running without applying any compatibility settings
to S4.exe or S4_main.exe.
I'm using a gfxengine.dll mod to fit the game resolution to my 4k screen though.
May be the "The Settlers 4 - Widescreen Tool" will work for you.

TC,
morphy
THx, this works. But now i have another problem. In game i can't left click on buildings. Only if i drag the cursor i can select buildings, but i can't build any construction because i can't left click on the spot to build. Any idea?
avatar
bazgauiu: THx, this works. But now i have another problem. In game i can't left click on buildings. Only if i drag the cursor i can select buildings, but i can't build any construction because i can't left click on the spot to build. Any idea?
hmm...
If you have wrong DXGL settings for S4_main.exe you might get a "mouse position offset" problem.
Are any windows compatibillity settings for S4_main.exe still enabled? i.e. the DPI option?
May be the widescreen tool i mentioned above can help you if you set the correct resolution of your monitor.

TC,
morphy
I'm glad that your copy work perfect.

But in my case - nothing work.

DXGL & widescreen & fix applied.
On nVidia card - the game start withoun DXGL but run VERY SLOW
On Intel card - I hear sound, but I see nothing.
The best effect I had with the dgVoodoo, but then my screen was 4:3 aspect ratio and my screen is 16:9, so whole game looked very bad...

My computer:
Lenovo 310-15IKB
Win10 64-bit
8 GB RAM
Intel graphic card + nVidia 920MX.
Post edited May 30, 2017 by SebaD86
Awesome, works for me! thanks!!
I got it to work using DXGL, but no matter what I do, the videos don't play properly. Does anyone know what I could do?

I have no problems playing the videos out of the game (I have RADTools installed).
Post edited June 15, 2017 by Neprofik
Hi,
I sometimes get a problem with a slow game or at least the game sprites seem to move around "choppy".
I usually fix this with alt-tab out and back to the game. As I already wrote, I only use DXGL and a widescreen mod, no other "fix patches" for the game exes. The video playback doesn't work for me either.
Seems playback doesn't work over DXGL but i never tried to get them to work as i don't need the videos. :)

(btw: My DXGL settings are used with nVidia and AMD cards which support OpenGL V2.0 and higher.
I don't know if they also work with other gc.
Intel drivers/Intel gc often cause problems, also in other games. )

TC,
morphy
I have seen several similar solutions in this thread, but this is how I got it working with the help of the friendly support: (Lazy me, I contacted them before searching thoroughly in the forum.)

I have windows 10 on a laptop with an AMD Radeon R7 M260X card.

1. Install DXGL, latest version. (I am not sure this was needed in the end)
2. In the windows Properties-dialog for the S4.exe (settlers) file, on the Compatibility-tab, I simply selected "Windows XP (Service pack 2)".
3. Done! Now the game starts with a silly "not optimal resolution" warning from windows that disappear after five seconds. Game and sound works, but not the videos. I guess it would be possible to tweak that too, but I am not interested in videos. :)

I tried "Windows 98", but did not work, so it seems crucial to use "Windows XP" at least.
Post edited August 09, 2017 by Snorvarg