It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Alright, I tracked down some NDS people and asked some questions.

the RC1 patch is the final update for the game, the guy who made it verified this for me so this is whats happening.

1. He will upload it to somewhere permanant and have GOG change the link at the OP
2. He will be giving it to GOG so they can either fold it into their version permanently or make it an optional download.
3. He has given me a copy that I have uploaded to my GD account which is linked above.

So there you have it: THE RC1 PATCH IS THE MOST UP TO DATE VERSION OF THE GAME.
the GOG build is now RC1 patched and up to date.
There is still a unfixed bug

unlike in the DOS version the reactor destruct code is no longer random.
no word if a fix will happen, I have brought it to NDS' attention.
Post edited February 08, 2018 by Lord_Kane
ok, it's fixed.
does not start
Don't start. i3 8100 intel with intel hd graphics 630.
the gpu might be too weak - but post full system specs.
I3 8100 3,6GHz, 16Gb DDR4 RAM, Win 10
yeah, my money is on the integrated gpu, last time I've tried, I had to install a dedicated gpu (nv gf8400) to make it run. maybe try to start the game in the opengl mode, edit kexengine.cfg (should be in %APPDATA%\Nightdive Studios\System Shock EE\) and change seta r_rhirenderfamily "directx11" to seta r_rhirenderfamily "opengl"

a new patch is in the works, hopefully it will lower the gpu requirements again.
Post edited March 14, 2019 by voodoo47
avatar
voodoo47: yeah, my money is on the integrated gpu, last time I've tried, I had to install a dedicated gpu (nv gf8400) to make it run. maybe try to start the game in the opengl mode, edit kexengine.cfg (should be in %APPDATA%\Nightdive Studios\System Shock EE\) and change seta r_rhirenderfamily "directx11" to seta r_rhirenderfamily "opengl"

a new patch is in the works, hopefully it will lower the gpu requirements again.
Thanks, i will try or wait)
I have two weird problems with the game.

I run a Lenovo laptop with a Ryzen 7 4000 series,Windows 10, a GeForce GTX 1650, 16Gb RAM.

I reinstalled the game today and

-Problem #1: if I turn off VSync I get something like screen scanning on CRT TVs.
-Problem #2: I have screen remanence, IE the refresh screws up and I get different screens overlaying each other.

I tried switching the renderer from GPU to software, switching to a 4:3 resolution (1024x768) and going from D3D to OpenGL (though I think I could use Vulkan with my onboard AMD), nothing works after a while I get remanence and everything is unreadable.

Anyone has an idea? Maybe I should go into the nvidia control panel?
avatar
Megacyclo: I have two weird problems with the game.

-Problem #1: if I turn off VSync I get something like screen scanning on CRT TVs.
-Problem #2: I have screen remanence, IE the refresh screws up and I get different screens overlaying each other.
It's not mentioned which game is, but I'm assuming it is the first one as enhanced edition.
Thus looks like this discussion is your way to go.
avatar
Megacyclo: I have two weird problems with the game.

-Problem #1: if I turn off VSync I get something like screen scanning on CRT TVs.
-Problem #2: I have screen remanence, IE the refresh screws up and I get different screens overlaying each other.
avatar
DawEdhel: It's not mentioned which game is, but I'm assuming it is the first one as enhanced edition.
Thus looks like this discussion is your way to go.
Sorry, yeah it was SS1EE.
Forcing onboard graphics in the nvidia control panel fixed it for the time being but thanks for the link.