It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
I fixed the problem of black screen right after the bio logo by setting compatibility mode to Win8 instead of WinXP.
also to get the movies to play correctly i followed Kotor: Cutscenes Widescreen 1080p & Minimizing fix [K1] guid: www.youtube.com/watch?v=bA5l6HVs4Y4
Hello guys, I've been trying to run kotor at widescreen for a day now, and can't find the fitting way to do it. Flawless Widescreen seems to do the trick - at least with menus, as the game crashes after creating a character and pressing "play" button (probably the intro). I have Windows 10, AMD card, and want to play with 1600/900. The game is a retail version on 4 CDs.
avatar
Azzura89: I fixed the problem of black screen right after the bio logo by setting compatibility mode to Win8 instead of WinXP.
also to get the movies to play correctly i followed Kotor: Cutscenes Widescreen 1080p & Minimizing fix [K1] guid: www.youtube.com/watch?v=bA5l6HVs4Y4
If you have 1080p can you send me your modify bink files? You can upload it on google drive or something i have steam version
avatar
Azzura89: I fixed the problem of black screen right after the bio logo by setting compatibility mode to Win8 instead of WinXP.
also to get the movies to play correctly i followed Kotor: Cutscenes Widescreen 1080p & Minimizing fix [K1] guid: www.youtube.com/watch?v=bA5l6HVs4Y4
avatar
Extreme96PL: If you have 1080p can you send me your modify bink files? You can upload it on google drive or something i have steam version
don't now if that would be healpful to you. i play the game in german :)
avatar
Fah: Hello guys, I've been trying to run kotor at widescreen for a day now, and can't find the fitting way to do it. Flawless Widescreen seems to do the trick - at least with menus, as the game crashes after creating a character and pressing "play" button (probably the intro). I have Windows 10, AMD card, and want to play with 1600/900. The game is a retail version on 4 CDs.
after creating a character and prssing play the intro starts. You have to play without the movies or follow the giud i mentioned above.
Post edited February 17, 2018 by Azzura89
Ok, so hopefully people are still around to help me out here,

I'm trying to use the Universal Widescreen Patcher.
With a clean install and using the 1530x864 method, I run into a problem after I click 'Patch'

I get an error text box saying 'Access violation at blah blah in module gdifull32.dll. Read of address more numbers.'

It seems less to do with the patcher and more with my pc. Yes I've tried run as admin.

I was excited to play, but this sucks.

edit: Ok so I guess it was a windows update that was in the way. The Widescreen patcher works.
But now I cannot get my display to force the game to scale down to 1366x768 from 1530x864
I think maybe my Intel Hd 520 just can not do it.

Anyways +1 to the Universal Patcher working.
Post edited May 10, 2018 by pkk234
high rated
I'm making this post to hopefully help some who will likely have some issues running this game in widescreen/running this game on a modern Windows 10 OS.

First of all use this guys method. Do not use Flawless Widescreen. It's too much of a pain and it's results, while it works, has bugs of it's own. Use the Universal Widescreen method as outlined by this guy. It's far more reliable and requires far fewer hoops to jump through once you get it set up. I will edit in some additional information into this guys post too.

avatar
MisterBlack: Here's some info for anyone confused on how to get this game working in widescreen (1920x1080) and have the movies work as well.

This is what I did step by step using the Universal Widescreen Patcher (Not the Flawless Widescreen program):

Homepage: http://www.wsgf.org/article/star-wars-knights-old-republic

1. If you already have unsuccessfully patched the game restore your backup of the original EXE if you haven't already, if you don't have a backup on hand then uninstall and reinstall the game.

2. Make sure you ran the game once before patching to create your default configuration.

3. Download the Universial Widescreen patcher from the site above if you haven't already

4. Download the Hud Correction files for your resolution, the one I specifically used since I want to run 1920x1080 is 1920x1080 (Updated by nix3r)

5.6.7. My EDIT: Don't bother with these steps. The issue of blacked out videos is due to a bug in the game, not the format the game forces the videos to play in. Removing those lines of code from uniws script will not fix blacked out videos. In either case, so you know exactly what's happening, this issue actually only affects a couple of the videos in game, not all of them. Sometimes it happens randomly, but there are only 2 instances in game where this will happen nearly 100% of the time. And that's the very first video of the game just after you finish setting up your character, and a video on Manaan underwater when you make your choice while interfaced with a computer. It's something to do with the way the game transitions from menu's straight into a video. But in most situations when it transitions from game level to video, videos play fine 99% of the time. But for all instances of blacked out videos, there's an easy way to fix it. If you get a black video and you can tell it's video, simply hit the Windows key on your keyboard OR Alt+Tab out. Same difference. Then once you're on your desktop, click the running game icon on your taskbar to bring the game back to full screen. The game will automatically restart the video from the beginning and play through properly. That's all you have to do. You see a black video, Alt+Tab out then click the running game icon on your taskbar to restart the video.

8. Run uniws.exe, choose Star Wars: KOTOR (1024x768 interface), doesn't matter what resolution you ultimately plan on running, that's the one you need. My EDIT: In case anyone's confused, he's referring to the 1024x768 interface option that's in the "drop-down menu" that's at the top of the uniws GUI. The two typable boxes on the bottom of the uniws is where you type the resolution you "want" your game to play at. But in the drop-down box you select 1024x768, because that is the resolution option in game that your new custom resolution will be replacing.

9. Browse to your KOTOR installation in the game installation folder section. Afterwards, set your screen resolution in the New Resolution section, I made mine 1920 for screen width and 1080 for height. Once you are finished go ahead and hit the patch button and exit the program.

10. Extract your fixed hud files. (mine being kotor-1920x1080_updated.rar) Extract them to your KOTOR/override directory, under the default installation path, that would be: C:\GOG Games\Star Wars - KotOR\Override (My Edit: Do not copy the folder with the HUD files into the Override Directory. Copy the "contents" (the actual individual files) for your HUD correction into the Override directory)

11. Edit swkotor.ini (This is in your game's installation directory) . We need to change the resolution still since it won't be able to be changed in game to the widescreen resolution and the patcher doesn't actually seem to change it for us. Find the section [Graphics Options] in swkotor.ini and set your resolution with the Width and Height variables. You can also set your refresh rate as well here.

12. (Optional) I recommend disabling the Frame Buffer in game. If it's enabled on my AMD Radeon 270x the game seems to lock up before it finishes loading the first level with Frame Buffer and anti aliasing enabled. You can disable the Frame Buffer in the advanced graphics options in game or disable it in the swkotor.ini file in the [Graphics Options] section by setting Frame Buffer=0 . This may not be an issue on nVidia cards so I would probably only change this if you have any issues. My EDIT: Antialiasing is fine and has no issues. On AMD cards, the only two settings you need to disable are Frame Buffer Effects and Soft Shadows. Both are in "Advanced Settings". Everything else is fine.

Hope this solves some of the issues some people have been having with the game, these are my findings and experience so far. Once the game is setup though, it seems to run great has no issues so far.
Here are some new things I'm putting up here in case anyone wants them.

Upscaled Videos:

I've taken the time to upscale all of the videos in the game to a couple more modern monitor friendly resolutions. Most modern monitors do well enough, but some just seem to have issues with certain resolutions once they go below a certain threshold. And some just don't like to constantly switch. So I've made upscaled versions in 1440p and 1080p. I made the 1440p version originally for my play through (I have a 4K monitor), and planned to share it, but I know most people only have 1080p monitors so I went ahead and did them again in 1080p as well so I can share them here. But even if your monitor doesn't have issues in this regard, I do recommend the upscaled videos in either case as there is still a considerable quality improvement as a result of the upscaling.

To install, simply copy and paste the files into the \GOG Games\Star Wars - KotOR\movies directory. When windows asks, select overwrite and replace all files.

1080p Upscaled Videos: https://drive.google.com/file/d/1MhRTsS5eZzFb53W7OwCyYaPG8EL7BG14/view?usp=sharing

1440p Upscaled Videos: https://drive.google.com/file/d/1vY0Zk8wf1F7HwX6Kfc36kf2UNhAtoeNC/view?usp=sharing

1440p HUD Files

As the guy I quoted mentioned, you will need to download files to fix the HUD in game. But the site he links, doesn't have any HUD files for 1440p or 4K resolutions. After some digging I was able to find HUD files for 1440p. Sharing it here in case anyone else wants the 1440p files:

1440p HUD files: https://drive.google.com/file/d/1G9hkh3A2fhV9FcRxp2vZxCsQulyZRb1a/view?usp=sharing

Those of you wanting the 1080p HUD files, just go to http://www.wsgf.org/article/star-wars-knights-old-republic and download the nix3r updated version.

Grass Fix

I ran into this issue on my run through of the game on my 290X, but I don't know if Nvidia cards have the same issue. If you Nvidia users are also having issues with grass, try this as well. Basically once I got down to lower Taris, I was having a lot of issues with the grass. It wasn't properly blending with your characters nor NPC's. Looking transparent, yet not. It's hard to describe, but essentially the grass was cutting off the legs of your characters and NPC's because the transparency effects weren't working properly. Or at least, that's how it appeared in game. I managed to find a fix for it and will post it here. Simply copy and paste "opengl32.dll" and "opengl32.ini" into the root level of your KotOR installation directory. I've already pre-configured .ini file to enable the fix for the grass so it will render grass correctly in game.

Grass Fix: https://drive.google.com/file/d/1_pvaDyFLICHyzfwpEERrc0CO6Y-wSSwH/view?usp=sharing

I hope this helps any remaining stragglers who were having issues getting this game to run properly.

Also, these upscaled videos I've made available (1080p = about 4GB / 1440p = about 6GB / 10GB total) are taking up a fair chunk of my google drive (I only have the free 15GB max storage limit). So if anyone's willing, I would appreciate it if someone else who has online storage to spare, could grab those videos and make them permanently available for others to download. If anyone's able and willing to do that, I would really appreciate. I'll keep them on my drive for a couple months or as long as I can, but I will eventually have to remove the upscaled videos at the very least. The other files such as the grass fix and 1440p HUD files, I should be able to leave there for quite awhile without issue.
Post edited July 20, 2018 by ValhallasAshes
Thanks for your hard work MisterBlack and ValhallasAshes, your post certainly made my experience better playing this game. I have created a mega links for the files so you can clean out your google drive.

1080p Upscaled Videos
1080p HUD files

1440p Upscaled Videos
1440p HUD files

Grass Fix
Post edited August 05, 2018 by Ominousrobot
avatar
Ominousrobot: Thanks for your hard work bignick277, your post certainly made my experience better playing this game. I have created a mega links for the video files so you can clean out your google drive.

1080p Upscaled Videos
1080p HUD files

1440p Upscaled Videos
1440p HUD files
Awesome, Thank you Ominousrobot. It really is appreciate. I'm going to leave my links up for a couple more months until I need the space back. But when I do take them down, I will update the links in my post to use your links instead and credit you for re-hosting the files. Could you also host the Grass Fix as well as that one will be important for many players. While it's not important in the main city sections, once you hit lower taris and especially Dantooine and Kashyyk, that fix will be very important. Thanks again.

And thank you for not using a file hosting service that charges for downloads or tries to manipulate people into paying for faster downloads. I generally take issue with those types of sites, so thank you for not using one of those sites.
Post edited July 20, 2018 by ValhallasAshes
Thank you for your hard work!

And i would also like to add, that if you are using your 'integrated graphics card', like i was with my 'Intel HD graphics card', then you have to remove your monitor from that graphics card and plug it into your 'NVIDIA/AMD' graphics card.

That solved the crashing on startup for me.

Sometimes i have to change to my integrated graphics card in order to be able to play some older games, that won't work on NVIDIA.
Post edited April 06, 2019 by qwerty87
A big thanks to ValhallasAshes !
You really helped me with your post.
:-)
Post edited November 26, 2019 by rogerT
avatar
MisterBlack: Here's some info for anyone confused on how to get this game working in widescreen (1920x1080) and have the movies work as well.

This is what I did step by step using the Universal Widescreen Patcher (Not the Flawless Widescreen program):

Homepage: http://www.wsgf.org/article/star-wars-knights-old-republic

1. If you already have unsuccessfully patched the game restore your backup of the original EXE if you haven't already, if you don't have a backup on hand then uninstall and reinstall the game.

2. Make sure you ran the game once before patching to create your default configuration.

3. Download the Universial Widescreen patcher from the site above if you haven't already

4. Download the Hud Correction files for your resolution, the one I specifically used since I want to run 1920x1080 is 1920x1080 (Updated by nix3r)

5. Extract uniws.zip anywhere and open patches.ini

6. Scroll down or search for the section labeled [Star Wars: KOTOR (1024x768 interface)]

7. From that section remove these lines and save the file. This will fix the black screen when viewing movies in game:

;movies edit 1
p4modfile=swkotor.exe
p4undofile=swkotorc.undom1
p4sig=800200007515813DD8D17800E001
p4sigwild=00000000000000
p4xoffset=0
p4yoffset=12
p4occur=1
;movies edit 2
p5modfile=swkotor.exe
p5undofile=swkotorc.undom2
p5sig=80020000C7442410E001
p5sigwild=0000000000
p5xoffset=0
p5yoffset=8
p5occur=1


8. Run uniws.exe, choose Star Wars: KOTOR (1024x768 interface), doesn't matter what resolution you ultimately plan on running, that's the one you need.

9. Browse to your KOTOR installation in the game installation folder section. Afterwards, set your screen resolution in the New Resolution section, I made mine 1920 for screen width and 1080 for height. Once you are finished go ahead and hit the patch button and exit the program.

10. Extract your fixed hud files. (mine being kotor-1920x1080_updated.rar) Extract them to your KOTOR/override directory, under the default installation path, that would be: C:\GOG Games\Star Wars - KotOR\Override

11. Edit swkotor.ini (This is in your game's installation directory) . We need to change the resolution still since it won't be able to be changed in game to the widescreen resolution and the patcher doesn't actually seem to change it for us. Find the section [Graphics Options] in swkotor.ini and set your resolution with the Width and Height variables. You can also set your refresh rate as well here.

12. (Optional) I recommend disabling the Frame Buffer in game. If it's enabled on my AMD Radeon 270x the game seems to lock up before it finishes loading the first level with Frame Buffer and anti aliasing enabled. You can disable the Frame Buffer in the advanced graphics options in game or disable it in the swkotor.ini file in the [Graphics Options] section by setting Frame Buffer=0 . This may not be an issue on nVidia cards so I would probably only change this if you have any issues.

Hope this solves some of the issues some people have been having with the game, these are my findings and experience so far. Once the game is setup though, it seems to run great has no issues so far.
avatar
MysteriousStranger: I followed these steps as noted (with the exception of Step 11, as I didn't see the option to modify the resolution). I ran KOTOR in Administrator mode (Run as Administrator in Windows 10) and removed most of the Graphics settings checkbox options, and so far it's running like a charm. I'm over one hour into the game w/o any issues (about to enter the lower levels of Taris). Thanks for the game and the info!

Windows 10 64-bit; Intel i5-2500; Radeon Rx 480
I followed your steps exactly but when I run the game it runs at a low resolution. I now have the option to change to 1920x1080 but the refresh rate is low when I want 144hz. Any new fixes?
Post edited December 01, 2019 by PlumScrumpler
Widescreen patch worked for me but the override for 1080 p did not.
In game the ui was all tiny and in the upper left.
I looked at tons of internet posts and some mention this but no fixes.
Result: I revereted to playing at 1024xwhatever.

As to smallerizing, the best thing to do is edit the ini to change fullscreen to 0 so that it starts windowed.
Once it goes past the two intro videos and to main menu, I fullscreen it and play.
It still sometimes minimizes during transitions between planets... pretty much every other time and I have to restart game to get it to go through.
Alternate option is to switch back to windowed mode just before transition.

Otherwise game runs pefectly in win7.
I do have it in compatibility mode for winxp sp 3, but it wasn't any differnt when I had it off.

I turned off both buffer and the other one in the ini; again no idea if it changed anything.
Hey. Everything works fine except one little thing. Do you guys also has this problem with moving after the battle? I mean the character is stuck and w,s,a,d is not working ;((



edit - i manage to solve this problem XD you have to enable v sync and buffor
Post edited December 31, 2019 by Arielbla