It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
I installed everything as MisterBlack said, and the intro movies load fine, but the actual in-game cinematics are just black screens. What do I do? I have a 2048MB ATI AMD Radeon R9 200 Series and a AMD FX-6300 if any of that matters (thanks speccy, easy to look up now). I've experienced severe issues in the past with the grass in this game, but the movies would load fine.
avatar
Baratos: I installed everything as MisterBlack said, and the intro movies load fine, but the actual in-game cinematics are just black screens. What do I do? I have a 2048MB ATI AMD Radeon R9 200 Series and a AMD FX-6300 if any of that matters (thanks speccy, easy to look up now). I've experienced severe issues in the past with the grass in this game, but the movies would load fine.
I downloaded a Dantooine saved game since I haven't gotten that far yet so I could see some actual grass in the game and I can confirm your issue. I have pretty much an identical setup to what you're running: AMD-FX 6300, 8 GB of ram and a AMD Radeon R9 270X all running on Windows 8.1 Pro (64-bit). After some research through Google, it seems to be a common problem with ATI/AMD cards. (I actually seem to recall having similar problems with a nVidia card in the past so it may not be just AMD cards, can't confirm that since I don't have a system with an nVidia card up and running on it to test.)

It seems the only solution for now is to disable grass in the graphics options. It sure doesn't look as pretty, but at least you won't have to look at graphics corruption/glitches anymore. Hopefully in the future either AMD fixes this issue or GOG/The Community come up with a patch or workaround.

As for your black screen on in-game cinematics, I'm not having that issue. Even the ones triggered in game beyond the intro (not to be mistaken for the in-game rendered cutscenes), play without an issue.

All I can say really are the stereotypical answers to these types of problems since I'm not entirely sure what's happening on your end, could be a mistake of your own (It happens), or it could be an issue that I have no idea how to solve that is somehow unique.

I'm currently running the AMD Catalyst 14.9.2 beta drivers, so I'd just make sure you got the latest 14.9 drivers off the AMD site if you haven't already. (Not the betas, the stable ones should be good enough.)

Also check that you removed the lines showed in step 7 in the [Star Wars: KOTOR (1024x768 interface)] section inside the patches.ini file. There will be duplicate entries of those lines for each resolution interface so it must be very specific.

If you don't want to do that yourself, or you if you want to be sure, I did upload my edited patches.ini to Dropbox:

https://www.dropbox.com/s/hd2earq3vxztcx6/patches.ini?dl=0

Just replace the one that came with UniWS.zip, restore your original EXE, and try patching again.

I hope that helps. It's about all I have at the moment.
I'm going to go through this again thoroughly later, thanks for all the help.
avatar
astewart1980: Flawless Widescreen + Manual update of the resolution in swkotor.ini working fine for me, after a couple of initial crashes.
avatar
Sachys: You mean flawless widescreen crashed, or KOTOR... or both?
Sorry, to clarify, KOTOR crashed a few times initially using FW but seemed to settle down. Only had the occasional issue with cut-scenes since, but nothing that isn't fixed by restarting both programs. Game is perfectly playable, so thanks for the recommendation.
avatar
MisterBlack: Here's some info for anyone confused on how to get this game working in widescreen (1920x1080) and have the movies work as well.
Confirming this works smoother then having the Flawless Widescreen exe loaded in background.
Flawless worked for a couple times then didnt go fullscreen anymore and lost 1920x1080 settings.

Mister Blacks technic worked perfectly.
only two minor issues:
- game takes longer to load, around 7-8 seconds
- FMV playback switches resolution back to 1280x760 and the n back to 1920x1080 when finished

tested on Win 7 64bit
cheers
avatar
MisterSpanky: Confirming this works smoother then having the Flawless Widescreen exe loaded in background.
Flawless worked for a couple times then didnt go fullscreen anymore and lost 1920x1080 settings.

Mister Blacks technic worked perfectly.
only two minor issues:
- game takes longer to load, around 7-8 seconds
- FMV playback switches resolution back to 1280x760 and the n back to 1920x1080 when finished

tested on Win 7 64bit
cheers
That's strange that your game takes longer to load, mine seems to almost instantly. Only thing I can think of that you could try is right clicking on the game shortcut, go to properties, then go to the compatibility tab and try disabling desktop composition. That might not do much to help, so if it doesn't i'd just uncheck that option and leave it. I remember some older games hanging on startup on Windows 7 with desktop composition enabled. (Diablo II was one of them, but this may not be the same case with KOTOR.)

My in-game videos play at 640x480 which is fine (I'll take that over them not playing at all), that's the same resolution the videos run at on an unpatched exe anyways.
Yesterday Flawless Widescreen got stuck in its update process, so i disabled all auto updates. The reason seems that the website is down.
Can anyone confirm this?
avatar
Prian: Yesterday Flawless Widescreen got stuck in its update process, so i disabled all auto updates. The reason seems that the website is down.
Can anyone confirm this?
seems to be the case:
http://www.downforeveryoneorjustme.com/flawlesswidescreen.org
Aahhh.... Ok.
Nevertheless, it works just fine, though sometimes i have to start the game a few times before it´s using the right resolution.
I've tried a number of different suggestions and all I get is audio with no screen and that's assuming the game doesn't crash before it reaches that point. If it takes this many tweaks for it to even work then they're charging too much money and / or never should have released it. I'm getting the refund. I don't have the time to do all of this. It would have been nice to play it again, but it's just not worth this hassle.
avatar
malevolentmuse: I've tried a number of different suggestions and all I get is audio with no screen and that's assuming the game doesn't crash before it reaches that point. If it takes this many tweaks for it to even work then they're charging too much money and / or never should have released it. I'm getting the refund. I don't have the time to do all of this. It would have been nice to play it again, but it's just not worth this hassle.
I very much doubt not being able to run the game in widescreen will classify as not being able to run the game. To run it in widescreen resolutions you have to use a third party fix.
Post edited November 07, 2014 by Sachys
avatar
MisterBlack: That's strange that your game takes longer to load, mine seems to almost instantly. Only thing I can think of that you could try is right clicking on the game shortcut, go to properties, then go to the compatibility tab and try disabling desktop composition.
yeah, as i said, only minor problems compared to annoyance of having to laod another program in background, that stills works only half the time... for the short time it worked.

Played 20 hours so far, added modded weapons and textures: not a single problem.

Activating .exes XP compatibility and assigning admin rights didnt change anything.
I noticed after the first time i start the game it takes a few seconds less to load, but again, im just nitpicking.
kudos man
avatar
MisterBlack: Here's some info for anyone confused on how to get this game working in widescreen (1920x1080) and have the movies work as well.
Thanks (and +1) for this info. Much obliged to you.
PSA: flawlesswidescreen.org is back online!

Everyone should use this opportunity to download it and update their plugins. The program works really well, BUT it has its idiosyncrasies and limitations. Here's what I've learned about using it with KotOR (Win8.1, x64, pre-GCN AMD APU):

The 32-bit version works better than the 64-bit one. Use that one, unless your OS prevents you.
The portable versions work as well as the installers.
You'll need to run the game several times to get it working properly.
You shouldn't need any special compatibility settings to run either one, though the setup requires some.

To set up a working solution, I had to set both swkotor.exe and FlawlessWidescreen.exe to Windows XP Service Pack 2 compatibility; FlawlessWidescreen.exe needed to be Run as an Administrator. With FW running, I needed to start the game at least twice because FW had difficulties reformatting the backgrounds and interface in one go. The first time you start the game, change the resolution to your desired one, even if it is already running in it. This will instruct FW to create new interface elements in the Override folder. However, these were still the original 800x600 resources, stretched. I needed to leave the game, then start it again. Now, FW was able to use its resources to copy new background images over the files in the Override folder, and the interface fits perfectly! I was now able to remove all previously applied compatibility settings from either programme. Once the game interface looks properly, it's a good idea to back up your Override folder. Getting a good set of working interface files has always been my greatest difficulty with KotOR.

One caveat to this method was that whenever I changed resolution, the game would revert to full screen. I was still able to use the process to create backgrounds at any resolution. Unfortunately, the in-game interface file only works in full screen; in a window, it gets cut off and is largely unusable.
avatar
Spinorial:
Cheers Spinners! Updated the OP.