It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
avatar
Chandoraa: Excuse me if I'm oversimplifying here, but if I understood correctly, The Flawless Widescreen method is easier to implement but may bork your grass, and the UniWS method does not have any known issues. Am I right? Because if so, I guess I'm gonna try the UniWS, or just play in 4:3.
My experience is that Flawless just would not work on my setup (Win 7 64bit), so I used the info on Universal WS posted here, and it works like a charm. No hassles, no borking of grass, no problems whatsoever.
avatar
medusa86: I've tried the Universal Widescreen Patcher, but I can't get it to work on 1366x768. I mean, it looks fine, except that in conversations I don't see any answer options...
Anyone else has this problem? Thanks!
Yup, same problem here. Invisible convo options makes succeeding in installing WS moot. :/

Oh well..
I managed to get 1920x1080 resolution working fine with uniws (i think) and editing the ini file, however it looks like the mini-map is messed up. Reverting the resolution to the 4:3 seems to correct the map issues.

Did i install or do something wrong so the maps are wrong? Or is that a permanent issue?
avatar
MisterB: In case anyone else is having the same issue I was, I missed the tip about using the 32 bit (x86) version of flawlesswidescreen and was trying to get the 64 bit version to work. No matter what I did, I couldn't change to anything but the default resolutions, fws seemed to be doing nothing. I uninstalled it and installed the 32 bit version, and it works perfectly, no tweaking needed.
Same for me 64 bit flawlesswidescreen doen't work, 32 bit works.
Playing Kotor1 Gog version on 64 bit Win 7.
Post edited January 09, 2016 by ianuse
avatar
rtcvb32: I managed to get 1920x1080 resolution working fine with uniws (i think) and editing the ini file, however it looks like the mini-map is messed up. Reverting the resolution to the 4:3 seems to correct the map issues.

Did i install or do something wrong so the maps are wrong? Or is that a permanent issue?
My guess is that you forgot to apply the necessary HUD corrections?
They, together with a short tutorial, can be found here.
avatar
Urnoev: My guess is that you forgot to apply the necessary HUD corrections?
They, together with a short tutorial, can be found here.
I did apply the HUD corrections, unless I put them in the wrong folder, but following the instructions I was sure I did it right. Although it's possible I did it wrong since the resolution part is confusing on following so I don't know.
Post edited January 22, 2016 by rtcvb32
avatar
MisterBlack: Here's some info for anyone confused on how to get this game working in widescreen (1920x1080) and have the movies work as well.
Thanks - I followed your guide and it worked perfectly... nice job.
avatar
MisterBlack: Here's some info for anyone confused on how to get this game working in widescreen (1920x1080) and have the movies work as well.

This is what I did step by step using the Universal Widescreen Patcher (Not the Flawless Widescreen program):

Homepage: http://www.wsgf.org/article/star-wars-knights-old-republic

1. If you already have unsuccessfully patched the game restore your backup of the original EXE if you haven't already, if you don't have a backup on hand then uninstall and reinstall the game.

2. Make sure you ran the game once before patching to create your default configuration.

3. Download the Universial Widescreen patcher from the site above if you haven't already

4. Download the Hud Correction files for your resolution, the one I specifically used since I want to run 1920x1080 is 1920x1080 (Updated by nix3r)

5. Extract uniws.zip anywhere and open patches.ini

6. Scroll down or search for the section labeled [Star Wars: KOTOR (1024x768 interface)]

7. From that section remove these lines and save the file. This will fix the black screen when viewing movies in game:

;movies edit 1
p4modfile=swkotor.exe
p4undofile=swkotorc.undom1
p4sig=800200007515813DD8D17800E001
p4sigwild=00000000000000
p4xoffset=0
p4yoffset=12
p4occur=1
;movies edit 2
p5modfile=swkotor.exe
p5undofile=swkotorc.undom2
p5sig=80020000C7442410E001
p5sigwild=0000000000
p5xoffset=0
p5yoffset=8
p5occur=1


8. Run uniws.exe, choose Star Wars: KOTOR (1024x768 interface), doesn't matter what resolution you ultimately plan on running, that's the one you need.

9. Browse to your KOTOR installation in the game installation folder section. Afterwards, set your screen resolution in the New Resolution section, I made mine 1920 for screen width and 1080 for height. Once you are finished go ahead and hit the patch button and exit the program.

10. Extract your fixed hud files. (mine being kotor-1920x1080_updated.rar) Extract them to your KOTOR/override directory, under the default installation path, that would be: C:\GOG Games\Star Wars - KotOR\Override

11. Edit swkotor.ini (This is in your game's installation directory) . We need to change the resolution still since it won't be able to be changed in game to the widescreen resolution and the patcher doesn't actually seem to change it for us. Find the section [Graphics Options] in swkotor.ini and set your resolution with the Width and Height variables. You can also set your refresh rate as well here.

12. (Optional) I recommend disabling the Frame Buffer in game. If it's enabled on my AMD Radeon 270x the game seems to lock up before it finishes loading the first level with Frame Buffer and anti aliasing enabled. You can disable the Frame Buffer in the advanced graphics options in game or disable it in the swkotor.ini file in the [Graphics Options] section by setting Frame Buffer=0 . This may not be an issue on nVidia cards so I would probably only change this if you have any issues.

Hope this solves some of the issues some people have been having with the game, these are my findings and experience so far. Once the game is setup though, it seems to run great has no issues so far.
Um, what if i do not know where to find my fixed hud files?
*edit* nvm i'm an idiot
Post edited July 10, 2016 by TheRealNiall
Why don't the game support 1920x1200 from the beginning? It does have 1600x1200. Do i have to run a custom patch to get it to work?
avatar
klappis: Why don't the game support 1920x1200 from the beginning? It does have 1600x1200. Do i have to run a custom patch to get it to work?
Because it is old and widescreen resolutions were not very common when it was released. See the start post for ways to make it work with widescreen resolutions. There may still be problems, like crashes when playing videos. See the post above yours for a possible solution.
I have a problem, with my 1366x768 resolution, the game work fine but i can't see my answer of the dialog, i try everything but i don't find ho to resolve this

Somebody know how to resolve my problem ?
avatar
Likion: I have a problem, with my 1366x768 resolution, the game work fine but i can't see my answer of the dialog, i try everything but i don't find ho to resolve this

Somebody know how to resolve my problem ?
See the "Notes" section at the bottom of the following page:

http://www.wsgf.org/article/star-wars-knights-old-republic
Okay, I'm using the GOG version of KOTOR, and am trying to set it up for my 2560x1600 monitor.
I installed the HUD files for 2560x1600 into the Override directory, as instructed.

The first time I ran uniws.exe V1.03, it let me type in my resolution values, but when I ran it, it gave an error message about user-mapped sections.

I then closed it and tried again, but now it simply *never* enables the 'New Resolution' data fields, nor the Patch button.

I *have* selected Game: Star Wars: KOTOR (1024x768 interface)
I *am* pointing Game Installation Folder to F:\Games\Star Wars - KotOR
which is the correct directory where swkotor.exe is located.

What is going wrong??
avatar
derelict.765: Okay, I'm using the GOG version of KOTOR, and am trying to set it up for my 2560x1600 monitor.
I installed the HUD files for 2560x1600 into the Override directory, as instructed.

The first time I ran uniws.exe V1.03, it let me type in my resolution values, but when I ran it, it gave an error message about user-mapped sections.

I then closed it and tried again, but now it simply *never* enables the 'New Resolution' data fields, nor the Patch button.

I *have* selected Game: Star Wars: KOTOR (1024x768 interface)
I *am* pointing Game Installation Folder to F:\Games\Star Wars - KotOR
which is the correct directory where swkotor.exe is located.

What is going wrong??
Just to be clear, you're supposed to install the HUD files after applying the patch.
avatar
Urnoev: Just to be clear, you're supposed to install the HUD files after applying the patch.
Ahhh... no, I didn't realize that. Let me remove them and try again...

Later:
However, even after deleting all files in the Override directory, I still have this issue;
in uniws.exe, I select "Star Wars: KOTOR (1024x768 interface)",
then select the install directory for Star Wars - Kotor, and I still cannot enter any numbers in the "New Resolution" fields.
The "Undo Patch" and "Patch" buttons are greyed out.
Post edited March 08, 2017 by derelict.765