It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Works for me. I have Windows 7 64 bit.

I downloaded the recommended version of flawlesswidescreen. ran it flwlesswidescreen and clicked on kotor. Started up kotor quit the game and started it up again and quit the game. Did this a few more time like it said to do in the instructions:

NOTE: You must start KOTOR and exit atleast once before this fix will properly be active, this is because custom files generated need to be detected by KOTOR before it starts, additionally graphics backgrounds and GUI files will not be generated unless you change the resolution
and I was then given the option to change the settings to 1920x1080.
Post edited January 23, 2015 by James175
Fixed that, but now I have another issue that is even more of a problem. See my "Kotor 1 freezing" post. :/

Thanks for your help!
If anyone develops a seamless patch to inject widescreen resolutions into menu options and fixes performance issues when rendering grass they would be my hero!
Here is my checklist for installing Kotor2. Note that I actually used the retail disks - so your mileage may vary slightly.

I have Windows 7 64-bit, and I installed into C:\Games rather than the default. Note also that I installed the restored content mods as well - no links here but they're very easy to find.

Read this for installing on Windows 7:


Install patches 1.0a and 1.0b

Install media update patches (see readme files). (These are easy to find too. Don't know if the GOG version comes with these as standard.)

Install restored content mod 183b

Install M4-78 mod 11b

Install Vista Fix

Apply widescreen patches - see tweak guide:

Make sure to set Squ1zZy_ResPatcher_SWKotor_2.exe to run as administrator in compatibility settings after dropping it in. Also set all the rest of the EXEs to run as admin as well.



Turn on V-Sync (prevents movement bug)
Post edited February 20, 2015 by Ian.747
Does this work for 1280x720? I can't get it to work.
In case anyone else is having the same issue I was, I missed the tip about using the 32 bit (x86) version of flawlesswidescreen and was trying to get the 64 bit version to work. No matter what I did, I couldn't change to anything but the default resolutions, fws seemed to be doing nothing. I uninstalled it and installed the 32 bit version, and it works perfectly, no tweaking needed.
Just thought I'd throw my experience into the mix:

I'm using the latest Windows 10 Technical Preview Build 10061 64bit on an Intel Core-i5 4200U and the integrated HD4400 graphics.

The latest 64 bit Flawless Widescreen fully installed worked to get widescreen working for me by running it in administrator mode and starting up KoTOR once, quitting it, and starting it again. 1920x1080 at 60hz runs great.
Cool fact: the UniWS method works like a charm for at least KOTR 1 when run on Wine. Including Wineskin on a mac.
MisterBlack: Here's some info for anyone confused on how to get this game working in widescreen (1920x1080) and have the movies work as well.

Just wanted to say thanks. This worked for me (although the cutscenes are now a little on the small size, the gameplay is smooth in WS 1920 x 1080).

Managed to sort out the low resolution cutscene issue by upscaling the movies to 1920 x 1080 and editing the hard coded resolutions in the swkotor.exe. I'm now running the game in fullscreen with 1920x1080 cutscenes. All good. Thanks to all that have contributed to this thread that have enabled the play of KOTOR at high resolutions.
MisterBlack: Here's some info for anyone confused on how to get this game working in widescreen (1920x1080) and have the movies work as well.

This is what I did step by step using the Universal Widescreen Patcher (Not the Flawless Widescreen program):


1. If you already have unsuccessfully patched the game restore your backup of the original EXE if you haven't already, if you don't have a backup on hand then uninstall and reinstall the game.

2. Make sure you ran the game once before patching to create your default configuration.

3. Download the Universial Widescreen patcher from the site above if you haven't already

4. Download the Hud Correction files for your resolution, the one I specifically used since I want to run 1920x1080 is 1920x1080 (Updated by nix3r)

5. Extract anywhere and open patches.ini

6. Scroll down or search for the section labeled [Star Wars: KOTOR (1024x768 interface)]

7. From that section remove these lines and save the file. This will fix the black screen when viewing movies in game:

;movies edit 1
;movies edit 2

8. Run uniws.exe, choose Star Wars: KOTOR (1024x768 interface), doesn't matter what resolution you ultimately plan on running, that's the one you need.

9. Browse to your KOTOR installation in the game installation folder section. Afterwards, set your screen resolution in the New Resolution section, I made mine 1920 for screen width and 1080 for height. Once you are finished go ahead and hit the patch button and exit the program.

10. Extract your fixed hud files. (mine being kotor-1920x1080_updated.rar) Extract them to your KOTOR/override directory, under the default installation path, that would be: C:\GOG Games\Star Wars - KotOR\Override

11. Edit swkotor.ini (This is in your game's installation directory) . We need to change the resolution still since it won't be able to be changed in game to the widescreen resolution and the patcher doesn't actually seem to change it for us. Find the section [Graphics Options] in swkotor.ini and set your resolution with the Width and Height variables. You can also set your refresh rate as well here.

12. (Optional) I recommend disabling the Frame Buffer in game. If it's enabled on my AMD Radeon 270x the game seems to lock up before it finishes loading the first level with Frame Buffer and anti aliasing enabled. You can disable the Frame Buffer in the advanced graphics options in game or disable it in the swkotor.ini file in the [Graphics Options] section by setting Frame Buffer=0 . This may not be an issue on nVidia cards so I would probably only change this if you have any issues.

Hope this solves some of the issues some people have been having with the game, these are my findings and experience so far. Once the game is setup though, it seems to run great has no issues so far.

For anyone else using the UNIWS method of getting widescreen working for KOTOR, and who is interested in having fullscreen cutscenes too, here's how I achieved it...

But first a few Caveats

i. This method took me a LONG time to implement - it relies on the upscaling conversion of KOTORS .BIK movies (Using RADTOOLS), and took my humble little PC the best part of a day to convert. SO: if you're looking for a quick fix, forget it. Please don't ask me to share my upscaled movies or hacked .EXE file. Let's try to keep things beautiful round here.

ii. As it relies on modifying your .BIK files and your "swkotor.exe" remember to BACK UP YOUR ORIGINALS. If you don't do this and it all goes horribly wrong then when you come back to the forum crying and mewling we'll all laugh at you and sing the "S/HE DIDN'T BACK UP THE ORIGINALS SO THEY'LL HAVE TO UN/INSTALL AND REINSTALL" song. Loudly.

iii. I've only tested this method for the 1920x1080 resolution. If you are set-up for anything else then you'll have to modify the hack to the executable that is detailed (as the hex is hardcoded specifically for whatever resolution you have scaled your movies to).

iv. This method does rely on being able to download and utilise additional external tools for its implementation - RAD VIDEO TOOLS (for the movie conversion) and HxD (for the EXE Hex hack). If you don't feel confident enough to batch process files or mess around editing Hex then best to leave this fix alone. Move along. Nothing to see here.

Ok - on to the fix.

1. Apply the Universal Widescreen Patcher as detailed by MisterBlack (see "quoted" above).

2. Backup the "Movie" directory and "swkotor.exe" located in your KOTOR Main directory - I created a directory called BACKUP and dumped a COPY of them in there.

3. Download and install RAD VIDEO TOOLS and HxD Hex Editor.

4. Set some time aside for this step as it takes a LONG time (Mine took about 6 hours so I left it to run overnight). Open RADTOOLS and in the LOOK IN browseable box at the top, browse to your original MOVIES directory (Your .BIK files should display in the box below). Click/Highlight the first file - Which should be "0a.bik" and then CTRL/A to highlight all the .BIK files. Then click the "BINK IT" button. Click "YES" at the one by one batch process prompt.

5. In the next "Bink Compressor" dialogue box, ensure that you select a suitable "output" directory (use the "Browse" button to select where your upscaled files are going to be stored when converted - I created a dir called "NewMovies") and under the "Scaling Type..." button, you input the desired "Width" of 1920 and "Height" of 1080.

6. Ensure that the tick is visible in "Compress audio" and that your "Compress Level" is set to 4. When this is done, click the "BATCH" button AND start the upscaling conversion. THIS WILL TAKE A LONG TIME TO DO - GO OUT FOR A MEAL OR VISIT THOSE RELATIVES YOU DON'T SEE OFTEN BECAUSE YOU'RE PLAYING RPG's ALL THE TIME.

7. Now that you have upscaled copies of the .BIK files in the output directory that you selected, you will need to rename these files, as the output process has added a "New_" to the front of all file names. As an example "0a.bik" has been outputted as "New_0a.bik". Remove all "New_" from your .BIK filenames.

8. Copy and OVERWRITE your new upscaled files into your original "Movies" directory located in your KOTOR Main directory.

9. Now, start the HxD program, (as we need to specify our new resolution which is hard coded into the EXE) and click File -> Open -> "swkotor.exe".

10. When "swkotor.exe" is open in HxD, click Search -> Find.

11. In the find dialogue box, ensure that "Datatype:" is set to "Hex-values".

12. in the "Search for:" box paste the following values 80 02 00 00 75 15 81 3D D8 D1 78 00 E0 01

13. Carefully change the highlighted Hex string to read as the following 80 07 00 00 75 15 81 3D D8 D1 78 00 38 04

14. Again, click Search -> Find.

15. In the find dialogue box, ensure that "Datatype:" is still set to "Hex-values".

16. in the "Search for:" box paste the following values 80 02 00 00 C7 44 24 10 E0 01

17. Carefully change the highlighted Hex string to read as the following 80 07 00 00 C7 44 24 10 38 04

18. Save your "swkotor.exe" and close HxD.

That's it - when you reload KOTOR all movies should play at fullscreen resolution!

Should you need any additional pointers and tips please feel free to consult the following resources from which I culled this install method, and give thanks to these guys, without whom, KOTOR cutscenes would be very small indeed.

RenegadeSniper7's Original Exehack forum posting (Lucasarts)

Xuul's Excellent Cutscene installation guide (Youtube)

Post edited May 16, 2015 by guartrainer
Did anyone get flawless to work with the gog version ? I installed it and I can run it but when i run kotr while flawless is running not much seems to happen.
I was abale to get unwis to work by the 4 little icons don't seem to display the right location (I have a 27 inch monitor @ 2560x1440) and I cant' quite figure out which setting with unwis to get things to look right (I mean the actual graphis look fine but the gui doesnt' seem right0.
So I guess I have two problems; I can't get things to look right with unwis and I can't figure out how to get flawless to work with the gog version of kotr.

hum uwis seems to work better if i run the monitor at 1080p and use the 1280x1024 resolution for the gui. I think I see how it is patching the gui - kind of wish I could fine tune it but this seems usable and the movies seem to work whehn i enter the scape pod.
Post edited June 12, 2015 by you2
I've tried the Universal Widescreen Patcher, but I can't get it to work on 1366x768. I mean, it looks fine, except that in conversations I don't see any answer options...
Anyone else has this problem? Thanks!
I've got it to work on my 1366x768. Not sure how.

However, the Flawless Widescreen is not Flawless. It crashes my game often where Windows states "Knights of the Old Republic has stopped working," and I even got a rare crash on FW just today! Also, sometimes, it takes me several loads of KoToR (opening and exiting it) before FW actually gives me my resolution. I run the resolution at 60Hz. Also, sometimes the game crashes after several hours of play.

Here are my specs:
Windows 7 64-bit Ultimate with SP1
Intel Core i5-2140M @ 2.30 GHz (I guess I missed that one)
4 GB of RAM
256 GB SSD
GeForce GT 555M VRAM: 1024 MB - latest drivers
DirectX: June 2010 (or later)
Sound Card: Realtek (I can't find the real name of it)
Video Drivers: Latest ones for my GeForce

Anyone know what's wrong? The crashes are VERY frustrating. I can still play the game (I'm at Dantoonie), but trying to load it up in the first place is just annoying.

Edit: Another note: I'm using the Restoration Mod, too.
Post edited July 22, 2015 by AegisRunestone
Excuse me if I'm oversimplifying here, but if I understood correctly, The Flawless Widescreen method is easier to implement but may bork your grass, and the UniWS method does not have any known issues. Am I right? Because if so, I guess I'm gonna try the UniWS, or just play in 4:3.