It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
avatar
MisterBlack: Here's some info for anyone confused on how to get this game working in widescreen (1920x1080) and have the movies work as well.

This is what I did step by step using the Universal Widescreen Patcher (Not the Flawless Widescreen program):

Homepage: http://www.wsgf.org/article/star-wars-knights-old-republic

1. If you already have unsuccessfully patched the game restore your backup of the original EXE if you haven't already, if you don't have a backup on hand then uninstall and reinstall the game.

2. Make sure you ran the game once before patching to create your default configuration.

3. Download the Universial Widescreen patcher from the site above if you haven't already

4. Download the Hud Correction files for your resolution, the one I specifically used since I want to run 1920x1080 is 1920x1080 (Updated by nix3r)

5. Extract uniws.zip anywhere and open patches.ini

6. Scroll down or search for the section labeled [Star Wars: KOTOR (1024x768 interface)]

7. From that section remove these lines and save the file. This will fix the black screen when viewing movies in game:

;movies edit 1
p4modfile=swkotor.exe
p4undofile=swkotorc.undom1
p4sig=800200007515813DD8D17800E001
p4sigwild=00000000000000
p4xoffset=0
p4yoffset=12
p4occur=1
;movies edit 2
p5modfile=swkotor.exe
p5undofile=swkotorc.undom2
p5sig=80020000C7442410E001
p5sigwild=0000000000
p5xoffset=0
p5yoffset=8
p5occur=1


8. Run uniws.exe, choose Star Wars: KOTOR (1024x768 interface), doesn't matter what resolution you ultimately plan on running, that's the one you need.

9. Browse to your KOTOR installation in the game installation folder section. Afterwards, set your screen resolution in the New Resolution section, I made mine 1920 for screen width and 1080 for height. Once you are finished go ahead and hit the patch button and exit the program.

10. Extract your fixed hud files. (mine being kotor-1920x1080_updated.rar) Extract them to your KOTOR/override directory, under the default installation path, that would be: C:\GOG Games\Star Wars - KotOR\Override

11. Edit swkotor.ini (This is in your game's installation directory) . We need to change the resolution still since it won't be able to be changed in game to the widescreen resolution and the patcher doesn't actually seem to change it for us. Find the section [Graphics Options] in swkotor.ini and set your resolution with the Width and Height variables. You can also set your refresh rate as well here.

12. (Optional) I recommend disabling the Frame Buffer in game. If it's enabled on my AMD Radeon 270x the game seems to lock up before it finishes loading the first level with Frame Buffer and anti aliasing enabled. You can disable the Frame Buffer in the advanced graphics options in game or disable it in the swkotor.ini file in the [Graphics Options] section by setting Frame Buffer=0 . This may not be an issue on nVidia cards so I would probably only change this if you have any issues.

Hope this solves some of the issues some people have been having with the game, these are my findings and experience so far. Once the game is setup though, it seems to run great has no issues so far.
Is there a way to run this to just get the movies rendering at screen resolution? I am running in 1280 x 1024 which is already a supported resolution, I'm just getting tired of the game always minimizing, often irrevocably, in between movies and cutscenes.
I followed Sachys' advice from the very first post. Thank you so much... it's so simple and it works.

However, for any of you whom might be trying to play this on a Acer AspireOne 10.1" laptop or some other 1366 x 768 resolution running little screen, I've discovered something that might help. Here's the thing:

When I've first tried running Stachys' solution, Flawless Widescreen running in the background did it's job nicely, but I still couldn't run movies, and I could barely play the game because big black horizontal bars flashed up the screen sporadically... drove me nuts! It was said that it might take a few tries before it actually took effect correctly... so I tried over and over again.

Anyways, that particular problem appears to have come from the fact that my built in Intel HD Graphics was running at 59pHz! Luckily, in the Advanced setting of the graphics driver, there's a nice little drop-down that offers one other choice: 60pHz! Once I changed the screen rate to 60 Hz, those dog gone bars disappeared!

I still cannot play movies, which drives me so mad that I'm very much ready to (for the first time in 909 days) ask for a refund. I am a CG animator working on my own movies, and seeing those beautiful works of art is a major part of the game to me! Just getting to my save, arriving in Taris from the escape pod, I had to tell my savior that I had a vision, even though "I" never got to see that vision!

Anyways, I thought that I'd mention that screen refresh rate thing for anyone interested in fixing this. The game itself plays beautifully in front of Flawless Widescreen.
avatar
Dartanbeck:
Its weird so many people are having issues with the movies - I only have the steam version and didnt have an issue (also using an Intel HD), so maybe its an issue with the GOG version?! - I'm sure support can help you figure it out though.
avatar
Sachys: Its weird so many people are having issues with the movies - I only have the steam version and didnt have an issue (also using an Intel HD), so maybe its an issue with the GOG version?! - I'm sure support can help you figure it out though.
I was troubleshooting someone's problem and we compared the bink libraries from my original and their GOG version, and they were identical. So no, I don't think anything about the movies was changed.

Honestly, I think the main culprit is something in people's Windows setups or how they've set up their drivers, not the actual hardware itself. For each of nVidia/AMD/Intel we have the full range of working/not-working feedback :/
avatar
Spinorial:
Do you think it could be something as simple as a codec conflict (or something along those lines)?
avatar
Sachys: Do you think it could be something as simple as a codec conflict (or something along those lines)?
Nah, I think binks are self-contained and don't rely on external codecs, that's why so many games use them. Some older version can be incompatible with modern OS, but that's not the case here.
Post edited December 05, 2014 by Spinorial
avatar
Sachys: Do you think it could be something as simple as a codec conflict (or something along those lines)?
avatar
Spinorial: Nah, I think binks are self-contained and don't rely on external codecs, that's why so many games use them. Some older version can be incompatible with modern OS, but that's not the case here.
I meant more along the lines of some external codec to the game, causing some kind of conflict with the binks somehow - like when people install those "codec pack" things - always cause problems somewhere
avatar
Sachys: I meant more along the lines of some external codec to the game, causing some kind of conflict with the binks somehow - like when people install those "codec pack" things - always cause problems somewhere
It crossed my mind, but again, it would have to be explicitly a bink codec conflict, i.e. another bink version installed. Even so, the file in the game's folder should take precedence over any other installation.

It's all theory, though. Something is screwing with the game and I couldn't begin to guess what it could be from out here :/
Post edited December 05, 2014 by Spinorial
avatar
Spinorial: Something is screwing with the game and I couldn't begin to guess what it could be from out here :/
GOGbears!!!!!
Okay, since I can't seem to find an answer to my problem, I figured I would ask here. I am using the UniWis patcher and the WSGF UI fix. Everything goes well until i get to the UI. The widescreen resolution works just fine, the menus have the backgrounds fixed, but the UI stubbornly refuses to change. I have tried everything I can think of to no avail. The interesting thing, is that the UI fix worked with my old disc copy on this same system, so I see no reason why it shouldn't work now.

EDIT: It appears i was simply using the wrong UniWis patch, carry on, nothing to see here.
Post edited December 13, 2014 by deadeye126
Hi folks,

Still trying to get FW running. The GOG game works way better for me than the steam version did, but it is very annoying to see the game stretched to the max on my huge monitor. I've had FW installed for osme time. I started the program, set my resolution, and started the game. I briefly saw "injecting" in the FW window, but when the game starts, there are no additional resolutions to select from in the graphics menu.

Can anyone help? Thanks!
Hello there!

I just wanted to ask if some of you already tried to enable widescreen-resolutions with UWS for the just released Version of KotOR 2 here on gog. Did it work, or are there any issues so far?

I will be running the game on Win7.

My problem (not just in this game) is, that the normal maximum resolution (1280x1024) is causing blurred horizontal lines all over the screen. The spaces between them are normal sharp. This is very subtle but annoying anyway. It looks like the screen is pressed together from upside down.

Or maybe someone can tell me how do fix this. Normally 1280x1024 is ok for me.

Thank you!
Post edited January 21, 2015 by heretic_fiend
avatar
jbeck83: Can anyone help? Thanks!
daft question: but you are running both FW and KOTOR as admin arent you? - if you are I'll have a think and see what i can come up with, if not, give that a go first!
avatar
jbeck83: Can anyone help? Thanks!
avatar
Sachys: daft question: but you are running both FW and KOTOR as admin arent you? - if you are I'll have a think and see what i can come up with, if not, give that a go first!
Thanks for your help. I think that might have fixed it - except now this is causing Kotor to crash, which prevents the patcher from working a second time around. If I close FW, the game launches fine. This is a new issue which I haven't looked into - any ideas?

I wouldn't be putting so much effort into this except, when it works, I greatly prefer FW to UniWis.

Thanks again!
avatar
jbeck83: Can anyone help? Thanks!
avatar
Sachys: daft question: but you are running both FW and KOTOR as admin arent you? - if you are I'll have a think and see what i can come up with, if not, give that a go first!
Nevermind. Fixed the crashing problem (disabled V-Sync and disabled windowed mode) and switching permissions fixed it. Thanks for the idea. An obvious thing I should have caught but didn't. Thanks again!
avatar
heretic_fiend: Hello there!

I just wanted to ask if some of you already tried to enable widescreen-resolutions with UWS for the just released Version of KotOR 2 here on gog. Did it work, or are there any issues so far?

I will be running the game on Win7.

My problem (not just in this game) is, that the normal maximum resolution (1280x1024) is causing blurred horizontal lines all over the screen. The spaces between them are normal sharp. This is very subtle but annoying anyway. It looks like the screen is pressed together from upside down.

Or maybe someone can tell me how do fix this. Normally 1280x1024 is ok for me.

Thank you!
Haven't tried yet, but I plan on it. Perhaps someone else has?
Post edited January 21, 2015 by jbeck83
avatar
jbeck83: If I close FW, the game launches fine. This is a new issue which I haven't looked into - any ideas?
hmmm... thats odd. I dont have the game installed right now (and actually trying to resolve crash issues with KOTOR2 myself), but I'll have a look later on at the text files I made (tend to keep a record of these things) to see if theres anything helpful. Hopefully someone else may have an idea in the meantime.

Edit: oh, you edited your post as I posted mine!
Heheheh
. glad you got it working. :)
Post edited January 21, 2015 by Sachys