It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
avatar
DD78: Hi! My friend tried to install the 1.50.x patch on his Mac - but running install-macosx only brings up a white window (the MOO2launcher). Apparently the two text input fields (paths) are there and if he's lucky he can click on "Browse" to open a folder selector.. But the folder selector doesn't allow him to go inte the game folder (installed by Gog Galaxy).

What to do? Anyone else had this?
Hi. Don't have time to troubleshoot mac os launcher, sorry. You can do manual installation, I can guide you if you're still interested. Also post which mac os version is it, so I know where launcher is broken.
I was able to successfully install the 1.5 patch, however when I get ready to launch it I get this error:

couldn't execute "B:\Master of Orion 2\Master of Orion 2\DOSBox\DOSBox.EXE": invalid argument
couldn't execute "B:\Master of Orion 2\Master of Orion 2\DOSBox\DOSBox.EXE": invalid argument
while executing
"exec $emulator -noconsole -conf $dbc_name -conf [norm_path $ct 150 dosbox.conf] &"
invoked from within
"if $run_directly {
set tclpath [pwd]
cd [norm_path $ct]
exec ./ORION150.EXE &
cd $tclpath
} elseif $have_dosbox {
..."
(procedure "cmd_launch_moo2" line 97)
invoked from within
"cmd_launch_moo2"
invoked from within
".r.run invoke "
invoked from within
".r.run instate !disabled { .r.run invoke } "
invoked from within
".r.run instate pressed { .r.run state !pressed; .r.run instate !disabled { .r.run invoke } } "
(command bound to event)

??????? I tried changing different parameters on the launcher but no luck, anyone can can help? I'm still able to launch MOO2 (ver 1.40b23) but not through the launcher that uses the 1.50.17 patch
Post edited May 15, 2020 by CyberTrick
avatar
CyberTrick: I was able to successfully install the 1.5 patch, however when I get ready to launch it I get this error:

couldn't execute "B:\Master of Orion 2\Master of Orion 2\DOSBox\DOSBox.EXE": invalid argument
[...]
??????? I tried changing different parameters on the launcher but no luck, anyone can can help? I'm still able to launch MOO2 (ver 1.40b23) but not through the launcher that uses the 1.50.17 patch
So it seems it couldn't find DOSBox program
- noticed you installed on B:\ drive? That's rare. Are you sure that's correct and DOSBox sits on B:\ and within the Master of Orion game directory??
- also noticed double MOO2 directory: "Master of Orion 2\Master of Orion 2" is that intentional?
- what means "I was able to successfully install.." Does it mean the Launcher autodetected your game and DOSBox and installation went without manual intervention?
avatar
Rocco.40: So it seems it couldn't find DOSBox program
- noticed you installed on B:\ drive? That's rare. Are you sure that's correct and DOSBox sits on B:\ and within the Master of Orion game directory??
- also noticed double MOO2 directory: "Master of Orion 2\Master of Orion 2" is that intentional?
- what means "I was able to successfully install.." Does it mean the Launcher autodetected your game and DOSBox and installation went without manual intervention?
Thaks for your response Rocco.40. Well, the patch was able to correctly auto-detect both of the needed folders for installation. I double checked the path for where it was supposed to be installed and I received a "successful installation" when it was done. I keep my games separate on the B: drive, and the "Master of Orion 2\Master of Orion 2" is intentional because the first folder also holds the original MOO2 setup.exe. the second "Master of Orion 2" folder is just the game itself. So it all looks as if it correctly auto-detected the proper files and installed, but crashes with that error on launch.
Post edited May 15, 2020 by CyberTrick
avatar
CyberTrick: [...] the patch was able to correctly auto-detect both of the needed folders for installation. I double checked the path for where it was supposed to be installed and I received a "successful installation" when it was done. I keep my games separate on the B: drive, and the "Master of Orion 2\Master of Orion 2" is intentional because the first folder also holds the original MOO2 setup.exe. the second "Master of Orion 2" folder is just the game itself. So it all looks as if it correctly auto-detected the proper files and installed, but crashes with that error on launch.
well, i would guess that if the original orion2.exe is both present in "Master of Orion 2" and in "Master of Orion 2\Master of Orion 2", then you might have 'tricked' launcher and installation was, contrary to the report, not a success. Better to make 1 level game directory, and to keep your "back up including setup.exe" in a separate dir that is not nested.
Post edited May 15, 2020 by Rocco.40
Patch version 1.50.18 has been released!

Changes are described in the changelog:
https://moo2mod.com/patch/CHANGELOG_150.TXT

This release got the all new "Mirror Map" functionality that splits the galaxy in identical shards mirroring each other, so each player gets an identical start.

Also with revamped scripting, you will find in Launcher the option to play with a random tech tree. Combined with a new parameter that can prevent player from seeing future tech tree, it will make for an entirely different moo2 experience.

Enjoy!
Post edited May 15, 2020 by Rocco.40
avatar
Rocco.40: Patch version 1.50.18 has been released!.....
Really.... REALLY Rocco.40!!

So I decided to uninstall the game and start from scratch. On your suggestion I made a 1 level directory and wouldn't you know... it worked! But then, I came here to thank you and you decide to post a new patch, THANKS (he says sarcastically) I got the new patch and was also able to install that without any problems. Thanks again.
avatar
Rocco.40:
Excuse me but the links in the first post do no work any longer. Easy to fix but you have to do it, if you could please be so kind, thank you.

I think the new features are excellent :-)
Post edited May 16, 2020 by Themken
avatar
Themken: Excuse me but the links in the first post do no work any longer. [...]
Fixed 'em!
Just installed the 1.5 patch and its great!

I do have a question though.

When I try changing the build queue lists, any changes I make in the build.cfg files doesn't change anything in the game.

Besides making changes and saving them, is there anything else I need to do to make the changes actually work?
avatar
Qiaosi: ... is there anything else I need to do ...?
Yes, RTFM
avatar
Qiaosi: ... is there anything else I need to do ...?
avatar
DarzaR: Yes, RTFM
Well, I wish I could say that your reply was helpful... but unfortunately I cannot.

I have read the manual and am still not sure why the changes I made are not taking effect. So... If anyone else could be more helpful than DarzaR, I would be very appreciative.
avatar
DarzaR: Yes, RTFM
avatar
Qiaosi: I have read the manual and am still not sure why the changes I made are not taking effect.
Possible options:
1. You didn't read it, and lied.
2. You can't read properly.

In case 1 you could went and read it, in case 2 its, sadly, more complicated.
avatar
Qiaosi: I have read the manual and am still not sure why the changes I made are not taking effect.
avatar
DarzaR: Possible options:
1. You didn't read it, and lied.
2. You can't read properly.

In case 1 you could went and read it, in case 2 its, sadly, more complicated.
Ok, I'll bite. :-)

Would you be so kind as to point out the line in the manual that would answer my question?
avatar
Qiaosi: Would you be so kind as to point out the line in the manual that would answer my question?
No, as there are more than one such line possible, alternatively relevant to it, as your question is very vaguely described. So it would be not reasonably to copy all of them here, as they are already collected in manual.