It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
Been a while, but everything's been running smoothly. There are, however, a couple of new issues:

- If a colony ship arrives in a system where an outpost ship is present, the player will be prompted to create a new outpost; if they decline, they will not be prompted to create a new colony, forcing them to do so manually.

- Here's a fun one. The Sakkra captured Epsilon from me during a war, then offered it back to me as part of a peace deal. When I received the system, a large part of the population was "captured," even though they were my own race. But now, on the next turn, I receive two simultaneous messages about rebels dying on Epsilon--a system entirely under my control, and filled with my own people--because I am both the rebel race and the occupying army.

SAVE1.GAM
New game, different issue. The colony of Naam is under threat from a comet. When the comet event first triggered, Naam was a Sakkra colony, but I have since captured it. On the next turn, my fleet will destroy the comet, but GNN gives credit to the "Sakkra" fleet.

SAVE1.GAM
Sorry for "fast" response.
Colony ship - its cannot be fixed easy way, and too minor to be fixed difficult way. If player decline colonization prompt on a star - it will stop all other ones there too, as prompt is per star, not per ship.
Sakkra -
Comet - Non-general events always target some player. Changing the colony ownership have no effect on it. Surely its minor bug, maybe will eventually be fixed.
Thanks for the info, man, and glad to hear its generally working well.
1.50.8 is UP !

Check the website for the details:
www.moo2mod.com
Post edited May 27, 2017 by Rocco.40
avatar
Rocco.40: 1.50.8 is UP !

Check the website for the details:
www.moo2mod.com
Installing via the launcher breaks the default GOG desktop shortcut, something that didn't happen with the old manual installation. Workaround is to rename ORION150.exe to ORION2.exe .
avatar
Rocco.40: 1.50.8 is UP !

Check the website for the details:
www.moo2mod.com
avatar
srhill: Installing via the launcher breaks the default GOG desktop shortcut, something that didn't happen with the old manual installation. Workaround is to rename ORION150.exe to ORION2.exe .
we intentionally made it so the gog desktop shortcut is unaffected and still leads to the 1.40 version of the game.
from the 1.50.8 patch onwards, the fan patch will not affect any files of the original installation, hence we used another exe name as well.
best is to use the Launcher desktop shortcut instead.
Post edited May 28, 2017 by Rocco.40
avatar
Rocco.40: best is to use the Launcher desktop shortcut instead.
Very thank you! That's the way to go!
we just patched launcher to v1.1.1
- tickboxes like '5 planet systems' now work as intended
Woah, just learned about this! Awesome stuff! It's gonna take me some time to pour over these updates.

Curious, is there any way to get mouse scroll wheels working with the in-game lists? I'm also not averse to coding myself. :)
Great, and I'm hoping to get back into this.

But the Launcher reports "Unknown version!" when trying to patch my 1.50.3 version.
(As reported on title screen: 1.50.3, V mod 1.2 + picks)

(I believe that latter info just indicates the use of modified config files)
This really improved upon the MOO2 experience. I'm flabbergasted that someone is still improving upon the best turn based strategy game ever!
avatar
legraf: Great, and I'm hoping to get back into this.

But the Launcher reports "Unknown version!" when trying to patch my 1.50.3 version.
(As reported on title screen: 1.50.3, V mod 1.2 + picks)

(I believe that latter info just indicates the use of modified config files)
Hi
I just created a moo2 folder with 1.50.3 and indeed the 1.50.8 Launcher does not recognize that exe version.
As a solution you can restore your old 1.31 or 1.40 exe, naming it as ORION2.EXE and delete the current ORION2.EXE that is v1.50.3. While you are at it, you can also safely delete the ORION2.BIN file. This .bin was the extension of the exe, but in 1.50.8 everything is packed in 1 exe.
Launcher will recognize v131 and v140 versions of orion2.exe.
avatar
cguinnup: Woah, just learned about this! Awesome stuff! It's gonna take me some time to pour over these updates.

Curious, is there any way to get mouse scroll wheels working with the in-game lists? I'm also not averse to coding myself. :)
There was some tool created for scrolling, by user called Kornstalx.
You can find thread about it here, but link to download seems to be dead, perhaps you can request a re-upload:
www.spheriumnorth.com/orion-forum/nfphpbb/viewtopic.php?t=738

avatar
Green_Knight: This really improved upon the MOO2 experience. I'm flabbergasted that someone is still improving upon the best turn based strategy game ever!
Glad you like it! We are team of 3 and spent many hours work on this true gem of a game.
Thanks so much, Rocco. Of course if I'd read the readme, I could have done the manual install. Anyway... looks great! Now to be unproductive for the next few days.
Woo-hoo, double armor!
Attachments: