It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
avatar
adamhm: It looks like you're missing libvulkan1 and/or libvulkan1:i386 - make sure those are installed as GOGWrap enables DXVK by default & will use Vulkan for DX10/11 games. You may also need to install mesa-vulkan-drivers and mesa-vulkan-drivers:i386 if you're using the open graphics drivers.
I'm using nvidia-proprietary and had libvulkan1 (v1.1.101.0-2~gpu18.04) installed already, but libvulkan1:386 is not in Mint's repo, as it seems.
Post edited July 13, 2019 by Klumpen0815
avatar
Klumpen0815: I'm using nvidia-proprietary and had libvulkan1 (v1.1.101.0-2~gpu18.04) installed already, but libvulkan1:386 is not in Mint's repo, as it seems.
It should be available (it's provided by Ubuntu). Try: sudo apt install libvulkan1:i386

Edit: Or you could try installing my common dependencies meta-package in case you're missing anything else as well
Post edited July 13, 2019 by adamhm
avatar
clarry: Which graphics driver are you using? That environment variable is not universal. However if this game really has the extension string bug, then I'd think it's better to patch the binary. However, it seems different from the Quake binaries..
avatar
adamhm: MESA_EXTENSION_MAX_YEAR is correct for the GPU & drivers I'm using (AMD RX480 using the open drivers. Kernel 5.0.0-20 & Mesa 19.1).

avatar
clarry: EDIT: please try replace ref_gl.dll with this version: http://guu.fi/g/sof/ref_gl.dll (I doubt it helps, but it's worth a try)
avatar
adamhm: I tried some of those as well, looks like GOG already use a patched version though. The one you linked to does not make any difference.
Hmm, our software is similar enough that I suspect this could be an issue with the game trying to use a display mode that your monitor does not support (or that is somehow disabled in software). (I'm also using RX480 with open drivers, MESA 18.3.6, kernel 5.0.9-200)

I could not figure out a simple way to stop the game from mode switching. It's possible to disable fullscreen mode but the game still does a mode switch at startup before reverting back to the desktop resolution.

EDIT: Does it give any more detail preceding the final error message?
Post edited July 13, 2019 by clarry
avatar
clarry: Hmm, our software is similar enough that I suspect this could be an issue with the game trying to use a display mode that your monitor does not support. (I'm also using RX480 with open drivers, MESA 18.3.6, kernel 5.0.9-200)

I could not figure out a simple way to stop the game from mode switching. It's possible to disable fullscreen mode but the game still does a mode switch at startup before reverting back to the desktop resolution.
I tried running the game in a virtual desktop in case that was an issue, but it did not help. The game seems to think there is no hardware acceleration available - this is what sof.log shows after enabling logging:
------- Loading ref_gl.dll -------
ref_gl version: GL 0.01
Initializing OpenGL display
...setting mode 3: 640 480 FS
...attempting fullscreen
...using gl_bitdepth of 32
...calling CDS: ok
...registering window class: ok
GLimp_Init() - no hardware acceleration detected
VID_CreateWindow() - GLimp_InitGL failed
ref_gl::R_SetMode() - invalid mode
ref_gl::R_Init() - could not R_SetMode()
ref_gl::R_Init() - could not load "opengl"
Initializing OpenGL display
...setting mode 3: 640 480 FS
...attempting fullscreen
...using gl_bitdepth of 32
...calling CDS: ok
...registering window class: ok
GLimp_Init() - no hardware acceleration detected
VID_CreateWindow() - GLimp_InitGL failed
ref_gl::R_SetMode() - invalid mode
ref_gl::R_Init() - could not R_SetMode()
ref_gl::R_Init() - could not load "3dfxvgl"
ref_gl::R_Init() - could not load "3dfxogl"
Cmd_RemoveCommand: avi not added
R_Shutdown() - Shutting down
************************************************************
ERROR: Could not initialize OpenGL rendering environment!
Thanks to Clarry it looks like a wrapper for Soldier of Fortune will be available sooner rather than later; using a modified ref_gl.dll he created the game now starts and I've encountered no problems so far :)
avatar
adamhm: Thanks to Clarry it looks like a wrapper for Soldier of Fortune will be available sooner rather than later; using a modified ref_gl.dll he created the game now starts and I've encountered no problems so far :)
It is possible that all the changes I made were unnecessary..

Assuming the "generic" string in your GL_RENDERER was the only problem, then you could probably just have your wrapper script patch the GOG version of that file on the fly. sed -i s/generic/SoFsuxx/ ref_gl.dll might be all it needs.

(My version has a couple changes in the code to bypass some checks; the version I posted earlier also neutered a possible gl extension string issue but I guess I overwrote that change at some point)
Post edited July 13, 2019 by clarry
avatar
Klumpen0815: I'm using nvidia-proprietary and had libvulkan1 (v1.1.101.0-2~gpu18.04) installed already, but libvulkan1:386 is not in Mint's repo, as it seems.
avatar
adamhm: It should be available (it's provided by Ubuntu). Try: sudo apt install libvulkan1:i386

Edit: Or you could try installing my common dependencies meta-package in case you're missing anything else as well
You're right since the command worked, for some reason Synaptic didn't show it.

Unfortunately Wuppo still has the sound bug (fullscreen issue was solved by setting the virtual desktop as I noticed in the wrapper as well as in system wine). At least I know now how the generic Proton wrapper works, it may come in handy in the future.

Thank you!
Post edited July 13, 2019 by Klumpen0815
avatar
clarry: Assuming the "generic" string in your GL_RENDERER was the only problem, then you could probably just have your wrapper script patch the GOG version of that file on the fly. sed -i s/generic/SoFsuxx/ ref_gl.dll might be all it needs.
I have an initial wrapper done and that does seem to be all that's needed.
high rated
A wrapper is now available for Soldier of Fortune.

In addition, all wrappers have been updated with a small winewrap.shlib update and wrappers using Wine+DXVK now use Wine Staging 4.10 and DXVK 1.3.
This is awesome.. Thank you so much for all your hard work. Do you have a git page?
avatar
adamhm: List of wrapper release threads:

Fallout: New Vegas for Linux
For your (and GOG's) info, this is the reason I just purchased Fallout: New Vegas.
high rated
All wrappers have been updated with a small update to winewrap.shlib. In addition, all Wine+DXVK wrappers were updated to use DXVK 1.3.1, all dgVoodoo wrappers now use dgVoodoo 2.60, and the wrapper for System Shock 2 was updated for the v2.48 installer.
high rated
All wrappers have received another winewrap.shlib update, which adds support for some changes made with Proton 4.11 and improves the DXVK/D9VK options. In addition, all Wine+DXVK wrappers now use DXVK 1.3.2 and GOGWrap now uses Proton 4.11-2 by default.
Post edited August 18, 2019 by adamhm
avatar
adamhm: All wrappers have received another winewrap.shlib update, which adds support for some changes made with Proton 4.11 and improves the DXVK/D9VK options. In addition, all Wine+DXVK wrappers now use DXVK 1.3.2 and GOGWrap now uses Proton 4.11-2 by default.
Thank you for the Proton 4.11-2 update :)
I'm using the generic Proton wrapper for Ori and the Blind Forest atm and it works perfectly with one exception: Controller.
I got a Logitech F310 and regardless of whether I set it to XInput or DInput, it checks out alright in the Wine joystick configuration inside the wrapper, reacts as it should, but isn't recognized in the game regardless of the setting.
Any ideas?

I have xboxdrv installed and it generally works.
Post edited August 21, 2019 by Klumpen0815