It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
SteamPlay Menu is now available again with numerous improvements, including more reliable detection of installed Proton releases and selection of the correct versions per app, as well as the ability to search through the games currently installed with SteamPlay if you don't know their AppIDs. More details & the download link can be found in post #3.
Hi,

I just installed BioShock remastered with your wrapper (bioshock_remastered_wine.sh). When I try to start the game I see

002d:err:vulkan:wine_vk_init Failed to load vulkan library
002d:err:vulkan:wine_vk_init Failed to load Wine graphics driver supporting Vulkan.
002d:err:module:LdrInitializeThunk "winevulkan.dll" failed to initialize, aborting

in the terminal. After reading around a bit, I see that your installer already uses wine staging and also downloads the latest dxvk drivers (1.0.3. atm). So for me to try to fix it I would probably repeat all the things you so nicely did. Any ideas why it still doesn't work? I installed libvulkan1 (albeit only after I got these errors, but wine staging doesn't get compiled on my machine right?), have a NVIDIA 730GTX (with the 418 drivers) and I am on Ubuntu 18.04.

Thanks!
avatar
tensionhead: I installed libvulkan1 (albeit only after I got these errors, but wine staging doesn't get compiled on my machine right?), have a NVIDIA 730GTX (with the 418 drivers) and I am on Ubuntu 18.04.
Make sure you have both libvulkan1 and libvulkan1:i386 installed.
Thanks for your quick answer!

avatar
adamhm: Make sure you have both libvulkan1 and libvulkan1:i386 installed.
libvulkan1:i386 is not available via apt in Ubuntu 18.04. Not sure if it's in the libvulkan-dev, I will investigate how to get it..
According to cacheable.net/2018/10/04/Run-Overwatch-on-Ubuntu-18-04-with-Lutris/ what is needed to install libvulkan:i386 on Ubuntu 18.04 is:

sudo dpkg --add-architecture i386
sudo apt install libvulkan1 libvulkan1:i386

I did exactly that, the libvulkan error disappeared and I could boot up the game, yeah!

However, right after the introduction (protagonist swims to the water surface) the game jumped back to the main menu. On the terminal I can see:

002d:err:winediag:wined3d_dll_init Setting multithreaded command stream to 0x1.
0034:err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.

Is that related to the game still not starting properly?

Update: After properly reading through the ntlm_auth error above, I installed the winbind package

sudo apt install winbind

and I can now play this amazing game :)
Post edited April 28, 2019 by tensionhead
avatar
tensionhead: However, right after the introduction (protagonist swims to the water surface) the game jumped back to the main menu
That's actually a bug with the game itself & not an issue with dependencies - for some reason the player character occasionally drowns before surfacing. Only thing to do is start a new game & try again.
Post edited April 28, 2019 by adamhm
avatar
adamhm: That's actually a bug with the game itself & not an issue with dependencies - for some reason the player character occasionally drowns before surfacing. Only thing to do is start a new game & try again.
Oh well, ok! Sadly the game is still highly unstable, frequently quitting with a Windows message of 'Serious errors were encountered' or alike. On the terminal I see a long stream of messages, I tried to filter out the most important:

wine: Unhandled page fault on read access to 0x00000000 at address 0x6a556f63 (thread 002d), starting debugger...
...
006b:fixme:dbghelp:elf_search_auxv can't find symbol in module
Unhandled exception: page fault on read access to 0x00000000 in 32-bit code (0x10e0698b).
006b:fixme:dbghelp:elf_search_auxv can't find symbol in module
Register dump:
CS:0023 SS:002b DS:002b ES:002b FS:0063 GS:006b
EIP:10e0698b ESP:4346fb8c EBP:4346fc04 EFLAGS:00010246( R- -- I Z- -P- )
EAX:00000000 EBX:00000001 ECX:01373d44 EDX:4346fbc8
ESI:00000400 EDI:00000400
...
18 0x7bcb54a9 call_thread_func+0xd8() in ntdll (0x4346ffdc)
19 0x7bcb0766 call_thread_entry+0x9() in ntdll (0x4346ffec)

any ideas?!
Post edited April 28, 2019 by tensionhead
Ok, I installed mdac28, vcrun2010, vcrun2012, jet40 via the wrapper provided winetricks. Now it runs much better and I actually progressed to the 1st fight!

Update: Right after I went back to the game it crashes after 2-3secs. It's quite a ride I have to say :|

I changed screen resolution before quitting it last time.. but other than that no idea what's going on. New errormessage:

006b:fixme:dbghelp:elf_search_auxv can't find symbol in module
Unhandled exception: page fault on read access to 0x00000000 in 32-bit code (0x6a556f63).
006b:fixme:dbghelp:elf_search_auxv can't find symbol in module
...
Backtrace:
=>0 0x6a556f63 EntryPoint+0x15bb3() in d3d11 (0x0053f988)
1 0x6a5494fa EntryPoint+0x8149() in d3d11 (0x0053fa50)
Post edited April 28, 2019 by tensionhead
Hopefully final update, I reinstalled the dxvk drivers via the respective menu from the wrapper.. now everything runs fine again.
Post edited April 28, 2019 by tensionhead
It shouldn't be necessary to install anything into the prefix other than what's already installed by the wrapper build script; the BioShock remasters are well known for being a bit buggy & unstable so the crashes are likely just due to that (although it could also be a GPU/driver-specific issue - I use an AMD GPU in my main system)
Hi ! I just signed in to post in this topic, obviously big fan of your work on those wrappers, makes everything a piece of cake, was wondering, is there a bit of expertise that you could provide into making a wrapper for Battlefront 1 and 2 ? Both have a strange bug that makes them only playable on a very specific version of Wine that has hybrid sync built in. I wanted to build my own wrapper since a year but came to nothing conclusive. Thought this might just be the place to start this again at.
hello, i was wondering what is the difference between your system shock 2 wrapper and the one on ./playit.? since system shock 2 works, do you think thief gold and thief 2 will be playable too?