It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
The issue here is that I have all of wine's dependencies and optional dependencies , btw I am on antergos ( basically arch) , But I guess I will just have to make my own ....
avatar
lukadominiek: The issue here is that I have all of wine's dependencies and optional dependencies , btw I am on antergos ( basically arch) , But I guess I will just have to make my own ....
It's likely that some update to Arch has broken compatibility with it then. It might work with a newer version of Wine... I'm planning to update my wrappers to 3.0/3.0-staging when that's ready, but until then you could try it with 2.21-staging instead and see if that works any better:

- Download https://dl.winehq.org/wine/wine-mono/4.7.1/wine-mono-4.7.1.msi and place it in ~/.cache/wine
- Run the wrapper build script as so: WRAP_WVER=2.21-staging ./falloutnv_wine.sh
You people make it way too complicated! Or is that me? I use Arch as my main OS and do not even own Windows. This game and many others runs perfect in PlayOnLinux using Wine 2.8 64-bit! Here's the catch though. I run a Debian 9 KVM on Arch and my NVIDIA card is attached to the VM, Arch does not have access to it. I use the graphics in my Intel I7 for Arch since I don't play games on it. This to me is the perfect setup because I can backup all of it and I can restore it when needed.
Post edited January 10, 2018 by flugalgourmet
Complicated? Aside from installing dependencies (which you'll have to do anyway):

- Put all the files in one place and run the falloutnv_wine.sh script to assemble the wrapper (and move the resulting directory wherever you want the game installed to, if it isn't there already)
- Run start.sh to play. Saves & settings will be stored in the user's home directory (or optionally in the wrapper's root directory if a "userdata" directory is created there)

Installing and using mods, third party tools etc will require additional steps, but again that'll be necessary either way.
Post edited January 10, 2018 by adamhm
On the latest non staging version of wine the game works fine .... , I beat the first dlc honest hearts with it.
All though it crashed sometimes and has weird white pixels flashing sometimes .... maybe I have to try your way sometime again :D
Anyone know how to get the Original Fallouts running on Mac? just bought fallout 2 and can't figure out how to use Wineskin to run install and run it
Good Day,

I'm using Debian Sid and with the recent update to Wine 3.0, I had to have a look in the Wine configuration to fix new errors occuring at runtime, usually triggered by selecting the Mojave music radio.

Concerning my Fallout New Vegas environment, I run it with Wine's virtual desktop activated, I use a GPU with the radeon driver provided by my distribution, and everything is working well, modulo the fact that:
- with Wine 2.0.4, I had to disable winegstreamer for proper game execution,
- with the upgrade to Wine 3.0, I also had to disable mshtml and mscoree.

I am testing these settings in a clean Wine prefix at the moment to ensure the modifications are necessary, sufficient and working (virtual desktop seems necessary in my case), as I tidied a bit my main prefix with Winetricks. B-)
So far, so good... I hope this helps if anyone is running into troubles.

Cheers!
Was able to get NV to install on a laptap. I ubuntued a desktop and have been trying to install it there, but running into problems. The install finishes with:
Moving files into place...
Archive: ./Fallout New Vegas/temp/app/webcache.zip
inflating: ./Fallout New Vegas/temp/36f4133ab2301d0ebd076123f233b28b27b4edb177ec11e1c6ecdca4d2aa6fd7.png
./Fallout New Vegas/temp/app/FalloutNV.ico: clr_important field in bitmap should be zero
./Fallout New Vegas/temp/app/FalloutNV.ico: clr_important field in bitmap should be zero
./Fallout New Vegas/temp/app/FalloutNV.ico: clr_important field in bitmap should be zero
./Fallout New Vegas/temp/app/FalloutNV.ico: incorrect total size of bitmap (72517 specified; 16936 real)
./Fallout New Vegas/temp/app/FalloutNV.ico: skipping 55581 bytes of garbage at 81330
./Fallout New Vegas/temp/app/FalloutNV.ico: premature end


Now, I was able to do 'start.sh', but it crashes when tryng to play the game, so I figure something didn't get installed right.
avatar
bignickel1: Was able to get NV to install on a laptap. I ubuntued a desktop and have been trying to install it there, but running into problems. The install finishes with:
...
Now, I was able to do 'start.sh', but it crashes when tryng to play the game, so I figure something didn't get installed right.
Those messages are normal (just processing the game icons & icotool skipping irrelevant data in the icon files).

What exactly happens when you run the game (open a terminal in the wrapper directory and run start.sh from there to check the terminal output)?

Also what are the system specs and which Ubuntu version are you trying to use & have you installed the system's Wine package to ensure that you have all required dependencies?

If you're using an Nvidia GPU you should install the proprietary drivers; otherwise you should make sure that your kernel and Mesa are up to date.
Sorry for taking so long to get back. The error was along the lines of "this program has stopped working" or such, but it never displayed the full error message after I tried switching video drivers.

The system is an AMD athlon II 1700 processor, with Nvidia Geforce 6150SE graphics chip, running Ubuntu 16.04.
Wine was installed, and gave no dependency messages. When installing Fallout, it would give me dependency messages, I would install the dependency, and then try again, until it installed with no dependency messages.

The system was using x.orgxservnouveaudesplaydrvier from xerver-xorg-video.nouveau. I switched it to 6150 nforce 430 unsing nvdiia legacy binarydriver 304.135. At that point, the game wouldn't give the technical details when crashing.

I installed MESA, and then tried installing a more 'uptodate' nvidia driver: that made the machine go into a permanent login loop. I've had to reinstall the whole OS. At the point, I'll see what I can come up next in terms of getting it to work
avatar
bignickel1:
Sorry :-( but do you really expect to be able to play 3D games many years newer to your integrated graphics chip?!

Copied system requirements:

Minimum system requirements - Windows: 7 / 8 / 10
Processor: Dual Core 2.0GHz
Memory: 2GB RAM
Video Card: NVIDIA GeForce 6 series, ATI 1300XT series
Hard Disk Space: 10GB free space
Mouse, Keyboard

Those are for standalone graphics cards and with rock bottom settings.
On an unrelated note, does anyone know where fallout_default.ini is located? I’m trying to turn off mouse acceleration when using pipboy.
avatar
bignickel1: On an unrelated note, does anyone know where fallout_default.ini is located? I’m trying to turn off mouse acceleration when using pipboy.
It's in the game directory. I'll be fixing this in the next update :)
(I'm also planning to update the wrapper to Wine 3.11-staging, assuming that there have been no regressions)