It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
I have constant flickering on Windows 10 as well.
I had the problem with no movies and no cursor, making the game uplayable on Windows 10. I played around with the program compatibility settings and got it to work.

Go to C:\Program Files (x86)\Dracula...
Right click the Dracula3.exe file
Select the Compatibility tab

I used these setting:

Run as Windows Vista
Reduced color mode to 16-bit
Disable fullscreen optimizations
Run as administrator

I also turned off vertical sync in Nvidia control panel. That can reduce flickering.
The flickering can be reduced a bit by turning off vertical sync in Nvidia control panel.

Some scenes cause flickering in the inventory screen. Fortunately there are enough places where it is stable so you can make progress. I wonder if this will hold until the end. I'm more than half way through now so I suspect it will be OK.

The game is playable but the flickering and other graphic issues drain it of drama. It is a story that depends on atmosphere. How can you believe in it if the images jump around?
Post edited October 01, 2018 by Timotek
Works fine with dgVoodoo WIP56 (only D3D9.dll and D3DImm.dll needed) on Windows 10 x64.
Attachments:
proof.jpg (101 Kb)
avatar
Zyankali: Works fine with dgVoodoo WIP56 (only D3D9.dll and D3DImm.dll needed) on Windows 10 x64.
Just to add an update to this topic:

Current dgVoodoo2 version is dgVoodoo v2.55.4.1 - for regular usage (released: 01.03.2019)

To specify:

you need the navigate to the dgVoodoo/MS/x86 (32-bit dll versions(!) even on your 64-bit Win10 OS!) folder and copy

D3D9.dll
D3Dlmm.dll

into your Dracula 3 folder.

Switch to fullscreen by editing

bFullScreen=1

And start the game via GOG Galaxy or GOG Shortcut.

Suddenly, the game logo and intro video will run smooth as butter in fullscreen and the game mouse will become visible in game!
I had the same problems, screen flickering, no cursor etc. For me it works with changing only compatibilty mode for All users to
Windows XP SP3
deactivate full screen optimization
and run the game as administrator.

I have also set NVidia control panel back to default as mentioned in an earlier post and excluded it in the Windows Defender Firewall.

Config needed also to edited to run the game in fullscree mode.

Game seems to run smooth, cursors and fonts are visible.

I have an Intel I5 4670 CPU and a NVidia GTX 1070.
Post edited May 29, 2019 by Calis85
This seems pretty esoteric, but the game ended up working for me, so here is what happened.

When I installed the game, the only way I could get it to work with severe stuttering and slow down was to "deactivate full screen optimization" in the compatibility tab and running the game in fullscreen. Despite trying several of the methods here, I never seemed to be able to get anywhere.

I uninstalled the game, updated my drivers, and set "run as administrator" for GOG Galaxy. The game still had the same issues as before, so I also tried setting affinity for the CPU cores. This time around, when I set the game to fullscreen and deactivated full screen optimization again, the videos would run smoothly, but the game would have issues with ghosting the cursor, not displaying certain UI elements properly, etc. Also, I can't say if CPU affinity was relevant at all, since afterward leaving it as normal still had the game running in the same manner.

Downloading dgvoodWIP again (http://dege.freeweb.hu/) (latest version was 60 at the time of me posting this) I finally managed to get this to work. Worth noting that the config.exe of dgvood was identified as a virus, and I had to manuever around that in order to change some settings to remove the watermark and other stuff.

I would say the most relevant things for me would have to be driver updates and running galaxy as the admin, but I can't say for sure. I hope this can be helpful, at least to some of you guys.