It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I can hear the intro playing, but game window stays black, no graphics at all.
Tried all imaginable compatibility options, installed DirectX packages - nothing works.

Any ideas?
No posts in this topic were marked as the solution yet. If you can help, add your reply
Did anyone manage to run D3 on Windows 10?
I just discovered this issue, any fix for this yet?
Full screen? Try to edit the ini-file in the game folder to play it in windowed mode.
I have the same problem. The default is windowed. I tried changing it to fullscreen but it didn't help.
I have the same problem. I can hear the sound but no image. Also, there is no cursor in the game and the inventory is not showing. Full screen or windowed makes no difference. Cannot install DX9 since it is too old, but it is supposed to be compatible anyway.
I will try to see if I can get it running in a XP virtual machine.
Initial black screen for me, I can load my save but then everything behaves weird. Clicking freezes the game. It's basically unplayable on my Windows 10 system.
Post edited January 18, 2016 by tsagas
I tinkered through several settings between integrated and Nvidia and I cant get it to be playable. If I use integrated I get the intro up to the title card and that's screen and music from there on. If I use the Nvidia card I don't get the intro and I can get into the game but the overlays are gone and you cant really do anything besides move around and click a few things. So basically unplayable right now.
I contacted gog's support. Here are a few things they told me to try out (none of them solved the problem, but I'm copy-pasting them for future reference):

Please try these troubleshooting steps:
1) Please make sure that you use "Run as Administrator" to install and to start the game (right-click on the shortcut or setup file and select "Run as Administrator"). If you are using Galaxy, then make sure to run Galaxy as Administrator.

2) Please reinstall the game AND add it to your anti-virus/firewall software's exception/trusted list. Simply disabling firewall or AV software could not be enough, since some of these software are running still in background or in services list. If you are using Galaxy, then please add Galaxy as well.

3) Reinstall the June 2010 DirectX runtime package. You can find the archive file containing the 2010 package installation files here:

After that please download and install the DirectX Web Installer:

You will have to extract the files into some folder, then open that folder and launch the DXSETUP.exe file in order to proceed with the installation.

4) Maybe you have some settings forced on your graphics device in NVidia Control Panel. If so then try to reset them:
I) Right-click on your desktop and select Nvidia Control Panel.
II) Click Manage 3D Settings.
III) In the upper-right corner, click Restore Defaults.

5) Try disabling DSR:"

and from a follow-up mail:

"Please make sure that no third-party applications are interfering with the game. Please try to install and run the game in “clean boot mode”. Instructions on how to do that can be found here:
Make sure the account you create for clean boot mode is granted Administrator privileges."
Post edited January 20, 2016 by tsagas
We need a fix for windows 10
Just to throw out some not really helpful info...

I had the same issue with windows 10 with the cut scenes slow/choppy/not really playing and then screen flickering inside the game with the inability to bring up the right clicked menu.

I also own a copy on DVD (that came with the first two games as a bonus). With that copy the opening and cut scenes worked fine but I still had the flickering and right click menu not working.

Reverting back to windows 8.1, I was able to open the GOG version just fine with everything working the way it should.
Can confirm I have exactly the same problem. Game is completely unlayable in widows 10. Has anyone found a fix on this?
Is it possible to request a FIX to GOG???????
I contacted GOG support and got more or less the same response mentioned a few posts earlier. Aparently they can't reproduce the problem in their windows 10 PCs. Tried again everything suggested but the problem persists. Hopefuly someone may find a working fix down the line. In the meantime I would urge everyone who has the same problem to contact support so that they understand it is a real issue.
Post edited April 03, 2016 by Castledoque
Its not a complete Windows 10 issue, its the grafix card and Windows 10!

I can play it with a trick fine in Windows 10, but my friend not! I have a GTX 555, my friend a 760 GT!