It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
high rated
avatar
rjbuffchix: Oh whoops, my apologies for the oversight. I guess I should've known better than thinking that was a dev post, haha (since we see users documenting changes themselves rather than always hearing from devs).
You could try to reach Larian with this e-mail : support@larian.com

I alrealdy tried : the result isn't really good if you ask me :

Larian washes their hands about the offline installer & offline patches, because it's a GOG's "issue" and GOG's support reply is : there's a "technical issue".....(since the launch of the definitive edition)....So i don't trust GOG at all and it's totally lame.....
Post edited October 18, 2018 by DyNaer
high rated
Changelog for Update Hotfix v3.6.31.2130 (added 18 October 2018):

Hi Everyone,

Our support team flagged a few urgent issues, so we are releasing a second hotfix to address them. Thanks to the detailed information sent in by community members, we were able to quickly track down and fix them!

Larian Crew

- Fixed Alexandar, Han and Sergeant Zrilla being hostile towards the player on the Lady Vengeance
- Fixed infinite loading screens for specific savegames
- Fixed issues with automatically unlocking the third Source Point under certain conditions. Unfortunately, this fix is not retroactive. Savegames that already have the third Source Point unlocked should be able to progress without issues, and the unlocked Source Point will not be removed by this fix.
high rated
avatar
rjbuffchix: Oh! Now I recognize your name! You post in the update topic!! Thank you for all the hard work there!
Cheers, but your thanks are misplaced; it's muntdefems and WinterSnowfall who (basically) do all the hard work, and deserve all the credit.
avatar
MechBFP: The gigantic nameplates that appear in combat are absolute garbage. What the hell were they thinking?!
They thought about hires TV's.
That problem goes back to original DOS2. No reply from devs on that mattter were received back then.
high rated
For those who expect a patch one day or another, don't wait at all : Right now the support reply is " dues to technical limitations, it's not possible to offer separate offline patches because the game size has doubled & each patch = downloading the game by itself"

It's more or less a translation from the reply i received, so don't shoot the messenger ;...

This is really a terrible excuse.... :-(

So either you d/l 45 GB at each buld (a minor or a major one) either you use the client.....in the end the former isn't really a solution....so it's clearly force users to install the client.....
Post edited October 19, 2018 by DyNaer
high rated
Changelog for Update Hotfix v3.6.32.1810 (added 08 November 2018):

Hi Everyone,

Our latest update is now live. This update fixes a known crash for some users and adds extra logging information to help us make your game experience even better.
Please keep reporting any issues you may have.

Larian Crew
high rated
Obviously, my rant to the support was successfull :P

Now a patch is avaible to patch the offline version of the game (from previous build -> to the latest one)

I hope this will continue.

11 MB vs 45 GB+ erm....that's a big difference.
high rated
Changelog for Update v3.6.32.4166 (added 16 November 2018):

* Fixed game crash after DXGI_Error_DEVICE_Removed
* Fixed issues related to changing display modes in graphics options
* Fixed Windows 7 compatibility issues
* Fixed DirectX errors related to 144hz screens (also gave DXGI_Error_Device_Removed error)
* Fixed alt-tab stability issues
* Fixed crash on startup related to graphics settings
* Fixed Fake Fullscreen resolution issues
Post edited November 16, 2018 by T_a_J
Changelog for Update 3.6.33.2684 (added 05 December 2018) - Part I:

Hi everyone,

The latest update for Divinity: Original Sin 2 - Definitive Edition is now live!

If you've been looking for new ways to create Static Cloud Arrows, Explosive Arrows, or grant immunity to Madness we have you covered with new recipes in this update. It's easier to be Sir Lora's shield now that he's ignored by Shriekers and your battles will be easier to navigate thanks to notifications in combat being moved up. We've also addressed issues with the combat log.

Enjoy your adventures throughout Rivellon!

And if you're interested in how Divinity: Original Sin 2 came to be, there's a making of documentary here: https://www.youtube.com/watch?v=A_wKAmBEa8Q

Larian Crew

Full patch notes below:

Updates:
- More than 15 items in the barter window are now allowed when using a controller
- The correct DOS2 edition launches automatically when receiving a multiplayer invite instead of having to manually select it in the launcher
- Moved notifications to allow better visibility during combat
- Party members now run through non-damaging surfaces like oil and ice automatically
- Dimensional bolt now correctly heals undead when rolling poison damage
- Lohse can no longer bypass the Doctor's possession by wearing an Immune to Charmed item
- Summons no longer teleport together with their masters in Arena Mode
- Tentacle lash is no longer affected by low ground penalties
- Worm tremor no longer entangles undead characters when they have active magic armor
- The unique gloves Soft Touch now allow the wearer to cast Healing Tears instead of setting the status directly
- Sir Lora is now ignored by Shriekers
- Added 5 per cent accuracy and dodging bonuses for players in Story Mode to match Explorer Mode. Also decreased Story Mode NPC's accuracy by 15 per cent
- The Apotheosis tooltip now mentions the increased primary attributes
- Reallocated Radeka's attributes in the Arena to have more points in Wits, making her Savage Sortilege talent more useful with a new Critical Chance of 8 per cent
- Potions of Strong Will and Cryogenic Stasis now provide immunity to Madness
- Added new recipes:
- Stunning Arrowhead + Well = Static Cloud Arrowhead
- Stunning Arrow + Well = Static Cloud Arrow
- Stunning Arrowhead + any source of water = Static Cloud Arrowhead
- Stunning Arrow + any source of water = Static Cloud Arrow
- Steamcloud Arrowhead + any air essence = Static Cloud Arrowhead
- Steamcloud Arrow + any air essence = Static Cloud Arrow
- Fire Arrow + Any oil source = Explosive Arrow
Changelog for Update 3.6.33.2684 (added 05 December 2018) - Part II:

Bug Fixes:
- Fixed windows7 specific issue when changing vsync settings
- Fixed a crash on start-up related to cloth settings. Added a ClothGPUAcceleration option in the graphicSettings.lsx file for users experiencing issues with this
- Fixed Fake Fullscreen always using the desktop resolution. It should now allow resolutions lower than the native resolutions.
- Fixed not being able to write to network paths on start-up (Failed to create dir:\ error)
- GM: fixed several minor visual and gameplay issues with The Dark Eye campaign
- GM: added default music settings to The Dark Eye campaign
- GM: fixed lighting issues when loading a level with default atmosphere
- GM: fixed a crash related to changing levels right after changing the atmosphere
- GM: fixed item generation levels being incorrect when using keyboard input
- GM: fixed a visual issue in the Character Creation screen for clients after a party reroll
- Fixed an issue with changing graphics options and pressing the close button
- Fixed an issue with clients connecting to hosts with several mods installed and enabled
- Fixed inactive quests not being hidden correctly in the journal
- The correct Game Edition is now automatically launched when receiving an invite
- Fixed tooltips sometimes not fitting on the screen
- Fixed the launcher buttons not being visible on certain machines with a specific combination of display scaling and Windows versions
- Drag and drop is now cancelled when switching characters during combat to avoid issues and exploits with summons
- Fixed the combat log not automatically showing the latest entries
- Fixed a rare crash when opening and closing the same dialogue many times in a row
- Fixed not being able to progress to Act Three due an issue with Malady's dialogue
- Fixed a crash related to taking shared gold from a dead party member (when buying resurrection scrolls, for example)
- Fixed a rare crash related to video playback
- Fixed a crash when trading a large amount of items
- Fixed a crash related to receiving the Eternal Blade
- Fixed certain mods causing a blocker with Malady's dialogue when trying to go to Act Three
- Fixed a Game Over message appearing in rare cases during the endgame dialogue. The epilogue should now show correctly.
- Fixed not being able to talk to Saheila anymore after escorting her to the camp
- Fixed Corbin not teleporting to the Lady Vengeance correctly
- Fixed a memory and performance issue when AI needs to evaluate too many barrels during combat
- Fixed Malady incorrectly starting The Weakening event on the Lady Vengeance
- Fixed a visual issue with the inventory after using the Shapeshifter Mask
- Fixed an issue with the Seven Altars achievement
- Fixed Almira disappearing if players were doing her quest in two separate parties
- Fixed an alignment issue with Zaleskar and Sergeant Zrilla on the Lady Vengeance
- Fixed multiple players being able to use the same consumable at the same time
- Fixed an issue with the Bard's dialogue in Arx when one player character has already tried to pay him
- Fixed not being able to do certain actions in the inventory after dismissing a party member
- Fixed certain tooltips reserving empty space, which made them larger than necessary
- Fixed combat continuing after escaping the secret room in the Lady Vengeance
- Fixed an issue with teleporting party followers when freeing Saheila after the fight with Roost
- Fixed not being able to cast certain spells in the tutorial after loading a savegame from the main menu
- Fixed not being able to cast spells by opening the skill hotbar
- Fixed surfaces re-appearing incorrectly after saving and loading
- Fixed several portraits not being rendered correctly for specific NPCs
- Fixed not being able to click on the top left blocks of the pipe puzzle in Arx
- Fixed not being able to rejoin an ongoing Arena match in some cases
- Fixed certain items floating in the air after stacking and destroying other items beneath them
- Fixed infinite loading screen when connecting to a lobby that no longer exists
- Fixed an exploit that allowed players to take a trader's gold in controller mode
- Fixed Traditional Chinese being labelled incorrectly in the launcher
- Fixed vibration being reset to zero after opening the audio menu
- Fixed selection issues in the skills interface after memorizing or forgetting a skill
- Fixed an issue where player 1 could affect the interface of player 2 in split screen during combat
- Fixed container interface not closing when switching characters
- Fixed the Toggle Info button not working correctly in the Actions menu
- Fixed the Lone Wolf Talent not taking the skill cap into account in Character Creation
- Fixed the map filter on the lobby screen
- Fixed item rotation when using the shoulder buttons on a controller
- Fixed an issue with getting stuck when refreshing the list of lobbies
- Fixed an issue with cancelling lockpicking in stealth also cancelling stealth
- Fixed incarnates not teleporting correctly when using gateways or waypoints
- Fixed an issue with characters still being in the Magic Mirror during a level swap
- Fixed summons not getting the correct music instrument assigned if summoned out of combat
- Fixed the dialogue interface being displayed incorrectly when clients in hotseat mode would connect to an ongoing multiplayer game
- Fixed the amount of available talent points not updating correctly
- Fixed the saving progress icon not being displayed in some cases
- Fixed the map interface not updating correctly when switching characters
- Fixed weapon shadows appearing when certain enemies are invisible
- Fixed armor values not updating correctly when equipping an armor piece
- Fixed Oil Voidlings constantly exploding and being healed during combat
- Fixed the camera not following the player characters correctly in Wrecker's Cave
- Fixed portraits not updating correctly after using the Shapeshifter Mask
- Fixed selection looping from bottom to top in several interfaces
- Fixed a selection issue in several interfaces after closing tutorial messages
- Fixed the inventory being stuck in a locked state if the player opened it during a dialogue
- Fixed an issue with entering combat incorrectly when stepping onto a party member's surface
- Fixed all NPCs reacting to selling the Djinn's amulet in Reaper's Coast
- Fixed Dallis not being able to use ladders correctly in Arena Mode
- Fixed Sir Lora teleporting to the wrong location in the Arena of the One
- Fixed Almira's source point quest not closing correctly
- Fixed Veiled Undead status not being restored correctly after being resurrected
- Fixed an issue with the Playing Dead status being stuck on Fane when the party is teleported to the Lady Vengeance for the first time
- Fixed Sir Lora not following the party anymore in certain conditions. Talking to him again should fix current savegames
- Fixed multi-select not being deactivated correctly when closing a container
- Fixed Almira not following the party anymore during her escort
- Fixed crime investigation not stopping after a successful bribe
- Fixed Ryker's Mansion hatches not being opened the first time, even when the player has enough strength
- Fixed voidwoken hatchlings near Peeper counting towards the player's Villain tag
- Fixed enemies receiving a killing blow from Lavafall in Arena mode
- Fixed Hannag's quest not closing correctly if she dies as Hannag reborn
- Fixed the Lost and Found quest journal not closing correctly when moving on to the Nameless Isle
- Fixed the Death Belowdecks quest not updating correctly when Magister Waters is dead
- Fixed Magister William sometimes surviving Windego's Source Blast
- Fixed starting equipment Threadbare Gown not being shown correctly on undead lizards
- Fixed the Damaged Oil Pump not accepting the correct lever combination after failing it at least once
- Fixed Magister Reed not always reacting correctly to attacking Higba
- Fixed projectiles not doing any damage on certain spots of several arena maps
- Fixed several smaller visual issues with terrain all over the game
- Fixed the Arx Destroyed ending movie not playing correctly
- Fixed not being able to trade with Papa Thrash when he invites Beast to the undertavern
- Moved status icons up slightly in Chinese and Traditional Chinese languages to improve readability
- Fixed not being able to poison all types of fish
- Fixed attributes not going over 30 inside the Magic Mirror when they should go up to 40
- Fixed the controller point being visible in the Magic Mirror
- Fixed the readability of the text in the Teleporter Pyramid's interface
- Fixed the selector not being in the correct place near your player character at the start of a turn in Arena Mode
- Fixed certain summons taking minor magic damage from the surface they were created from
- Fixed traps on the Source Bridge in Reaper's Coast staying invisible even when stepping on them
- Fixed move action not being cancelled when activating the hotbar
- Fixed an issue related to crimes and areas being in alert mode while having Sir Lora in your party
- Fixed Gheists reacting to crimes committed near them while they should not be able to talk
- Fixed the borders of all arena maps
- Fixed several minor sound issues
- Fixed several minor interface readability and usability issues
- Fixed several minor level design and item placement issues
- Fixed certain texts being cut off in French, Spanish, German, Russian, Chinese and Traditional Chinese
high rated
Changelog for Update 3.6.33.5509 (added 07 December 2018):

Hi everyone,

We have released a new update today to fix a crash (or black screen), that could occur when starting or alt-tabbing the game for a small percentage of our Windows 7 users.

Please keep reporting any issues you encounter.

Larian Crew
high rated
Changelog for Update 3.6.35.8270 (added 31 January 2019):

Updates:
- The Kraken is now immune to Chicken Form to avoid breaking certain animations
- Cursor-Focused Movement is enabled by default when creating a profile
- The Resurrection Idol can be chosen only once, and henchmen can no longer do the related quest
- Teleporter Pyramids are no longer removed from the inventory after the Wellspring is destroyed
- Targh now has the Troll Blood status
- Crispin no longer joins combat with NPCs

Bug Fixes:
- Fixed a crash when loading savegames that were made with preset mods enabled
- Fixed a rare crash related to using a Razer keyboard and trying to connect to host in multiplayer
- Fixed a crash when using Magic Mirror from Active Search as the second player in split screen
- Fixed a crash when loading a save or starting new campaign in Simplified or Traditional Chinese
- Fixed a crash happening when using a gamepad to close the level-up confirmation message
- Fixed an issue with lobbies timing out instead of closing when the host leaves
- Fixed status modifiers on weapons disappearing after saving and loading
- Fixed some corpses not showing up as Empty after getting looted
- Fixed summons occasionally spawning without the correct buff on stats
- Fixed incorrect party alignments when attacking Tarquin
- Fixed Dallis’ dragon transformation when leaving Fort Joy
- Fixed Dallis not having the correct weapons in later acts if defeated at Fort Joy
- Fixed the Vault of Braccus Rex quest not closing correctly after Act One
- Fixed the Burning Pigs quest not closing when all pigs are killed
- Fixed Mona’s reaction to her Diseased status being healed in certain conditions
- Fixed being able to avoid combat with Andras after leaving the Crypt
- Fixed the corpse in the elven encampment being moveable
- Fixed an issue with the placement of eggs in Wrecker’s Cave
- Fixed an issue with missing trap feedback on the Source Bridge
- Fixed the crafting menu not closing after combining a Broken Lever with a Silver Level Shaft
- Fixed another player being able to receive the reward for the Murderous Gheist quest while in a different party
- Fixed ghosts’ behaviour after the ritual is stopped in Ryker’s Mansion
- Fixed Sebille not leaving with Shadow Prince after Mother Tree is killed
- Fixed the reactions of kids and Ryker’s servants to being pickpocketed
- Fixed Barin not fleeing the scene after being teleported to the boat
- Fixed an issue with the Evasion Aura skill status icon appearing infinitely
- Fixed characters never ending their turn if provoked on a hazardous surface
- Fixed Sebille refusing to teach the scar song despite having a good relationship with the player
- Fixed the Mask of the Shapeshifter not working in the epilogue
- Fixed the possibility of getting stuck in an endless fight with Beast during the epilogue
- Fixed the map marker not being highlighted when the player clicks ‘On Map’ in the journal
- Fixed the assault on the Lady Vengeance quest occasionally being completed even if all playable characters are dead
- Fixed an issue where cancelling lockpicking with the controller caused players to leave stealth
- Fixed an issue with the display map showing up as black when a second player joined an ongoing session in split screen
- Fixed issues caused in the final fight if an ally is encumbered
- Fixed an issue with skill casting not cancelling when dismissing a tutorial popup
- Fixed Time Warp giving two extra turns instead of one when used during a delayed turn
- Fixed an issue with crafting poisoned food and drinks using objects that are already poisoned
- Fixed a rare issue with being unable to join the fight for Divinity when loading savegames
- Fixed shapeshifted Fane being unable to solve the puzzle in Lucian’s Tomb
- Fixed Beast being unable to fight in ambushes if the player doesn’t speak to him at the start of Act Two
- Fixed Source Puppets getting stuck in an incorrect state after being summoned
- Fixed a feedback issue when trying to identify objects with insufficient AP
- Fixed the journal entry for A Lizard Nightmare quest
- Fixed an issue with two Ascending companions not entering combat if the player chooses to not become a new Divine
- Fixed Wind-up Toys spawning twice after the wedding cake is attacked
- Fixed a rare issue with Waypoints becoming unusable in Honour Mode
- Fixed an issue with player characters sometimes getting stuck in dialogue mode
- Fixed Gareth not appearing on the Lady Vengeance if all the Seekers are killed in Fort Joy
- Fixed the content menus in crafting not appearing if the player interacts with an object or NPC while it’s open
- Fixed the player character losing the ability to speak to NPCs after pickpocketing someone in Fort Joy
- Fixed Alexandar sometimes getting stuck at Fort Joy’s gates and not appearing at the end of Act One
- GM: Fixed a crash related to changing atmosphere when four clients are connected
- GM: Updated books containing placeholder text at the start of The Dark Eye campaign
- GM: Fixed stats for the Source Titan
- GM: Fixed several minor gameplay issues in The Dark Eye campaign
- GM: Fixed camera bounds on the Demon Ark in The Dark Eye campaign
- GM: Fixed containers not opening and closing correctly in certain situations
- GM: Fixed issues with the GM’s ability to add and move items in character inventories
- GM: Fixed hotkeys for Skill Panel, World Map, and journal when possessing a creature
- GM: Fixed the display of skills in the Spellbook after selecting monster skills
- GM: Fixed an issue with the level loading incorrectly for the first player if they confirm in Character Creation but the second player leaves the game
- GM: Fixed an issue with opening the Custom Stats tab with a gamepad
- Fixed an issue with text overlapping and getting cut-off in German and Russian
- Fixed minor issues in dialogue and text
- Fixed several incorrect or missing icons for objects and talents
- Fixed minor issues with skill casting effects and animations
- Fixed missing or incorrect portraits for several NPCs
- Fixed many interface readability, usability, and control issues
- Fixed minor texture and item placement issues
- Fixed certain animation and pathfinding issues
- Fixed several minor sound issues
Spacebar doesn't close an already empty container. Escape works, as a work around, or just use your mouse. Sometimes enemy pods don't all attack the player. Just the ones in direct sight. That's all I've noticed so far.
avatar
distantdarnoc: Spacebar doesn't close an already empty container. Escape works, as a work around, or just use your mouse. Sometimes enemy pods don't all attack the player. Just the ones in direct sight. That's all I've noticed so far.
I have noticed the same problems. I thought they were caused by mods but obviously not if other people have the same problems.
avatar
distantdarnoc: Spacebar doesn't close an already empty container. Escape works, as a work around, or just use your mouse. Sometimes enemy pods don't all attack the player. Just the ones in direct sight. That's all I've noticed so far.
avatar
TheFonzz: I have noticed the same problems. I thought they were caused by mods but obviously not if other people have the same problems.
looks like an update went through to fix the ai problem. It's not because of mods since it's my first playthrough and am not using mods.