It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
@jnisbet:

No, I already use the newest versions of dgvoodoo and the patch, dgvoodoo 2.54 and the newest patch from pcgamingwiki entry.
I have tried everything and I still can't get it to work. Ive had to run it through DXWnd as its the only way I can get it to work and let me select 3D.. But I always get the "can't load level" error when starting singleplayer. However multiplayer loads up fine! correct enhanced edition models etc..

I've been fighting with it for 3 days. Any help would be appreciated!
avatar
ghastlymelodies: I have tried everything and I still can't get it to work. Ive had to run it through DXWnd as its the only way I can get it to work and let me select 3D.. But I always get the "can't load level" error when starting singleplayer. However multiplayer loads up fine! correct enhanced edition models etc..
I'm surprised that DxWnd is the only thing that works for you. Do you happen to have an AMD graphics card? If so, you might try the AMD fix (3rd option), though I think that it may be an outdated, unnecessary fix nowadays.

As for the "can't load level" error on single player, try deleting your in-game profile and creating a new one. Also, did you happen to install the High Detail Mod? If so, try re-installing that. If worst comes to worst, re-install the game and add patches, fixes and mods one by one, testing between each one.
Post edited August 30, 2018 by jnisbet
avatar
ghastlymelodies: I have tried everything and I still can't get it to work. Ive had to run it through DXWnd as its the only way I can get it to work and let me select 3D.. But I always get the "can't load level" error when starting singleplayer. However multiplayer loads up fine! correct enhanced edition models etc..
avatar
jnisbet: I'm surprised that DxWnd is the only thing that works for you. Do you happen to have an AMD graphics card? If so, you might try the AMD fix (3rd option), though I think that it may be an outdated, unnecessary fix nowadays.

As for the "can't load level" error on single player, try deleting your in-game profile and creating a new one. Also, did you happen to install the High Detail Mod? If so, try re-installing that. If worst comes to worst, re-install the game and add patches, fixes and mods one by one, testing between each one.
Thanks for the reply! I have tested at every step and nothing seems to work. This is as far as I get.

If I run without DxWnd, I can get JKE to run but I can't get 3d acc to work. So I can see the new models etc from JKE but all the textures are corrupted, multicolour blobs. This is as far as I can get, Ive followed sooo many tutorials now.

Usually I have no problems doing this on other old games but, JK is being so stubborn.

I didn't download the high detail mod yet, I was actually trying to get this to run first.
avatar
ghastlymelodies: Thanks for the reply! I have tested at every step and nothing seems to work. This is as far as I get.

If I run without DxWnd, I can get JKE to run but I can't get 3d acc to work. So I can see the new models etc from JKE but all the textures are corrupted, multicolour blobs. This is as far as I can get, Ive followed sooo many tutorials now.

Usually I have no problems doing this on other old games but, JK is being so stubborn.

I didn't download the high detail mod yet, I was actually trying to get this to run first.
Yes, JK is very stubborn and requires a lot of work. Have you found and followed my guide in the 3D acceleration thread yet?

https://www.gog.com/forum/star_wars_dark_forces_series/jedi_knight_mots_hardware_acceleration_graphic_patches_for_all/post175
avatar
ghastlymelodies: Thanks for the reply! I have tested at every step and nothing seems to work. This is as far as I get.

If I run without DxWnd, I can get JKE to run but I can't get 3d acc to work. So I can see the new models etc from JKE but all the textures are corrupted, multicolour blobs. This is as far as I can get, Ive followed sooo many tutorials now.

Usually I have no problems doing this on other old games but, JK is being so stubborn.

I didn't download the high detail mod yet, I was actually trying to get this to run first.
avatar
jnisbet: Yes, JK is very stubborn and requires a lot of work. Have you found and followed my guide in the 3D acceleration thread yet?

https://www.gog.com/forum/star_wars_dark_forces_series/jedi_knight_mots_hardware_acceleration_graphic_patches_for_all/post175
yeah first thing I did actually. Ive followed a few but still cant get it to work. I think I have to give up at this point.
avatar
jnisbet: Yes, JK is very stubborn and requires a lot of work. Have you found and followed my guide in the 3D acceleration thread yet?

https://www.gog.com/forum/star_wars_dark_forces_series/jedi_knight_mots_hardware_acceleration_graphic_patches_for_all/post175
avatar
ghastlymelodies: yeah first thing I did actually. Ive followed a few but still cant get it to work. I think I have to give up at this point.
Have you tried switching the render mode to RGB emulation (add -displayconfig to the desktop shortcut to reveal the hidden menu where you can do this)? I’m curious if this would work. It basically is the hardware accelerated version, but running completely on the CPU (and missing texture filtering).
I got the game running perfectly with the Enhanced mod and GlowSaberX, except for one small detail: When I pick up the new lightsaber during the fight with Sariss, it still has a green blade. This is explicitly something that should be accounted for in the mod. I tried both the Basic and Beta 7 versions of GlowSaberX. Any idea what might be wrong and how to fix it?

edit: Nevermind, got it sorted out. I think the issue what that I was not using the version of JK.exe which comes packaged with GlowSaberX.
Post edited December 08, 2018 by timotaka
will the enhanced mod break compatibility for multiplayer?
All work fine for me with :
https : //github.com/jdmclark/jkgfxmod

Folow the installation guide for GOG Galaxy.

It's look fine with :
https : // www.moddb.com/mods/jedi-knight-neural-upscale-texture-pack/downloads/jedi-knight-neural-upscale-texture-pack