It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
these days I do things slightly differently so I don't have many of these problems.

but back when I played KOTOR and KOTOR 2, I had trouble getting them to run.

NWN is the same engine and game layout. I haven't played NWN2 so I don't know how similar or different it is to 1. basically, the .exe will need to be run with full permissions as administrator, and I had to disable DEP. look on the net for how to do that. if you cannot change it with the GUI you can definitely change it via the command line. also, with KOTOR2, I needed to replace the mss32.dll with the one from KOTOR because the new one simply wouldn't run.
avatar
johnnygoging: these days I do things slightly differently so I don't have many of these problems.

but back when I played KOTOR and KOTOR 2, I had trouble getting them to run.

NWN is the same engine and game layout. I haven't played NWN2 so I don't know how similar or different it is to 1. basically, the .exe will need to be run with full permissions as administrator, and I had to disable DEP. look on the net for how to do that. if you cannot change it with the GUI you can definitely change it via the command line. also, with KOTOR2, I needed to replace the mss32.dll with the one from KOTOR because the new one simply wouldn't run.
I exchanged the mss32.dll from nwn2 with the one from nwn1 and that actually did the trick. I can now start the game and go all the way through the intro and character creation so hopefully it should be fine now. Though there is no sound so I'll have to figure out what the issue is there now, but still thanks for the help jonnygoging
Running the game in XP SP3 compability mode + admin did it for me.
I feel a bit stupid not trying this right away. But two other computers were able to run the game with no issues without doing it.
Hi , i found a final solution for me!!!

try disable your sound card, and if game run corectly you have the same problem.

my problem was in settings EAX for game

i have sound card sounblaster X-Fi and there is a program ALCHEMY (include in driver)
i add the nwmain.exe into the tab and its work!!!!!

if you have different sound car try disable eax suppor or try find similar aplication for your sound card

I had to set also compatability mode for mwmain. exe (windows XP sp3)

i found the solution there

httpforum.baldursgate.comdiscussion33293cant-get-nwn-diamond-to-run-on-my-new-computer-raaagh-help

sory for my bad english

have a nice day
Post edited November 03, 2014 by refuse666
avatar
Anakoreten: Running the game in XP SP3 compability mode + admin did it for me.
XP SP3 compat wasn't enough for me; I had to disable visual themes too.
avatar
refuse666: i found the solution there

httpforum.baldursgate.comdiscussion33293cant-get-nwn-diamond-to-run-on-my-new-computer-raaagh-help
...
Not sure how that solved your problems. It didn't solve mine and I was the one who started that discussion...
(lemme fix that link while I am here: http://forum.baldursgate.com/discussion/33293/cant-get-nwn-diamond-to-run-on-my-new-computer-raaagh-help)

Anyway, I did some research and apparently the fix for the issue on a realtek card is something called "3D SoundBack Beta 0.1". The trick with that is it didn't work for me until I set the compatibility mode on both the soundback thing and the NWMain to a vista service pack.

You can find that here:
http://www.realtek.com.tw/downloads/downloadsView.aspx?Langid=1&PNid=14&PFid=24&Level=4&Conn=3&DownTypeID=3&GetDown=false
Post edited November 20, 2014 by Tresset
I am running Win 7 64 pro 64 bit. Nothing worked until I set the compatibility to XP Service pack 2, rather than 3. I also installed the new Catalyst drivers for my ATI card, that didn't change anything, nor did changing the name of the exe file. I just wanted to add something that worked for me!
avatar
atnighthawk: 4) As i was aware it launched in a tiny 1024/768ish window, i went into the NWN2 folder in my documents and editied the nwn2.ini. Simply went to the section called [Display Options], then set my resolution manually.

Example.

[Display Options]
FullScreen=1
Width=1920
Height=1080

There were some other options in there for gamma etc but i didnt mess with those.

Save/Closed that file.

Relaunched the game and it worked.

No need to rename the .exe then so any optimisations that may rely on the .exe in your drivers can still apply.

I used to mess with this game and the original a lot back in the day as far as config goes... so I hope this helps someone as I like a fairly clean windows install and didnt really want to have to mess it up to much to get things working. This is about as minimal impact as it gets imo.

Also you can start to change display options to your liking once your in the game. So i've turned anti aliasing on etc. :)
I was getting "nwmain.exe stopped working" message at GOG's NWN startup and it seems that editing the FullScreen option value from 0 to 1 under [Display Options] nwn.ini made it go away. Now... what class should I roll?
Dug up this old post as I was having troubles with blank screens, freezes on start up and generally being a pain to install

Thanks to the advice from Aliatriste (page 3) - it really was as simple as renaming the .exe to something new, and the game runs perfectly on Windows 7 64 bit.

Just thought I'd bump this thread in case it helps others.
Post edited February 03, 2015 by iscagog
avatar
Alatriste: My hardware is CPU Athlon X2 6000+ & videocard HIS HD 5670 IceQ 512MB (ATI Radeon 5670), OS is Windows XP SP3, and I`ve same trouble NWN crash on start: Installed NWN couple of days ago and it refuses to run no matter what I do. I have tried almost everything: update DirectX 9c, windowed mode, change the "safemovie", mentioned here ati ogl dll for NWN Explorer 1.1, downgrade ATI drivers, edit game shortcut to point to +TestNewModule "xyz", disabling the sound, change the resolution... It`s all was helpless... What a disaster!

But! After some googling (sorry for _._ and absence link to finded original post, this forum does not allow me insert any links), I just renamed nwmain_._exe to anything else (game_._exe, for example) and...IT WORKS NOW!
Very strange and very simple workaround, but it work for me. I`am impressed...
Thanks a lot for sharing this! I guess sometimes a simple fix is the way to go. Rated up.
I posted on this topic because I couldn't seem to start a new topic.

I have had a major issue (CRASH ON STARTUP) with Neverwinter Nights Diamond since I purchased and downloaded it from GOG several days ago. The crash was consistent, and the error message was always the same:

-----------------------------------------------
Error Signature
AppName: nwmain.exe AppVer: 1.6.9.0
ModName: ntdll.dll ModVer: 5.1.2600.6055
Offset: (this changes every time)
-----------------------------------------------

I worked on this problem for 36 hours straight (no sleep), and tried everything I could think of, and everything I could find on various forums to solve this issue. Steps taken: CLEAN re-install (i.e. UnInstall, Clean orphan entries in the registry (I use CCleaner from Piniform), Sometimes De-fragging the partition, Re-boot, Re-Download and Install the program). I made my Windows Firewall and Trend-Micro anti-virus 'friendly' to */Gog.com/* and re-downloaded. I tried several 'fixes' suggested by the GOG tech support team, even doing things that were done to the computer long ago. The results were always the same - CRASH ON STARTUP.

Then I went to this website, and the 'fix' turned out to be amazingly simple:

From: pcsupport.about.com/od/fixtheproblem/a/ntdlldll.htm

Applies To:

Ntdll.dll error messages can apply to nearly any Windows based software program, driver, or plugin on any of Microsoft's operating systems from Windows NT up through Windows 8, Windows 7, Windows Vista, and Windows XP.

How To Fix Ntdll.dll Errors

1. Restart your computer. The ntdll.dll error you're receiving could be due to a one-time, temporary issue and a simple reboot may resolve the problem completely.

2. Reinstall the program if the ntdll.dll error only displays when you use a specific program.

Steps 3 to 7 all have to do with Windows XP (or newer) or Internet Explorer (or Chrome). Since Neverwinter Nights was the only program I was having this problem with, I skipped all of these steps.

8. Update drivers for any hardware in your computer where updated drivers are available. Outdated drivers sometimes cause ntdll.dll errors.

NOTE: This seemed unlikely since other graphics intensive games (like Dungeon Keeper 2 and Silent Hunter IV) weren't having this problem, but at this point, what did I have to lose?
CONTROL PANEL\SYSTEM\HARDWARE tab\DEVICE MANAGER button\expand DISPLAY ADAPTERS\select ATI RADEON HD 2600 PRO\PROPERTIES button\DRIVER tab\UPDATE DRIVER button\select 'Install Software Automatically'. Windows did a search, then installed 'something'. Re-booted the Computer.

After the computer started up, I selected 'Neverwinter Nights Diamond' from the desktop icon, and VOILA!! NWN started up with no hesitation - Opening credits, music, intro movie and Main Menu. All selections after that worked properly, and I was able to select a Campaign, or Other Module (including ALL the Premium modules sent by GOG, as well as the Premium modules I had purchased from BioWare years ago. HAPPY, HAPPY, JOY, JOY!!

Upon further inspection, I found something really strange. Windows had actually 'rolled back' my driver to a previous edition.
---------------
Display Devices
---------------
Card name: ATI Radeon HD 2600 PRO
Manufacturer: Advanced Micro Devices, Inc.
Chip type: AMD Radeon Graphics Processor (0x9589)
DAC type: Internal DAC(400MHz)
Device Key: Enum\PCI\VEN_1002&DEV_9589&SUBSYS_33301545&REV_00
Display Memory: 512.0 MB
Current Mode: 1366 x 768 (32 bit) (60Hz)
Monitor: DELL E1910H
Monitor Max Res: 1366,768
Driver Name: ati2dvag.dll
Driver Version: 6.14.0010.7267 (English)
DDI Version: 9 (or higher)
Driver Attributes: Final Retail
Driver Date/Size: 7/3/2012 21:37:10, 306176 bytes

---------------
Display Devices (Changes)
---------------
** Current Mode: 1280 x 768 (32 bit) (60Hz)
** Monitor: Plug and Play Monitor
** Monitor Max Res: 1600,1200
Driver Name: ati2dvag.dll
** Driver Version: 6.14.0010.7179 (English)
DDI Version: 9 (or higher)
Driver Attributes: Final Retail
** Driver Date/Size: 4/5/2011 19:01:20, 302080 bytes

Quite bizarre NWN works with an earlier driver edition, but the other programs (mentioned above) still work too, so I'm not going to beef.

ISSUE SOLVED (for me)

If your ntdll.dll problem is more consistent and faulting with other programs, there are other steps to try at the above website.

This is Proteus signing off, and wishing you MANY GOOD LUCKS!
avatar
Carolla: I am running Win 7 64 pro 64 bit. Nothing worked until I set the compatibility to XP Service pack 2, rather than 3. I also installed the new Catalyst drivers for my ATI card, that didn't change anything, nor did changing the name of the exe file. I just wanted to add something that worked for me!
This is exactly what helped me run the game! Thank you!
Post edited June 07, 2015 by warps
Setting the compatibility for Win XP SP 2 worked like a charm here as well, after tearing my hair out trying other things. Thank you very much.
tried (almost) everything stated here.
the links are broken, so i could not get the opengl.dlls

having dx10 installed does NOT make your game use dx10 overriding your dx9 - unless you live in a parallel universe where everything works opposite to our reality and PC games buy and play humans.

Fix that worked: applying a 4gb patch to the executable. (patching it to use LargeAdressAwareness and thus working with 64bit systems)
though this file is posted with this mod, it works with all 32bit executables patching them to be 64bit compatible and use more than the 3GB RAM limited by 32bit.
http://www moddb com/mods/ultimate-apocalypse-mod/downloads/laa-large-adress-awareness-patch
add dots yourself - as i am not allowed to post links yet.

still the game only launches when i disable sound - and using the game without sound should be punishable through whipping.
Post edited October 06, 2017 by PvtPirate