It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
Hey all I fix the ultimate annoying problem everyone has with nwn diamond which is that it won't start up or it crashes on start up.

Here's my solution and it really works.

1. get ccleaner by going to google

2. Wipe all traces of nwn diamond from your computer and I mean ALL traces of it.

3. install ccleaner.

4. Run ccleaner and go to the cleaner tab and click analyse and then remove/delete all rubbish files thatcome up and repeat this step until it says there's nothing left.

5. In ccleaner go to registration and click find issues and then fix all the issues that are found and repeat this until there's nothing left to fix.

6. Install nwn diamond to the c drive and NOT the gog file.

7. After it's installed right click on the given shortcut and go to properties and then in properties go to the compatibility tab and set the compatibility to XP SP3.

And now you should be able to play it with no problems what so ever.
This may have been discussed earlier in the forum (no time to waft through 4 pages), but I always right click the file and 'run as admin' and have not had any crashing problems since.
Literally went through every fix on this thread. Including the ones on the Bioware thread.

Not a fucking thing worked. Brand new install of Windows 7 64-bit, onboard graphics (Intel HD4000), newest drivers for everything, DX10 attempt from earlier. Nothing. Never mind. Won't waste my time with it.

You're welcome for the 10 dollars I guess.
I had problems with crushing, but fixed it somehow:
Running Win 7 Ultimate Edition 64 bit, ATI card

Game was crushing whenever I started it...
I installed Kingmaker addon, and I could see intro movies but then I got black screen...
Then i went to GOG Games folder -> NWN -> nwmain.exe -> Properties -> Compatibility -> Run as Win XP SP 3
and it works now :)
Post edited November 15, 2013 by astraldemon
avatar
Thiev: OpenGL error then. I don't have ATI card myself, I won't be able to replicate it.

A long stretch, but grab file from here, unpack it to NWN directory and try running game again.
(and disable Catalyst AI, if it's still possible with that drivers)
avatar
sketchobviously: This did it for me! thanks man
Worked for me as well, thank you!
For anyone that might end up here like I did and still get the crashes;
I checked Neverwinter nights .ini file and found out that it had set my OS on Windows XP ->SERVICE PACK 2<- (I have Windows 7 64bit). I tried running Neverwinter on Windows XP service pack 3 compatibility mode prior to finding this out and I'm happy to inform that changing the compatibility mode to service pack 2 worked! :D
avatar
Curmudgeon60: Thanks, Alatriste. Just re-naming the nwmain.exe to NWN1.exe did the trick for me, too
This worked for me too. I installed the game on my extern HD, but I got always the message that the game stopped working. I never even got to the intro! Renaming the .exe worked for me.
avatar
astraldemon: [..]
Then i went to GOG Games folder -> NWN -> nwmain.exe -> Properties -> Compatibility -> Run as Win XP SP 3
and it works now :)
Worked vor me, Win8.1 Pro

Thanks ;-)
avatar
Alatriste: But! After some googling (sorry for _._ and absence link to finded original post, this forum does not allow me insert any links), I just renamed nwmain_._exe to anything else (game_._exe, for example) and...IT WORKS NOW!
Very strange and very simple workaround, but it work for me. I`am impressed...
This also fixed it for me in Win 7 64-bit. Thanks!
avatar
astraldemon: I had problems with crushing, but fixed it somehow:
Running Win 7 Ultimate Edition 64 bit, ATI card

Game was crushing whenever I started it...
I installed Kingmaker addon, and I could see intro movies but then I got black screen...
Then i went to GOG Games folder -> NWN -> nwmain.exe -> Properties -> Compatibility -> Run as Win XP SP 3
and it works now :)
It works for me too. Thank you.
Doesn't work for me either, even after running as admin and running it as win xp sp 3.

Using win 7 64bit.
I`m using Windows 8.1. I`ve tried every solution in this thread and nothing works. It loads as far as the Atari splash screen them just crashes. Renaming NWMain.exe does nothing, running in compatibility mode (any mode) does nothing.

Why does Microsoft insist on launching new versions of Windows and not allowing backwards compatibility. This is why I refuse to downgrade(it isnt an upgrade if nothing you have works on the new OS) to a new OS unless I am forced to.
avatar
Mageala: I`m using Windows 8.1. I`ve tried every solution in this thread and nothing works. It loads as far as the Atari splash screen them just crashes. Renaming NWMain.exe does nothing, running in compatibility mode (any mode) does nothing.
And you're running it in admin mode? And it was installed directly to the C drive rather than under program files?
The default Binkplayer's DLL is designed for 32 bit. There is a work-around but TBH I don't know what it is. Maybe a compatibility issue? But Win7 and Win8 users have solved it. Check the BSN threads for recommendations.
I have pretty much reached a point where I'm willing to just give up on ever getting this game running.
I tried every trick in this forum:

-Installing Direct X V9
-setting compatibility for nwmain.exe to Win XP SP3
-starting as Administrator
-renaming nwmain.exe
-Installing tha game directly in C: instead of the GOG file.
-changing the setting in the nwn2.ini [Display Options] to FullScreen=1 Width=1920 Height=1080
-and installing the CEP V2.4 as some here have recommended

and still I can't this thing running.
whenever I start the game it just immediatly throws me back to the desktop without giving me any error Messages
and without me even seeing a intro clip. The game can still be seen running with the icon shown in the Destop bar
but clicking on it just keeps throwing me back to the desktop

I am running it on a Win7 x64 sp1 with an AMD Radeon HD 7900