It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
avatar
Alatriste: But! After some googling (sorry for _._ and absence link to finded original post, this forum does not allow me insert any links), I just renamed nwmain_._exe to anything else (game_._exe, for example) and...IT WORKS NOW!
Very strange and very simple workaround, but it work for me. I`am impressed...
One POSSIBLE explanation (but not necessary the only):
Some video card driver optimization for improved performance by both AMD and nVidia involves the driver identifying the game you run and then applying various optimizations to it, from forced settings to actually hacking code (ex, replacing the MSAA code with CSAA code dynamically).
If renaming the exe made it work then its likely that the issue was all along in such a modification which no longer identifies it (exe name is important to both the nVidia and AMD method of identification)

Another possible explanation:
Renaming the exe does not prevent it from finding and running its dependencies but DOES prevent THEM from finding and doing things to it. It is possible that one such dependency (most commonly an anti cheat mechanism) is causing the instability and that the core game works just fine without it.
Post edited February 03, 2013 by taltamir
Mine works now too....strangest fix I've ever seen. Thanks.
So the actual fix is to change the letters of the main executable? Do the GOG dudes know about this?
My game keep crashing every time i tried to change the resolution from 800X600. Changed the name of the main exe and now it work right. LOL
I have a solution:
Right clik on nwmain.exe -> Properties.
Next Compatibility tabs, set "Run this program in compatibilty mode" for example in Windows XP SP3 and Voilà :)
avatar
Teramage: My game keep crashing every time i tried to change the resolution from 800X600. Changed the name of the main exe and now it work right. LOL
Yep, had same problem, same fix worked, AMD card?
Post edited April 06, 2013 by Trid
avatar
Teramage: My game keep crashing every time i tried to change the resolution from 800X600. Changed the name of the main exe and now it work right. LOL
avatar
Trid: Yep, had same problem, same fix worked, AMD card?
Yes amd.
avatar
Trid: Yep, had same problem, same fix worked, AMD card?
avatar
Teramage: Yes amd.
The advice in the following thread worked for me.

http://social.bioware.com/forum/Neverwinter-Nights-1/NwN-1-Technical-Support-Self-help-for-all-versions-and-expansions/NWN-immediately-crashes-on-startup-14817313-1.html
avatar
Alatriste: My hardware is CPU Athlon X2 6000+ & videocard HIS HD 5670 IceQ 512MB (ATI Radeon 5670), OS is Windows XP SP3, and I`ve same trouble NWN crash on start: Installed NWN couple of days ago and it refuses to run no matter what I do. I have tried almost everything: update DirectX 9c, windowed mode, change the "safemovie", mentioned here ati ogl dll for NWN Explorer 1.1, downgrade ATI drivers, edit game shortcut to point to +TestNewModule "xyz", disabling the sound, change the resolution... It`s all was helpless... What a disaster!

But! After some googling (sorry for _._ and absence link to finded original post, this forum does not allow me insert any links), I just renamed nwmain_._exe to anything else (game_._exe, for example) and...IT WORKS NOW!
Very strange and very simple workaround, but it work for me. I`am impressed...
You rock bro, I was about to say my NWN copy wasn't working, don't know why you not so much rep for doing this! +1

My videos are not streaming ok though, they freeze a lot :S
Post edited April 10, 2013 by Crsldmc
Same here.
AMD 7770 and "Neverwinter Nights has stopped working" immediately upon launch.
I actually went to trouble of swapping in my old nVidia 8800 in order to play a module, worked fine and I did.

But now after replacing the GPU, I see this thread and find that renaming nwnmain into neverwinter fixed the whole problem.

Thanks and +1 to Alatriste.
Sorry, noticed answer is already on thread. N/M
Post edited April 18, 2013 by n64link
Hi there I tried the change nwmain.exe thing to anything else but it's not working am I do it wrong or something. If you could explain how to do it that might help but at the moment I at a loss and I've been at this for months.
fuck you gog. nothing on this works. wtb money back
avatar
Nightwing66: Hi there I tried the change nwmain.exe thing to anything else but it's not working am I do it wrong or something. If you could explain how to do it that might help but at the moment I at a loss and I've been at this for months.
Hi,

On Windows 8 X64 Pro, Haswell i5, Asrock Z87M Extreme4 mobo, ATi 6950, Soundcard is the onboard Realtek ALC1150, 16GB RAM.
2x Dell 2311U monitors (1920x1080). ...yes i know overkill for NWN2... xD

I just bought the game and I had issues on windows 8 where it would not start.

I run multiple monitors (used to do eyefinity) and it seemed to hate everything I did to try and get it to work. XP Compatibility mode got me a small 1024/768 window with the intro, but if i clicked on it it just minimised to the taskbar and crashed.

I'm aware of all the little workarounds you can do but i'll list what I did in order as I did very little and I hope it helps anyone.

1) Switched the .exe to compatibility mode for XP SP3. This works to launch the game for me, but if you click anywhere it fails.

2) Turned off XP SP3 compatibility mode.

3) Downloaded The Direct X runtime installer (it only downloaded about 10mb worth of data for me and frankly i'm not sure it helped).

4) As i was aware it launched in a tiny 1024/768ish window, i went into the NWN2 folder in my documents and editied the nwn2.ini. Simply went to the section called [Display Options], then set my resolution manually.

Example.

[Display Options]
FullScreen=1
Width=1920
Height=1080

There were some other options in there for gamma etc but i didnt mess with those.

Save/Closed that file.

Relaunched the game and it worked.

No need to rename the .exe then so any optimisations that may rely on the .exe in your drivers can still apply.

I used to mess with this game and the original a lot back in the day as far as config goes... so I hope this helps someone as I like a fairly clean windows install and didnt really want to have to mess it up to much to get things working. This is about as minimal impact as it gets imo.

Also you can start to change display options to your liking once your in the game. So i've turned anti aliasing on etc. :)

Edit : Just to clarify i'm running this on a single monitor, I like to use my other monitor for a video steam or sites.
Post edited June 24, 2013 by atnighthawk
avatar
Nightwing66: Hi there I tried the change nwmain.exe thing to anything else but it's not working am I do it wrong or something. If you could explain how to do it that might help but at the moment I at a loss and I've been at this for months.
avatar
atnighthawk: Hi,

On Windows 8 X64 Pro, Haswell i5, Asrock Z87M Extreme4 mobo, ATi 6950, Soundcard is the onboard Realtek ALC1150, 16GB RAM.
2x Dell 2311U monitors (1920x1080). ...yes i know overkill for NWN2... xD

I just bought the game and I had issues on windows 8 where it would not start.

I run multiple monitors (used to do eyefinity) and it seemed to hate everything I did to try and get it to work. XP Compatibility mode got me a small 1024/768 window with the intro, but if i clicked on it it just minimised to the taskbar and crashed.

I'm aware of all the little workarounds you can do but i'll list what I did in order as I did very little and I hope it helps anyone.

1) Switched the .exe to compatibility mode for XP SP3. This works to launch the game for me, but if you click anywhere it fails.

2) Turned off XP SP3 compatibility mode.

3) Downloaded The Direct X runtime installer (it only downloaded about 10mb worth of data for me and frankly i'm not sure it helped).

4) As i was aware it launched in a tiny 1024/768ish window, i went into the NWN2 folder in my documents and editied the nwn2.ini. Simply went to the section called [Display Options], then set my resolution manually.

Example.

[Display Options]
FullScreen=1
Width=1920
Height=1080

There were some other options in there for gamma etc but i didnt mess with those.

Save/Closed that file.

Relaunched the game and it worked.

No need to rename the .exe then so any optimisations that may rely on the .exe in your drivers can still apply.

I used to mess with this game and the original a lot back in the day as far as config goes... so I hope this helps someone as I like a fairly clean windows install and didnt really want to have to mess it up to much to get things working. This is about as minimal impact as it gets imo.

Also you can start to change display options to your liking once your in the game. So i've turned anti aliasing on etc. :)

Edit : Just to clarify i'm running this on a single monitor, I like to use my other monitor for a video steam or sites.
Hi there thanks for the help but it didn't wrok but I did find away to fix it and got it running and it's fullest.