It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
I got it to work today after doing the administrator and toolset thing. But now the toolset won't open! What gives! I feel like gog should give a refund for this game that does not work properly....
In my case, I found the sound to be the problem. Disabling the sound from the menu>configuration prevents crash on start up when using higher resolutions. If you use this approach, change the resolution from the menu>configuration.

I can't see how it could be related but I disabled my second monitor and lowered the resolution on my monitor to 1024x768 or something like that to get the game to run with sound (alternately you can set a low resolution in the menu>configuration panel).

I can't tell if this is a sound issue, a graphics driver issue, or a combination of both. In both cases, the game freezes if I try to change the resolution in game. Also, fully exiting the game requires a minimize to desktop where I see a message that the game has crashed.
Post edited September 17, 2012 by asortofdream
avatar
thelovebat: Unfortunately I've tried every possible solution in this thread and not a single one of them has worked. I have an ATI Radeon HD 5700 graphics card, Windows 7 Home Premium Dell computer.
avatar
thme: Have you seen the thread below or the Ultimate Link List Sticky that has the Win 7 install guide?

http://www.gog.com/en/forum/neverwinter_nights_diamond/campaign_videos_cutscenes_not_playing_right/page1

http://social.bioware.com/forum/1/topic/187/index/3341490

I have Win 7 and I had to install it to C:\ Neverwinter Nights, copy in the updated bnk32 file, run from nwnmain.exe as Adminstrator.

Good luck.
Well thanks for the help.

I finally got it to work after turning off User Account Control, putting the Neverwinter Nights game folder in the C:\ Hard Drive and then running the game as an administrator in Windows XP SP3 compatibility mode. Running it in glorious 1920x1080 resolution without having to play with any .ini settings.

Didn't have to download the bink file or whatever, but that's good because the download link for that file in the topic expired.
On win7 x64 SP1.
Using the binkw32 fixed file for ATI (along with setting it to disable desktop composition, winXP SP2 compatibility, and run as administrator) works but only if I use safemovie=0.
If I combine it with the safemovie=1 it crashes.
Post edited January 30, 2013 by taltamir
Sounds like your machine is new, and fast. Most likely you're running on DirectX 10. NWN has issues with DX10. Try rolling your rig back to DirectX 9.
avatar
urknighterrant: Sounds like your machine is new, and fast. Most likely you're running on DirectX 10. NWN has issues with DX10. Try rolling your rig back to DirectX 9.
the only way to do that is install windowsXP.
Windows Vista+ has DX10 and it cannot be uninstalled.
avatar
urknighterrant: Sounds like your machine is new, and fast. Most likely you're running on DirectX 10. NWN has issues with DX10. Try rolling your rig back to DirectX 9.
avatar
taltamir: the only way to do that is install windowsXP. Windows Vista+ has DX10 and it cannot be uninstalled.
That one kind of threw me because I installed DX9c on my vista rig to get the NWN2 toolset working, and it worked. Turns out we're both right. After a few searches it appears if you install DX9 over DX10 it will install DX9 files that are not included in DX10. I've confirmed I'm still running DX10, but I guess the new files make it possible for 10 to properly emulate 9, because I didn't get the "This Machine Already Has DX installed" dialog box. The installer ran all the way through to the end.
Post edited October 19, 2012 by urknighterrant
avatar
taltamir: the only way to do that is install windowsXP. Windows Vista+ has DX10 and it cannot be uninstalled.
avatar
urknighterrant: That one kind of threw me because I installed DX9c on my vista rig to get the NWN2 toolset working, and it worked. Turns out we're both right. After a few searches it appears if you install DX9 over DX10 it will install DX9 files that are not included in DX10. I've confirmed I'm still running DX10, but I guess the new files make it possible for 10 to properly emulate 9, because I didn't get the "This Machine Already Has DX installed" dialog box. The installer ran all the way through to the end.
Its not "installing over" its installing additional updates.
DX10 does not replace DX9, they live side by side. Download the latest DX bundle and it will update both DX9 and DX10. Both are still installed. DX10 is not removed or downgraded... they are two different branches each with its own updates and capabilities.

Think of it like how video games... installing an update to starcraft 1 does not "overwrite" or "remove" starcraft 2. you have both systems installed at once.
Yep. You have to install DirectX 9 in order to get older DirectX games to work. It coexists just fine with DirectX10.
This totally worked for me!
avatar
JonathanWolfe198: [...]
avatar
Thiev: OpenGL error then. I don't have ATI card myself, I won't be able to replicate it.

A long stretch, but grab file from here, unpack it to NWN directory and try running game again.
(and disable Catalyst AI, if it's still possible with that drivers)
I have an ATI 5850 graphics card with Windows XP SP3 (Catalyst Version 12.10). Every time i try to start the program, I receive an error message- ModName ntdll.dll (sometimes but rarer atioglxx.dll) and altgough I have tried everything the program refuses to start even with your instructions. Any idea to overcome the problem?
Now sure why my last post isn't showing up ..

but suffice it to say .. a re-install did no good .. fresh out of the box..

I'm updating ms .NET framework (odd that I thought I had JUST updated it like a month ago......) .. but we'll see after the install of the update will work.. I doubt it only because I think it's something with ATI driver.. my catyst control center is NOT loading and I'm suspecting it's something to do with that..

standby ..

ETA: NOTHING on this thread has helped.. the atixx.dll rebooted my PC twice .. OUCH ..

ETA#2: well... no matter how hard I try .. I can NOT get catylst control center to launch, period. I'm not sure what else to do at this point..

any suggestions GoG? or members ??
Post edited January 05, 2013 by Arthurox
high rated
My hardware is CPU Athlon X2 6000+ & videocard HIS HD 5670 IceQ 512MB (ATI Radeon 5670), OS is Windows XP SP3, and I`ve same trouble NWN crash on start: Installed NWN couple of days ago and it refuses to run no matter what I do. I have tried almost everything: update DirectX 9c, windowed mode, change the "safemovie", mentioned here ati ogl dll for NWN Explorer 1.1, downgrade ATI drivers, edit game shortcut to point to +TestNewModule "xyz", disabling the sound, change the resolution... It`s all was helpless... What a disaster!

But! After some googling (sorry for _._ and absence link to finded original post, this forum does not allow me insert any links), I just renamed nwmain_._exe to anything else (game_._exe, for example) and...IT WORKS NOW!
Very strange and very simple workaround, but it work for me. I`am impressed...
Post edited January 10, 2013 by Alatriste
Thanks, Alatriste. Just re-naming the nwmain.exe to NWN1.exe did the trick for me, too
Thanks a lot. Renaming does the trick.