It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
avatar
adamhm: Wrappers are now available for SimCity 4 and The Evil Within :)
avatar
WaylanderPK: Anybody else having te follwoing issue?

Looks like a Zenity issue, but I;ve not been able to track down the error.
Anybody have a workaround?

I'm on Ubuntu Mate 19.10.
avatar
adamhm: This is likely due to the libraries that are now bundled with Proton 5.0 conflicting with libraries provided with newer versions of Ubuntu. You could try using an earlier version of Proton (try the argument: -winever=proton-4.11-13) or pruning the bundled libraries to remove the conflicting one(s).
Yes! Thank you, especially for Sim City 4.
avatar
adamhm: Wrappers are now available for SimCity 4 and The Evil Within :)
avatar
WaylanderPK: Anybody else having te follwoing issue?

Looks like a Zenity issue, but I;ve not been able to track down the error.
Anybody have a workaround?

I'm on Ubuntu Mate 19.10.
avatar
adamhm: This is likely due to the libraries that are now bundled with Proton 5.0 conflicting with libraries provided with newer versions of Ubuntu. You could try using an earlier version of Proton (try the argument: -winever=proton-4.11-13) or pruning the bundled libraries to remove the conflicting one(s).
Thank's I'll give that a go.
Also thanks for your hard work on this.
Post edited April 19, 2020 by WaylanderPK
I know you've already done one favor for me, but another series that Linux struggles with is the Gothic series. If there was an installer that also took care of the Community patches or players kits that would be amazing.

More important, thank you so much for the SimCity 4 wrapper, this is going to make such a difference in my gaming.
high rated
Wrappers are now available for Deus Ex: Human Revolution Director's Cut and Deus Ex: Mankind Divided :)

Please vote for the "classic" version of Deus Ex: Human Revolution (i.e. the original release with separate The Missing Link DLC) on the community wishlist: https://www.gog.com/wishlist/games/deus_ex_human_revolution_original_version. It looks and performs much better and is much less buggy than the Director's Cut; if/when it arrives here I'll make a wrapper for that too.
I am running GOG SimCity 4 DE on my Dell XPS 15 (model 9570). This is running Ubuntu 19.04

I have been able to use the simcity4_wine.tar.xz to successfully run the software. This is an amazing thing!

My problem is that the XPS15 9570 has a high resolution screen. In turn the icons and text in the game are unreadably small. I describe what I've done below, but in a nutshell:

Can I force Wine to run a virtual desktop in full screen mode?

To be clear, this isn't a problem with the script, I suspect it comes down to me not knowing Wine. Here's what I've done so far:

1) Run start.sh and set the screen DPI using winecfg - this makes the wrapper script menus and other pieces the right size, but once the game starts automatically in full screen mode everything in the game renders as if my screen is not a high DPI screen but a normal DPI one

BEGIN EDIT
1a) Setting the resolution in the game also doesn't work - e.g. 1600x1200 (which is 1:1.33 vs 1:1.77 like the screen itself) has no effect then or on restarting the game
END EDIT

2) Manually twiddle the screen resolution before and after - this works, and is probably a reasonable workaround, but it feels wrong to change the underlying OS resolution when Wine has virtual desktops that can do it. The command I use is: xrandr -s 1920x1080; ./start.sh; xrandr -s 3840x2160

3) A virtual desktop w/ resolution 1920x1080 - the text and icons are perfectly sized in this relative to the virtual desktop window, but the window is half the dimensions of the laptop screen so it's unreadable. If I could force it to render full screen though this would be the perfect solution. Hence my question above :)

Thanks -
Lambdoid
Post edited May 29, 2020 by lambdoid.annuent
*Praying for Prey*
Hello,

I have just installed Cat Quest with the generic Proton wrapper and the gamepad (Logitech F310, doesn't matter whether I set it to xinput or dinput mode) doesn't work although it is recognized just fine in the wine joystick settings inside of the wrapper. I had the same problem with the last game I played with it (Ori and the blind forest) is there any way to fix this?

I never had that problem with Proton on Steam, only with the wrapper.

Edit: I made the game run with game-pad working via Lutris.

The pad works fine in pure WINE, Steam's Proton and Lutris Proton, the wrapper here is the only method that makes it dysfunctional, I wonder why.
Post edited June 17, 2020 by Klumpen0815
Can you please make a wrapper for Grandia 2 Anniversary Edition?
I just tried Prey with the generic wrapper and it works wonderfully, but I can confirm what Klumpen0815 is saying, my gamepad isn't detected. Alas, I have no insight to offer as to why this is the case, perhaps Steam's Proton adds an extra layer of compatibility for controllers? No idea really.
avatar
sunshinecorp: I just tried Prey with the generic wrapper and it works wonderfully, but I can confirm what Klumpen0815 is saying, my gamepad isn't detected. Alas, I have no insight to offer as to why this is the case, perhaps Steam's Proton adds an extra layer of compatibility for controllers? No idea really.
Thanks for the confirmation.

Lutris' Proton works with controllers as well, so it's not really about Steam, I think.
Post edited June 21, 2020 by Klumpen0815
Sorry to bother you. Just bought ARMA: Cold War Assault (also called Operation Flashpoint) and tried to install it using your script. Unfortunately it complained about the setup file. According to the script it's supposed to have a version number of 2.0.0.6, but the downloaded game is named setup_arma_cold_war_assault_1.0_(36421).exe

So I got a wee bit stuck :-|
Post edited July 13, 2020 by Pangaea666
avatar
Pangaea666: Sorry to bother you. Just bought ARMA: Cold War Assault (also called Operation Flashpoint) and tried to install it using your script. Unfortunately it complained about the setup file. According to the script it's supposed to have a version number of 2.0.0.6, but the downloaded game is named setup_arma_cold_war_assault_1.0_(36421).exe

So I got a wee bit stuck :-|
GOG silently updated the installers, and I've also been a bit busy lately. Anyway I've updated those wrappers now :)
avatar
Pangaea666: Sorry to bother you. Just bought ARMA: Cold War Assault (also called Operation Flashpoint) and tried to install it using your script. Unfortunately it complained about the setup file. According to the script it's supposed to have a version number of 2.0.0.6, but the downloaded game is named setup_arma_cold_war_assault_1.0_(36421).exe

So I got a wee bit stuck :-|
avatar
adamhm: GOG silently updated the installers, and I've also been a bit busy lately. Anyway I've updated those wrappers now :)
Thanks a lot. Managed to install the game with the new script, and started it up quickly just to test if it ran. Seems like it all works like intended. Looks familiar yet very different :)
avatar
adamhm: GOG silently updated the installers, and I've also been a bit busy lately. Anyway I've updated those wrappers now :)
avatar
Pangaea666: Thanks a lot. Managed to install the game with the new script, and started it up quickly just to test if it ran. Seems like it all works like intended. Looks familiar yet very different :)
Hiya, sorry to bug you...the warhammer final liberation one has also been updated and is also broken.

I tried just modifying the sha256 sum, just to see, but I got "Extracting Final Liberation: Warhammer Epic 40k...
Not a supported Inno Setup installer!
"

So...yeah. not sure where to go from here.


THANK YOU FOR SETTING THESE UP! (regardless of whether you can get to this update, I appreciate you being out here helping folks)
Post edited July 17, 2020 by qkslvrwolf
I just redownloaded it; the filename and checksum are identical so it looks like your download was just corrupted (this would also explain the innoextract error). Redownload it and try again with the unmodified script.