It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera


Came to say my game does not launch on my Surface Book, I followed the instructions on the Support page but nothing seems to be working Anyone have a fix for this?
Thanks, I tried this and it fixed my launching issues
Post edited September 10, 2019 by G-Wizard
blutok: Well I did as u said (just downloaded pure installation files and installed it) but nothing has changed, the problem is still occuring.
NicoMonNico: Thanks mate, you saved me.
I'm sorry, but what?!!?
I don't understand any of this thread apart from that the game doesn't start. Like mine.
I explicitly used GoG Galaxy to circumvent different installers and an overloaded harddisk. And after reinstalling twice, nothing. That's a first for a GoG buy.
GS_Schimpf: Thanks for your help!

The reinstalling of MS XNA 4.0 refresh fixed it for me!

Best regards!
Yes, that worked. WTH? A piece of [censored] software from 2011?
Not going to refund. But won't play. Thx a lot.
Same problem here, Installing XNA libraries according "GOG support" post helped. Still I thing that this could be managed in some user more friedly way.
L3goury: Ok guys, i found how to install the game correctly. Just to advertise, i have the GoG Galaxy on French so i hope my translation would be good.

When on GoG Galaxy, click on your game "UnderRail" on the left.
Then click on "more" just on right of install.
Click on "Saves and Goodies".

You have 2 parts : "UnderRail" and "Patch".
Download this 2 parts. It would be on the file : GoG Galaxy/Games/UnderRail/!Downloads.

Go to this file and click on "setup_underrail_1.0.4.17".

You would instal the game, not from GoG Galaxy, but directly with the file of the game.
Patch would automatically be installed with the game.

Enjoy !!!! ;-)

Let me know if you did it !!!
Worked for me!
It seems to be that XNA doesn't work on Windows 10 anymore. On the "Microsoft XNA Framework Redistributable 4.0 Refresh" download page there is no Windows 10 in compatible OSs.

And when I download and run this package on latest Windows 10 anyway, it says that "This installation package could not be opened. Contact the application vendor to verify that this is a valid Windows Installer package."

Does anyone have a solution for that?
Please reinstall Microsoft XNA 4.0 Refresh:

This did it for me, running the game under win10 64 ! :)
Post edited January 19, 2021 by gabbawokky
XNA Framework Redistributable 4.0 Refresh download is unavailable, at least in my area -- I'm not sure about elsewhere. I tried installing other versions still hosted by Microsoft, but nothing worked. Only solution was to take the risk and download it from unofficial sources. I googled "xnafx40_redist.msi" and luckily found the correct file in an old sourceforge page of a game called "Under Attack XNA" (late thanks to the dev for hosting the file for so long), took the risk downloading it and it worked.

I don't recommend my solution for anyone, though, so I'm not posting links or anything. It did work, but it's not supposed to be like this. If you're having issues like I had, it's on you if you download something that messes up your computer.

I messaged GOG support about this issue, waited almost two weeks with no answer (I'm not complaining, I know they're overwhelmed) and decided to drop the request today since I did manage to get the game working.
sergioluisb: decided to drop the request today since I did manage to get the game working.
may i ask how you manage to do that?
gabbawokky: Please reinstall Microsoft XNA 4.0 Refresh:

This did it for me, running the game under win10 64 ! :)
Thank You - this worked for me! Had the same problem on my system W10Pro 64bit 21H2 even though the game worked on my other two PCs (notebooks) with W10 Home with all the latest updates without the need to install this package...
Post edited April 09, 2022 by praashek