It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera


Came to say my game does not launch on my Surface Book, I followed the instructions on the Support page but nothing seems to be working Anyone have a fix for this?
Thanks, I tried this and it fixed my launching issues
Post edited September 10, 2019 by G-Wizard
blutok: Well I did as u said (just downloaded pure installation files and installed it) but nothing has changed, the problem is still occuring.
NicoMonNico: Thanks mate, you saved me.
I'm sorry, but what?!!?
I don't understand any of this thread apart from that the game doesn't start. Like mine.
I explicitly used GoG Galaxy to circumvent different installers and an overloaded harddisk. And after reinstalling twice, nothing. That's a first for a GoG buy.
GS_Schimpf: Thanks for your help!

The reinstalling of MS XNA 4.0 refresh fixed it for me!

Best regards!
Yes, that worked. WTH? A piece of [censored] software from 2011?
Not going to refund. But won't play. Thx a lot.