It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
avatar
sunwaterpark: I really don't know what you say exactly
So, What should i do to play Thief Gold improved?
Does GOG version include New Dark mod and TFix?

I tried to play TG after install TFix 1.17 beta in TG GOG version
but it doesn't work appearing error message that can't not open Thief 2 metal age (???)

Could you anyone tell me how to install New Dark mod and TFix for Thief Gold?
Take a look at this page if you haven´t already done so
http://www.gog.com/news/mod_spotlight_thief_gold_and_thief_ii_the_metal_age
Post edited November 19, 2013 by CorranHorn
avatar
JudasIscariot: Hi everyone,

Just wanted to let you know that we have uploaded some brand spankin' new installers for the first two Thief games. Included now are all the NewDark (version 1.21) fixes for both games. Shout outs/thank yous go out to voodoo47 who has been more than awesome with the community and helping us out with everything Thief-related.

So, please, enjoy these newly-enhanced installers and let us know what you think... and don't forget to steal everything not nailed down :P
avatar
Arethmus: I noticed that Thief 2's NewDark upgrade has numerous frame drop problems and a complete lack of anti-aslising; not to mention no bugfixes what so ever. All of this is fixed in Thief GOLD (including the bugfixes) but Thief 2 is full of these problems. I was wondering if GOG can release an update for Thief 2 that addresses these problems, similar to the update you guys gave to Thief GOLD?
Not sure if this is still relevant or not but I find that turning antialiasing and filtering on for games using the video driver's control panel per-application override almost always gives better graphics because higher levels of AA are available at the driver level, or even different AA algorithms than what a given game might have built in support for. Ditto with a number of other effects, etc. Having said that, games should of course be fixed if they have bugs with such features, etc. but in the mean time using the driver to override things is generally superior in my experience even though it takes a minute or two to set it up for every game one wishes to do it with. I'm using an ATI card right now but I know nVidia supports this also.

Hope this helps.
this is not very recommended actually, as force-overriding the application settings may cause conflicts and issues. the uneven frames should be resolved with the latest GOG update, but no idea whether they've chose to enable multisampling by default (while this improves the visuals for most users, it will cause the infamous intel black screen problem, and possible flood the GOG user support with support tickets. //edit: no,it's disabled by default, so the safer way it is).
Post edited December 30, 2013 by voodoo47
Oh awesome, will there be a new installer for System shock 2 as well. It uses new Dark and I've been loving it.
a small fixup package has already been submitted to GOG - it should add the mod autoload folder already available in the steam version (so one will have the basic mod load ability even without using ss2tool), and a couple of cfg variables that are required for SCP (the massive community overhaul project that we were hoping to deliver on christmas, but somehow santa would not cooperate - fat man said he had too much xbones and ps4s to deliver, and no time for pc gamers and their free mods for their almost free games).
Post edited December 30, 2013 by voodoo47
Is there no TFix style fan pach for Thief 2? I can't find anything beyond a TafferPatcher that appears to have not been updated in quite a long time, is that still valid or obsolette? Anyway, if anyone cares I also found a torch that when you put it out with a water arrow it doesn't actually turn off its light. Here it is, in the fancy bath of the first mission's upstairs:

https://abload.de/img/thief2_2019_02_26_15_y5jqk.png
Post edited February 26, 2019 by Al3xand3r
can't use old saves after patching up (that's what's happening with the torch).

also, TafferPatcher is not terribly out of date, so it's fine to use it for the time being. it will either get updated, or replaced by a new patcher soon enough.
Post edited February 26, 2019 by voodoo47
Ah, thanks!