It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
high rated
I've put together a Wine wrapper for System Shock: Enhanced Edition, allowing it to be played on Linux almost like a native game & with no Wine knowledge required. This also supports the easy use of different soundfonts (default is to use the Fluid R3 GM soundfont available from the repositories on Ubuntu/Mint).

Simply run the build script to create the wrapper. If the installer files are not alongside the wrapper build files then the path to them will need to be specified either by passing it as an argument to the build script with -respath="<path>" or by setting an environment variable named WINEWRAP_RESPATH containing it. You can change the path to build the wrapper in and the name of the wrapper directory with the -buildpath= and -dirname= arguments. The build path can also be set with the WINEWRAP_BUILDPATH environment variable.

The output will be a directory containing the game set up within a preconfigured Wine prefix, along with its own copy of Wine, extracted game icons, documentation, and start script(s). From there simply run the start script to play. The start script also includes options for creating a shortcut, configuring the wrapper etc.

(to uninstall simply delete the game directory and any shortcuts you created, and the game's user data directory in ~/.local/share if you don't want to keep your saves & settings)

User data is stored under ~/.local/share/sshock_enhanced

Full details are in the readme.txt and release notes. Here is the download link:

sshock_enhanced_wine.tar.xz
(36.1 kB, SHA256: 180c13c3e634888271056db6502539d7a7bf36721847028a98288245fc0d6804)

Updated 2019/07/15: Updated winewrap.shlib.

The wrapper uses Wine 4.0. Wine and Winetricks will be downloaded automatically if not present; to avoid redownloading for other scripts the downloaded Wine package will be stored in ~/.cache/winewrap

If anyone runs into any problems with this then post in this thread, Adamhm's Linux Wine Wrappers - News, FAQ &amp; Discussion and/or The "Judas&trade; does this run in Wine" thread v1.173.

For more of my Linux Wine wrappers check out post 3 in this thread: Adamhm's Linux Wine Wrappers - News, FAQ &amp; Discussion
Post edited 2 days ago by adamhm
avatar
adamhm: I've put together a Wine wrapper for System Shock: Enhanced Edition, allowing it to be played on Linux almost like a native game & with no Wine knowledge required. This also supports the easy use of different soundfonts (default is to use the Fluid R3 GM soundfont available from the repositories on Ubuntu/Mint).

Simply place the script, resource archive and installer files together in the same directory & run the script. The output is a directory containing a "GOG-style" ready-to-go Wine-wrapped version of the game (the build script also has the option to create a tarball of the assembled game package); from there installation is simply a case of moving the directory to wherever you want it installed to - then just run the start script to play, create a shortcut for the game, access the advanced options etc :)

(to uninstall simply delete the game directory and any shortcuts you created, and the game's user data directory in ~/.local/share if you don't want to keep your saves & settings)

Running the start script with the argument "play" will bypass the menu and start the game immediately (this is the default setting for shortcuts created by the script).

User saves are stored under ~/.local/share/sshock_enhanced

Full details are in the readme.txt and release notes. Here is the download link:

sshock_enhanced_wine.tar.xz
(11.7 kB, SHA256: 31a98901afff904c03a07070106d3319a636dfef0d0dea67038969faf4c9cdce)

Updated 2017/05/14: Some minor fixes and documentation update. Also enhanced the build script's test for innoextract - the build script will now download its own copy of innoextract from http://constexpr.org/innoextract/ if the system provided version is not installed or too old.

The wrapper uses Wine Staging 2.0 with CSMT enabled. Wine and Winetricks will be downloaded automatically if not present; to avoid redownloading for other scripts the downloaded Wine package will be stored in ~/.cache/winewrap

Due to being a bit unwell last week I didn't get around to starting work on this until Tuesday so this has had a lot less testing than I'd have liked & should definitely be considered a beta release, but I don't think there are likely be any big issues. However if anyone does run into any problems then post in this thread and/or The "Judas&trade; does this run in Wine" thread v1.173.

For more of my Linux Wine wrappers see my GOGmix: adamhm's Linux Wine wrappers
Just got this game in their deal today. I will definitely check your script out. Thanks, again!
I'm experiencing audio issues, in the terminal it says: Checking for FluidSynth...
No soundfonts could be located; will not launch fluidsynth.
Soundfont missing or fluidsynth disabled. MIDI music playback may not work


With fluidsynth installed it says this: Checking for FluidSynth...
Using FluidR3 GM soundfont: /usr/share/sounds/sf2/FluidR3_GM.sf2
fluidsynth: warning: Failed to pin the sample data to RAM; swapping is possible.
fluidsynth: error: Couldn't find the requested audio driver pulseaudio. Valid drivers are: file, oss.
Failed to create the audio driver
Try running it with fdrv=alsa, e.g.:

./start.sh play fdrv=alsa
avatar
adamhm: Try running it with fdrv=alsa, e.g.:

./start.sh play fdrv=alsa
This still resulted into the same audio issue: fluidsynth: warning: Failed to pin the sample data to RAM; swapping is possible.
fluidsynth: error: Couldn't find the requested audio driver alsa. Valid drivers are: file, oss.
That's very odd, PulseAudio is pretty much standard but there should at least be ALSA support... what distro are you using?
avatar
adamhm: That's very odd, PulseAudio is pretty much standard but there should at least be ALSA support... what distro are you using?
I'm using Ubuntu Mate 18.10
I suspect that something's been broken with Ubuntu 18.10, since that should use PulseAudio by default. Doing a quick search for "ubuntu 18.10 pulseaudio" it looks like others have had similar issues after upgrading to 18.10.