It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
There's a new fix for the game available in the form of an updated ddraw.dll

You can download dgVoodoo2 from http://dege.freeweb.hu/

You will need to extract the contents of the MS folder to Septerra Core's root folder and overwrite ddraw.dll

Also extract dgVoodooCpl.exe and play a bit with those settings and see which one works for your system.
i didn't have any .avi files or ddraw.dll or QuickTime.qts in the root folder

but besides that i followed the steps to this fix perfectly (aside from having to place the .db files differently because administrator priviledges bullshit) and this fix didn't work

back to square 1
Post edited July 24, 2017 by foulidity
I tried, and I am giving up. I got the videos to play under Win 10, but the mouse and screen have around a 1 Hz update rate (as others have said).

Note that, initially, I could get NOTHING to work, until I uninstalled the K-Lite Codec Pack. Then some progress, but still slow performance.
avatar
Silvery-Corgan: There's a new fix for the game available in the form of an updated ddraw.dll

You can download dgVoodoo2 from http://dege.freeweb.hu/

You will need to extract the contents of the MS folder to Septerra Core's root folder and overwrite ddraw.dll

Also extract dgVoodooCpl.exe and play a bit with those settings and see which one works for your system.
I did both fixes in this thread, and it did not work until I did this. Thanks a bunch <3


EDITED

There is a small bug still, where launching the game from Galaxy will cause the intro videos to not play the video, only the audio. Launching the game from the game folder however does not cause this to happen.

I'm willing to live with this.
Post edited January 02, 2018 by Shriketastic
Thx man, that's really working.
Thanks very much. this fix worked for me as well. windows 10 64 bit:)
The instructions from the first post of this thread also work for me. (Windows10 64bit with a nVidia GTX970)

Thank you so much for your help, Silvery-Corgan, much appreciated!
MERGETI PE YOUTUBE SI SCRIETI ASA..
SEPTERRA CORE INSTALARE PE WINDOWS 10 64 BITS MERGE 100%
avatar
Sicod: Works great! It took me a couple of times to actually follow the directions properly, but I got it!
avatar
Silvery-Corgan: Hello,

I found a solution for the game to run on Windows 10. Please make this post sticky.

After installing the game, you need to remove all .avi files from the installation dir as well as "ddraw.dll" and "QuickTime.qts".

Download the following file. It contains the movies and the QT fix: mega.nz/#!tB80ULaS!W0DyyPzWa3lS7in_ko7L3lgckNcY0MMLf-VXXxRIM-I

Replace the .DB files in the installation dir with the ones from my archive.

Place the files inside the archive "QT4.zip" into your C:\Windows\SysWOW64 (Or C:\Windows\System32 if you have 32 bits Windows)

You will find "QT4.zip" in my uploaded archive.

Conclusion: Videos work and there is no stuttering. It's like back in '99 when the game was released.

PS: I'm not allowed to publish full links here. You'll need to copy the link into your browser to access the file hosted at mega. I've scanned the file with Virustotal and it's clean:

virustotal.com/en/file/806b27d23ca0c17d7fd4b502de6690c335fdbea10a8523390ac27b647730ebb4/analysis/1448203864/
avatar
Sicod:
Thanks this fixed my issues!! wish I had found this thread sooner, I was about to give up. =D
I fixed it for WIN10 by renaming ddraw.dll to ddraw.dll.bak and QuickTime.qts to QuickTime.qts.bak. so basically deleting those 2 files specifically. and it runs fine. no mouse lag, no issues, perfect.