It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
HP Slimline 450 -a120 amd e1 ----- Return of Krondor fix ------ I check the RTK.log within the C:\Sierra\Rtk folder it says atiumdag.dll violation. So within the same C:\Sierra\RtK folder I place the .dll file within. The file however is a Swiftshader (d3d9.dll) that is renamed into (atiumdag.dll).

The opening intro cutscenes does not work in stretch mode due to windows media player issues on windows 10. To fix this within the C:\Sierra\Rtk folder open\edit the RTKrondor.ini file. Set the [Cinemat] Stretch=0 (that's is all). Then in properties set the compatibility to XP Service mode 3. The video should now display, but not filling the screen of the monitor.

Dgvoodoo 2.44 to 2.54 has a MS folder within, that contains d3d8.dll this as well can be used. Change the .dll file name to atiumdag.dll and place within the C:\Sierra\RtK folder. Note: some downloads of this file however contains warnings of malicious\virus. find proper version without the virus\malicious content.
Post edited March 08, 2018 by WillowCrystalis
Hello All,

Short version: 1.Turn off D.E.P 2.Turn off any and all over lays that can affect the game (gog,nvidia, radeon, etc), 3.Download the standalone installer and right click it to install as administrator, when the install is done launch the game from the install is finshed box and it should start 4. Close the game and bring up the return to krondor folder and go into the compatibilty options on rtk.exe, and set the compatibility mode to windows 98 and make sure that run as administrator is checked and then apply the changes. Now right click rtk.exe and select run as administrator and the game should start.

I hope this helps with anyone trying to get this game started. After many hours of trying everything in this thread and a couple of threads on steam, it seems that windows has some kind of issue with how this game tries to access certain files and the game itself seems to have issues with any type of overlay.

So the first thing I think that may have helped is I turned off Data Execution Prevention, I beleive its listed in this thread somewhere if not a quick google search will tell you how to do that. Since that didn't fix the problem on its own I messed around with the compatibility settings. That didn't work either initially. So I decided to uninstall the game from galaxy and reinstall by downloading the standalone install file, that way I could avoid any gog overlay stuff. When I installed it this time though i made sure to run the install file as the administrator, just so windows understood I wanted the program to do what it needed to do. It took a little longer than normal but it did install and amazingly it did start!

Then I closed the game and it preceded to not want to start again.

So I did the whole process again and it worked again,then it didn't work again. So the only thing I did differently than the last sevral installs was to right click the install file and run as admin. So I checked the compatibility settings on rtk.exe and noticed two things: I had it set to win 98 compatibility at some point and I had it set to run as admin. So on a hunch I I right clicked the rtk.exe in the game folder and ran it as administrator again and the game started! To double check I changed the compatibility settings a little bit and it went back to not starting even though i was running the exe as admin. Changed the settigns back ot win 98 and run as administrator and the right clicked the exe and ran as admin and the game started again.

Don't know why this worked for me but it did. The machine im using has windows 7 on it and I don't have a way to test it on windows 10 but this may work there too. Hopefully someone else can try it and post here to let others know.

Hope this helps.
Hey everyone!

I've met the same problem with "RtK" recently. Last time i saw that kind of habitation - it was "Shogo". There was several tries to resolve it, but i finished with disabling Windows' Game Center entirely via regedit. It helped me to forget about "rundll32" problem and more.

Just start "run" through the control panel, then type "regedit", run it, and find:

HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\GameUX\Service Location

There will be "Games" parameter. Change it's volume (https with something) to "localhost". Now restart your PC and try to run "Return to Krondor" again.
Post edited July 10, 2019 by ShellDNMS
I tried so much things, at the end I found a workaround:
Delete (backup first) the .dll which cause the problem - check the rtk.log in the game directory.

In my case it was nvd3dum.dll - after i deleted it, my game starts with a blank screen BUT without an error and with sound. I could just skip the scenes and then see the legendary main manu. :D

Sad that all video scenes are just black with sound, but I can play this game!

Hope this workaround will work for you too.

Oh and don't forget to set compatibility mode to Win XP SP2
For all those suffering - rejoice, the savior have come to deliver you! :) I've been trying to get the damn thing to work for last few years with very occasional and unsteady results. Eventually the farking thing would just stop working and no matter what I did, it wouldnt start up again. Pretty much nothing helped (compatibility, disable this, enable that, etc) But I did enjoy playing the game all those years ago, so I just kept coming back and trying again.

Solution turned out to be rather unorthodox. Well, not a solution really, but thrice cursed, bloody effing thing finally runs. Consistently. Every. Bloody. Time. With. NO. PROBLEMS.

Every time you actually manage to start a game, it will create or update RtK.log in your main game dir. I usually delete logs and such to make sure I can review them for any errors and such, but for last year or so, the game wouldnt get that far as to create even a log. Today I was playing with a few things and accidentally started RtK.exe twice. Again, usually I force quit the one that failed to start, but this time I forgot and..... to my complete amazement RtK.log got created. Just like that. The game didnt start yet, but the effing log got created with current date, so I got optimistic, opened up task manager, killed one of RtK.exe and mothertrucking holy sh!t! The thing started up and ran with not a hiccup. Dont ask me why, just go to your main game dir, disable any compatibility, start RtK.exe, wait 5-10 secs, start it again, wait 5-10 secs, open up task manager and kill the one RtK.exe with lower memory usage out of two running. Works for me and have been working consistently for about two weeks, but fark me sideways if I know why.
I had the same problem, trying to run the game resulted in nothing (except that for some reason trying to run the game turned ClearType off and all my fonts became jagged, im running Windows 10 64) I tried most of the fixes listed here and the support page with no luck. RtK.exe starts up on task manager but completely hangs up and the game never starts.

For me the solution ended up being simple: I tried running the game completely normally, then opened up task manager, right clicked the task->Go to details->Right click again->Analyze wait chain. RtK.exe was waiting for some background process (it had something to do with discord). Killed that process, and the game immediately started without problems :)
I'm getting an error that says:

"An error has occurred while trying to read the game file: .try

The game requires this file. This problem may be corrected by reinstalling the game. To reinstall game insert disk ."

Can some one please help me with this its one of my favorite games and would love to play it
The answer was very simple for me Windows 10 64 bit and NVIDEA GPU: you have to go in GeForce Experience App; disable toggle for in in game overlay- then it works perfectly
Post edited December 08, 2020 by rbush47
I had the same problem that a "Launcher" icon appeared in the bottom right, but no game appeared. Here's how I got it fixed.

1. Try to start the game, so that the Launcher icon appears bottom right

2. go into Task Manager (Ctrl-Alt-Delete, then select Task Manager or the bottom option)

3. show the detailed view - the list of processes - hit More Details if necessary

4. Find RtK on the list (not Launcher) - if it doesn't appear, your problem is different

5. Right click it, choose Go to Details or Details - you should see RtK.exe on the Details tab

6. Right click RtK.exe in the Details list, pick Analyze Wait Chain.

This shows if the RtK game is being halted by something else. You might then see another process that needs to be shut down or done something with. If you don't see anything, your problem is different.

For me, it was Adobe CEF Helper - yep, Adobe Creative Cloud service was stopping RTK from starting. So I right-click that process and ended it (every instance in the list), and RtK worked.
avatar
dingoperson: I had the same problem that a "Launcher" icon appeared in the bottom right, but no game appeared. Here's how I got it fixed.

1. Try to start the game, so that the Launcher icon appears bottom right

2. go into Task Manager (Ctrl-Alt-Delete, then select Task Manager or the bottom option)

3. show the detailed view - the list of processes - hit More Details if necessary

4. Find RtK on the list (not Launcher) - if it doesn't appear, your problem is different

5. Right click it, choose Go to Details or Details - you should see RtK.exe on the Details tab

6. Right click RtK.exe in the Details list, pick Analyze Wait Chain.

This shows if the RtK game is being halted by something else. You might then see another process that needs to be shut down or done something with. If you don't see anything, your problem is different.

For me, it was Adobe CEF Helper - yep, Adobe Creative Cloud service was stopping RTK from starting. So I right-click that process and ended it (every instance in the list), and RtK worked.
Thanks it worked, and for me it was the Nvidia Container.
Post edited February 11, 2021 by Dr.Bo
avatar
dingoperson: I had the same problem that a "Launcher" icon appeared in the bottom right, but no game appeared. Here's how I got it fixed.

1. Try to start the game, so that the Launcher icon appears bottom right

2. go into Task Manager (Ctrl-Alt-Delete, then select Task Manager or the bottom option)

3. show the detailed view - the list of processes - hit More Details if necessary

4. Find RtK on the list (not Launcher) - if it doesn't appear, your problem is different

5. Right click it, choose Go to Details or Details - you should see RtK.exe on the Details tab

6. Right click RtK.exe in the Details list, pick Analyze Wait Chain.

This shows if the RtK game is being halted by something else. You might then see another process that needs to be shut down or done something with. If you don't see anything, your problem is different.

For me, it was Adobe CEF Helper - yep, Adobe Creative Cloud service was stopping RTK from starting. So I right-click that process and ended it (every instance in the list), and RtK worked.
THIS WORKS!!!!!!!!!! thank god you sweet sweet person i can finally play with game again