It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
I encountered this problem.
my os is windows 10.
what should I do? pls somebody help me.
avatar
GamerJapan: I encountered this problem.
my os is windows 10.
what should I do? pls somebody help me.
Same problem. Windows 10.
Solution for me: Resetting Network Adapter (Winsock Reset)
in admin cmd
netsh winsock reset
and restart. ¯\_(ツ)_/¯
Hey, I was also having this issue on iMac (Sonoma 14.3.1 (23D60)). I had to uninstall GOG multiple times, toggle the login settings, and also move the installed GOG folder from shared into my user's folder.. I hoped this helps some of you. I really wanted to play the new Stardew update and I would have rioted if I couldn't. Shame on GOG for not addressing this directly in forums tho
avatar
Shanaya_Stephenson: Hey, I was also having this issue on iMac (Sonoma 14.3.1 (23D60)). I had to uninstall GOG multiple times, toggle the login settings, and also move the installed GOG folder from shared into my user's folder.. I hoped this helps some of you. I really wanted to play the new Stardew update and I would have rioted if I couldn't. Shame on GOG for not addressing this directly in forums tho
I have the same issue. To be fair, there have been messages similar to this one filling the logs since the release of MacOS 14 last autumn - with the app being unable to close.

So this looks like a bad bug that GOG just haven't fixed in more than half a year - they're really, really bad at maintaining their client.
2.0.73 Beta (2023/11)

Issue still remains when connected via RDP. Connected via Parsec instead, GOG launches flawlessly.
I have the same issue. Was unable to solve it.

M1 mac on Sonoma 14.4.1
Post edited April 17, 2024 by OlegBoleg
I had the same problem, multiple reinstall, and deletion of some or all files manually was not wark.

I find out that after installation only Galaxy component was mark as enable to run in background in my settings, but gog sp. z o.o. was not - after I click on that switch my client start to work normally :)

Hopę this help some of you I louse few days to figure that out because after installation I always get info new items was added to background setting (or something like that) so I do not even think to check it.
Attachments:
Post edited April 25, 2024 by TvoroV
Having same issue here, just installed today. Tried a few things mentioned here, no luck. No idea what enabling to run int he background means though or where to set/check that. Old gog app worked great, this one sucks.
same issue. Uninstalling GOG Galaxy...
Same issue here. None of the above fixes works :(
Mac Sonoma 14.5, GOG Galaxy 2.0.74

Deleting everything GOG related, including in /Users/bm/Library/Application Support/ + reinstall and login and still GOG after a little while displays the 'GOG Galaxy - Error \ Connection to Communication Service \ was lost and could not be restored! GOG \ Galaxy will now shutdown." window pops up. And instead of really shutting down, the app-window duly goes away but the app itself has to be manually Force closed.

It seems the Mac just has no priority at all. At all.

/ps tried fresh install yet another time, made sure start item 'GOG Sp. z o.o.' was enabled and 'GOG Galaxy.app' was not, then rebooted my Mac and started GOG Galaxy, user login and the 'Connection' error stayed away.
Post edited May 25, 2024 by bmeerdink
avatar
bmeerdink: Mac Sonoma 14.5, GOG Galaxy 2.0.74

Deleting everything GOG related, including in /Users/bm/Library/Application Support/ + reinstall and login and still GOG after a little while displays the 'GOG Galaxy - Error \ Connection to Communication Service \ was lost and could not be restored! GOG \ Galaxy will now shutdown." window pops up. And instead of really shutting down, the app-window duly goes away but the app itself has to be manually Force closed.

It seems the Mac just has no priority at all. At all.

/ps tried fresh install yet another time, made sure start item 'GOG Sp. z o.o.' was enabled and 'GOG Galaxy.app' was not, then rebooted my Mac and started GOG Galaxy, user login and the 'Connection' error stayed away.
Worked for me (so far ;) ). Thanks!
Same issue here on macOS Sonoma 14.5 on my Macbook Pro (Intel model from 2019).