It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

This crap is still not fixed? It's outrageous.

Clean install, reinstall, re-reinstall, uber-reinstall, reinstall macOS, reinstall democracy - tried everything, the same crap message shows up. Can't connect so SHUT IT DOWN? wtf
same problem, MAC OS Monterey 12.0.1 . Any way of fixing it?
Post edited February 17, 2022 by zipsniperwizard
Hansul: I'm getting this as well.

I'm on a new laptop, Mac Monterey. I did the TimeMachine and GOG wasn't working - fine, I had jumped ahead on which version of OSX I was using. I uninstalled, and then put a new version of GOG Galaxy. Everything boots up fine, but the moment I scroll, it flashes up the error message and shuts down.

I even deleted Galaxy and reinstalled it, and I still get the error. Exactly the same wording, exactly the same timing, all of it.

I don't have any antiviruses or anything installed at the moment, no VPN, nothing.

Anyone know what's happening, or how to fix it?
I'm having the same problem. I was able to get Galaxy to open once by deleting it, emptying trash, restarting my computer, and reinstalling Galaxy. It opened once, I played for a while, closed it, came back a few days later to the same error. I just sent a trouble ticket to GOG support hoping to get some information.
have the same problem, cant play any gog games
Post edited April 24, 2022 by brabro
Crashing for me as well.
legally speaking, this is fraud

taking money for goods and services but not fulfilling the contract

have better stuff to do in my life then to threaten an incompetent company but i have no other idea how to get them to deliver what is owed, support is clueless and unable to address the issue
Post edited April 24, 2022 by brabro
Can not connect with anymore. Can some one help please?
Looks like they finally fixed it in the latest update (2.0.49). I needed to restart my Mac cos it still wasn't working right away after the update, but *currently* it seems to be working fine

Edit: it was working for 2 days, now it's not working again, same crap error message, can't do anything, the app quits. Seriously, Gog People, it's clear that more and more people are having this issue which means we can't use your app to play games. It's not a minor annoyance, it makes playing games impossible
Post edited May 15, 2022 by igazine
I'm suddenly getting this error. I can't access anything, Galaxy immediately just shuts down. What the hell is going on?
Is this solved? I faced the same error on Win11, continued with complete uninstall of the galaxy client, reinstalled it but still the error persist. What can be done?
Like @igorta and many others here. I'm interested to know as a customer - has this been solved yet please GoG development team?
I haven't tried recently, but I haven't heard from GOG support, and - as of a couple of weeks ago - I was getting the same kind of error.

I'm had to resort to downloading game installers separately (i.e. not through GOG Galaxy) and tbh, I'm not really touching GOG at the moment because of this. Not out of spite or anything, but because Steam and Epic are turning out to be more convenient than GOG.

I would love to have this fixed, but no luck as yet.
The reason why reinstalling Galaxy does not work is because it keeps settings and files after it is uninstalled. I had to do a full wipe to get it working again.

These issues happen with every major update. Updates fail to remove the old launch settings because it never closes galaxy properly during the update. I have talked with support about it and recommended a few options to prevent this issue in the future. Here's hoping they fix the way the program updates.
Post edited May 16, 2022 by cmba2
Has anyone gotten an answer as to why GOG Galaxy requires internet to begin with? I know i can launch the apps w/o it, offline. But the whole point of using galaxy is to make it easy to launch the games. What is the point of a launcher that requires internet? Especially on laptops that are offline often and launching games that have no online component anyway.
It just seems a bit too "DRM-y" for non-drm games. (it is probably for feedback maybe, but still, an online requirement is lazy programming no one has 100% uptime.)

Just reinstalled, and rebooted, w/o success. :/

EDIT: After a second reboot, Galaxy is working (for now. Yes harsh, but this keeps coming back :( )
I would still like to know why Galaxy auto-closes just because it cannot find the internet. Devs?
Post edited August 10, 2022 by drache
I'm getting this on macOS Ventura Public Beta 3. Previous Public Betas didn't have this issue. Really not sure what's going on as when I reboot my Mac and open Gog Galaxy, EVERY TIME it tries to install the Helper, which I have done, still to no avail.

I've sent through log files to support and bug report so I'm really hoping someone will get back to me about it. If anything I hope it'll help with the beta-testing.