It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

high rated
IMPORTANT: Please read before posting This topic has been provided to discuss the latest releases of our Downloader (for both Mac and Windows systems) and to submit bug reports. The stable releases (recommended for most users) can be found at this address:http://www.gog.com/downloader.

Latest version:

Mac OS X - 1.2 (build 512)
Windows - 3.6.0

Both Downloaders now have the option of sending Error Reports directly to us (this can be found in app under Settings).
Post edited October 29, 2013 by Fallen_Zen
Kirin_Persus: Hi,

Where would I find the log File again?

Please copy-paste this file on pastebin-like service.
Shinook: This is a follow up to my prior post.

For some reason, several downloads just freeze at a certain point, the transfer speed remains the same (it freezes at a certain point), and nothing progresses.

Unfortunately, my log is too long to post and attaching it won't work. Is there somewhere I can email it?
Please post your log file on pastebin-like service.

corfe83: Just tried GOG downloader for the first time today. The download will go fine at first (and very fast, I'm on fiber optic) until the download is around 80 or 90% complete, then no progress will occur. [..]
Shinook: For some reason, several downloads just freeze at a certain point, the transfer speed remains the same (it freezes at a certain point), and nothing progresses.
rihkama: I noticed the same thing when I had left the downloader running during the night. Gothic 2 for example had frozen at 99% or so.
It looks like downloader has problems with recognizing how much has been downloaded in the last chunk of game. Does this problem occurs with small games (< 100mb) as well?
I will fix it in next version of downloader.

tswijaya: Every time I lost my internet connection, the downloader crash and the currently downloaded game is missing when the downloader was restarted

Unable to download costume quest

Here's the content of the logger.log file
Does downloader crashing or just getting froze? I checked it, downloader has been froze, but as soon as I turned my net connection on, the downloader resumed download successfully.
Post edited December 14, 2012 by Szulak
rihkama: Regarding the issue with Alien Nations: downloader doesn't crash anymore but I supect that's because the file is no longer found :)

edit: Even direct download with the web browser gives 404 - Not Found error so seems like issue isn't with the downloader only.
Yes, that was a server side issue, which has been resolved. The game should be working now.
jacobmarner: I have this problem; I only noticed it within the last month or two so I think it is a new issue.

I have set by GOG downloader to start at system boot, but it not longer starts in the tray. It start at full size and when I hit the "x" to minimize to tray it just becomes a very small window in the lower left side of the screen. If I make it bigger again and then minimize it again it works fine.

I am using version 3.3.5 I downloaded a few days ago from the link Szulak provided.

I use Win7 64-bit in English.
It has been reported already, thanks. I will fix it in the next version.

Does downloader crashing or just getting froze? I checked it, downloader has been froze, but as soon as I turned my net connection on, the downloader resumed download successfully.
tswijaya: The first case, it crashed. I got an error message from Windows (?). Unfortunately I did not screen captured it.

The second one, my internet connection seemed to stagnate. It did not drop but there is no data sent or downloaded either. I tried to pause the downloader but I got the 'waiting' cursor (the circling cursor). I restarted my internet connection but the downloader keep showing the 'waiting' cursor. So I closed the downloader.

In both cases, the downloaded game disappear from the download list so I have to add it again. The previous downloader (3.2.22) was able to quickly resume the download where it left off.
How did you close the downloader? Did you kill the process by task manager?
I will take a look on this issue carefully. Thank you for reporting it.
Draugr: 1. Downloader version (found under settings) - 3.2.22
2. OS version - WIndows 7 x64
3. OS language - German
4. Browser kind and version (this is required only if you're having problems when adding games to the queue from the website) - not applicable
5. Downloader log contents if possible: - not applicable

Dear gog.com team,

last night I scanned my computer for malware (from Linux with multiple scanners) and sadly a trojan was reported by ClamAV in Setup_Downloader_3.2.22.exe. I uploaded the file to virustotal.com and the result was that only ClamAV found a "WIN.Trojan.Zapchast-107".

Now I think that if it really was a trojan it should be found by more than one scanner, so I'd like to check back with you if the file is the unaltered original. After all some malware can have modified the file locally.

The md5 checksum of my local version of Setup_Downloader_3.2.22.exe is: f333d692b494915ae3cfbbef8ef7b7f3

Can you please tell me if this is the unaltered file? Have you heard previously of ClamAV reporting false positives with your downloader?

Best regards and thanks in advance
I've checked it:

f333d692b494915ae3cfbbef8ef7b7f3 *Setup_Downloader_3.2.22.exe

It must be certainly false positive report. Does this problem occurs with version 3.3.5 as well? If yes, I will forward it to appropriate people.
Kirin_Persus: Anywhere I can obtain older versions of the downloader as this new one as stated on previous page is FUBAR for me.
Even if you install older version of the downloader, the downloader will automaticly update to the newest version.

Tanque: My gog downloader just seems to be completely broken but doing a clean install won't fix it,everytime it starts it stops working and crashes,though I can see it keeps trying to download theme hospital no matter what I do.
Also can't download any games from the website.
Could you post your log file? However, if you can not download games from the website, it looks like server-side issue.

bevinator: 1) I've been getting the same "stop at 100% but never finishing" bug that I've had ever since the old 0.9 downloaders were discontinued. This has happened with every game regardless of size.

2) Recently, though, closing and reopening the downloader doesn't "fix" the downloads, it only corrupts them. Everything I've downloaded today has been corrupted. Today the downloader only seems to crash on exit, it never seems to just close. AFAIK this is the first time I've downloaded multiple games at once with 3.3.5, perhaps that's the issue?

3) I can't remove any of the games. I can't even select them. The "open file location" button works, but that doesn't really help me if I can't cancel the downloads.

I even uninstalled and reinstalled the program, but the games are all still there, still corrupting, still unremovable.
Please post your log file. Moreover, remove the downloader, all folders associated with the downloader, and install the downloader again.
bevinator: I unfortunately no longer have my log file, as I deleted everything in an attempt to do a clean install (which worked). I've since found that you CAN remove games, but only by right-clicking on the progress bar or the picture, NOT by clicking on the title... which makes no sense.

Removing the game manually will also remove all of the files with it, even if the download is already completed! This is exactly the opposite of the old downloader and I consider it to be a significant step backwards.

I've just resorted to downloading only one game at a time, which seems to still work. (So I still don't have a useful log file to post.)
Removing the games by clicking on progress bar makes sense, since there is stacking feature. Try to add game and it's bonus content, you will see what I mean.

tswijaya: I've tried to lower the number of concurrent connection to 2.
I got "checksum error on chunk 29, please contact support"

here's the content of my logger.log
How stable your net connection is? From your log file I can see many timeouts, which is caused mainly by unstable net connection. Try to lower the number of concurrent connections to just 1, and try again.

Salvat0re: I dont know exactly why, but i think my gog.com downloader is kinda buggy. Im downloading thief gold right now, but instead of moving forward, the download bar seems to go backward. I fixed it by restarting the downloader, but it happen occasionally with my previous download.
It usually happens when there are any server-side issues, and restarting the download process almost always fixing the problem. We are working on fix this issue anyway.
Vrioniavas: 1. Version 1.0 (200)
2. Mac OS X 10.8.2
3. English
4. Firefox 17.0.1
5. Downloader log contents if possible:
I wasn't able to find a log neither inside the app nor in the Application Support folder, so I attached the app from the Application folder. EDIT: Seems the zip was too large, I'm uploading it to DropBox: http://is.gd/Zrb14R

6. So, I've been downloading Arma II: Combined Operations for Windows. I know it won't install on OS X, but since it's a big download (14.8 GB) and I mostly use my Mac running OS X, I didn't want to be stuck in windows while I downloaded. I've been leaving it running in the background for the last day or so, and everything seemed to be going fine. This morning it was about to finish downloading, at or around 13 GB out of 14.8 GB. I left my computer running and didn't check on it again until at around 15:30 today. By then the download had finished at 100%. I quit out of the app and proceeded to connect my external extra drive to move the install files there. But when I started copying, I saw the contents of the "arma_2_combined_operations" was only about 928 MB. I noticed too, that the free space on my hard drive had gone up by about 13 GB. In the Arma 2 download folder, there were 3 files:
-rw-r--r-- 1 ********* staff 882M 15 des 10:09 setup_arma_2_1.0.0.36-1.bin
-rw-r--r-- 1 ********* staff 476K 15 des 10:11 setup_arma_2_1.0.0.36-4.bin
-rw-r--r-- 1 ********* staff 2,3M 15 des 10:03 setup_arma_2_1.0.0.36.exe

It seems as if the downloader deleted many of the install files (bins 2, 3 and 5-13?) after completing download, or more likely, after exiting.


I wanted to add that I have downloaded many of the games that work on Mac now with no problems, like Crusader: No Remorse, Syndicate and Theme Hospital.

I did pause the downloader a few times during the Arma 2:CO download, and maybe I exited the app 1 or 2 times.
Hello my friend,

Tried downloading ArmA on Mac and everything worked fine.
Downloader of course cleans the download folder after the merging process is complete but this only concerns to chunk files (their name ends with a number). If the problem persists please PM me, we'll find a solution.
Dinasis: Minor bug (small annoyance, doesn't affect downloading) to report on GOG.com Downloader version (Stable) under Windows 8 Pro x64. When the Downloader starts up, either with the system or if I launch it manually, the window opens without a Taskbar button. When closed, the window minimizes to the lower left corner of the desktop and the icon in the notification area's tooltip bubble displays. Trying to close the minimized window does nothing, but double-clicking the title bar restores the Downloader to its normal size along with its Taskbar button. It functions normally after that.

- Startup: http://i47.tinypic.com/2ptwknq.jpg
- Minimized: http://i45.tinypic.com/9rkebq.jpg
Thanks for the heads-up. We'll look into it.
Flyinaspargus7: Version: 3.3.5
OS: Windows XP
Language: English

The downloader crashes as soon as it starts up with a 'GOG.com Downloader has encountered a problem and needs to close.' message. I've tried re-downloading it and restarting my computer, but it gives me the same message.
Could you post or paste on any pastebin-like serivce?
The problem with stucking downloads on 99% will be fixed in the new version of downloader. Could you guys post your log file (or paste it on pastebin-like service), and additionally post what net connection do you have?
hercufles: 1. 3.3.5
2. Windows 7 64 bit
3. Dutch
4. firefox 17.0.1
6.An annoying problem. When I download the game and I want to open it by pressing the icon next to the fil magnifying glass It always goes to my documents but the settings clearly state that everything goesto c:\gog.com so it keeps opening a map it didnt download it to.
Thank you for reporting this issue, it will be fixed in the new version.

goplanet: I tried using the Downloader today (Windows 7, 3.3.5). I hibernated the computer while the downloader was paused. Upon resuming the download, it got to the end of the file and just kept downloading and downloading. Finally I paused it again for a couple minutes. When I resumed it again, it immediately started the next file. Well, of course the file it had been stuck on was corrupted and useless. I wound up scrapping the whole folder, uninstalling GOG Downloader and manually downloading from scratch.

I won't be trying the Downloader again any time soon.
Could you post (or upload on any pastebin-like service ) your log file please? You can find it as follow:
Gerbilforce: 1. (stable)
2. Windows 7
3. English
6. This is an oddity, but, for some inexplicable reason the past few downloader versions have failed to function properly, each simply cease working at 10 MB or 20 MB with no noticeable error or reason. I checked the log and there doesn't appear to be any oddities, it just stops. The program is allowed through my firewall and antivirus software and is run in administrator mode. Furthermore, I have attempted changing the number of connections and clearing the local data folder, yet nothing has succeeded. Any assistance with this matter would be well appreciated.
This issue has been already reported, and will be fixed in the new version of the downloader. We would like to apologize for the problems this issue has caused.