It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
https://steamcommunity.com/games/228260/announcements/detail/1618392861330306968

What about GOG?
I guess devs or GOG are waiting for a less beta release, waiting for a patched release, 2.6 ...
Post edited May 17, 2019 by ERISS