It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
deleting post... all works fine once I run Revision
Post edited April 09, 2017 by derelict.765
I tried to run vanilla (GOG) Deus Ex, and get an application crash when I try to start it. Windows 7 64bit.

Running it in safe mode, disabling audio makes it at least run (title screen) so apparently it is some kind of audio (driver) problem for me?

Anyway, I think I'll try to install GMDX mod anyway, if it makes it run. I just wanted to see it vanilla first (plus GMDX says you should run the game once anyway before installing GMDX).
Post edited October 12, 2017 by timppu
Ok I think I found a solution to my problem, in case this helps someone else. (Windows 7 64bit)

Running vanilla GOG version of Deus Ex crashed, right when the DE title screen should come. Things I already tried and didn't help:

- Running DE as an administrator.
- (Re)installing DirectX (directx_Jun2010_redist.exe)

I tried to run it in safe mode, and turns out the only way I could make it run, sort of, was to disable audio. It didn't run great though because the title screen would run in a window (even if I unselected the "run in a window" option), would have some odd green tint in the graphics, and it wouldn't react to any mouse or keyboard input even if I focused in the window with Alt-Tab. But at least it didn't crash.

I installed GMDX 9.0.2 on top of it, but it would crash the same.

Next I disabled DEP... and yep, that fixed it. Now at least the GMDX-modded version seems to run fine. I am unsure if the vanilla version would run fine too, but I guess I won't try it (I presume I'd have to reinstall Deus Ex, or...?).

This is how I disabled DEP in Windows 7:

1. Open the Command Prompt as an administrator.
2. bcdedit.exe /set {current} nx AlwaysOff
3. Restart Windows.

If you want to later enable it again (when you are not running Deus Ex anymore), I presume this should work:

1. Open the Command Prompt as an administrator.
2. bcdedit.exe /set {current} nx AlwaysOn
3. Restart Windows.
Post edited October 12, 2017 by timppu