It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

high rated
I've put together a Wine wrapper for Deus Ex, allowing it to be played on Linux almost like a native game & with no Wine knowledge required. This package uses "Deus Exe" 8.1 by Kentie and Chris Dohnal's enhanced OpenGL renderer.

Simply run the build script to create the wrapper. If the installer files are not alongside the wrapper build files then the path to them will need to be specified either by passing it as an argument to the build script with -respath="<path>" or by setting an environment variable named WINEWRAP_RESPATH containing it. You can change the path to build the wrapper in and the name of the wrapper directory with the -buildpath= and -dirname= arguments. The build path can also be set with the WINEWRAP_BUILDPATH environment variable.

The output will be a directory containing the game set up within a preconfigured Wine prefix, along with its own copy of Wine, extracted game icons, documentation, and start script(s). From there simply run the start script to play. The start script also includes options for creating a shortcut, configuring the wrapper etc.

(to uninstall simply delete the game directory and any shortcuts you created, and the game's user data directory in ~/.local/share if you don't want to keep your saves & settings)

User data is stored under ~/.local/share/deusex

Full details are in the readme.txt and release notes. Here are the download links:

(259.6 kB, SHA256: f43e92548672a33d89f1d530d3b554590182e855f95e30b1a427c2c9e08d4b5b)

(101.3 kB, SHA256: a6983131023e24c4691f1c0fc052e7d43e35a121eab6e486d9fd21ef884a0f50)

Last updated 2021/07/11

The wrapper uses Wine 5.0. Wine and Winetricks will be downloaded automatically if not present; to avoid redownloading for other scripts the downloaded Wine package will be stored in ~/.cache/winewrap

I've done very little testing with these particular versions of Wine & Deus Exe but I've done a complete playthrough using earlier versions and it ran perfectly, and there's no reason to think this may have changed. Also I've played little of Revision. However if anyone does run into any problems then post in this thread, Adamhm's Linux Wine Wrappers - News, FAQ &amp; Discussion and/or The "Judas&trade; does this run in Wine" thread v1.173.

Multiplayer has not been tested and may or may not work.

For more of my Linux Wine wrappers check out post 3 in this thread: Adamhm's Linux Wine Wrappers - News, FAQ &amp; Discussion

Please vote for the "classic" version of Deus Ex: Human Revolution (i.e. the original release with separate The Missing Link DLC) on the community wishlist: It looks and performs much better and is much less buggy than the Director's Cut; if/when it arrives here I'll make a wrapper for that too.
Post edited July 11, 2021 by adamhm
You man are amazing, on a long quest to nixify the world.
What's winetricks for? I've played Deus Ex on Linux for over a decade and I never needed winetricks or any native dll overrides.
clarry: What's winetricks for? I've played Deus Ex on Linux for over a decade and I never needed winetricks or any native dll overrides.
It's included just in case the user needs it for anything (e.g. if a mod, utility or whatever needs a particular library).
Worked great for me! Thanks!
I was having lots of trouble when trying to configure wine on my own to make Deus Ex work. However after using this dude´s bash script it worked like a charm!
Thanks dude Deus Ex is now running flawless on my Deepin OS Linux 64 bit.
Works great, thank you for your work Adam!!
Works great.
I am currently not able to install. Seems like I may have the incorrect version of Deus Ex.

My downloaded version is: "setup_deus_ex_goty_1.112fm(revision_1.3.0.1)_(16231)_(g).exe"

But the readme in the script states I need: "setup_deus_ex_goty_1.112fm(revision_1.2.2)_(15442).exe"

Can any advise be provided???

I can post the error log if it is needed.
Post edited November 25, 2017 by TandyTandon
TandyTandon: My downloaded version is: "setup_deus_ex_goty_1.112fm(revision_1.3.0.1)_(16231)_(g).exe"
You've downloaded the Galaxy installer, which what the (g) in the filename indicates. To get the Galaxy-free installer you'll need to click "More" and then select the "Classic Installers" option before downloading anything.
Thanks for replying Adamhm, I have downloaded the classic version, and it does not have the (g), but the revision number does not match. The new file name is: setup_deus_ex_goty_1.112fm(revision_1.3.0.1)_(16231)...

I have tried to locate the version with revision number 1.2.2, but I am not having much success..
Post edited November 25, 2017 by TandyTandon
Pinging you since the person above me forgot to hit the reply button.
TandyTandon: ...setup_deus_ex_goty_1.112fm(revision_1.3.0.1)_(16231)...
Oops :p Sorry, I didn't notice that GOG had uploaded a new installer... anyway, I've updated the wrapper to support it now :)
Amazing stuff, thanks for the assistance Adamhm, and thanks for the great support you provide to the Linux community...

Thanks also Themken for pining Adamhm, will remember to do that next time, if needed.

Thanks for the script. Do you have a updated version that will also install the Revision mod (the GOG version)? I'm thinking a few more tricks would have to be added since its relying on dx9.