It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
If you are on Windows 10 and get boxes in Worms Armageddon or World Party Remastered that you can't get rid of, the solution is simple (credit to UnluckyForSome from Steam). Just right-click on the game's executable file in its directory (WA.exe for Armageddon, w2.exe for World Party Remastered), go to Properties -> Compatibility, and then tick the "Disable fullscreen optimizations" box. Apply, then OK.
avatar
Plokite_Wolf: If you are on Windows 10 and get boxes in Worms Armageddon or World Party Remastered that you can't get rid of, the solution is simple (credit to UnluckyForSome from Steam). Just right-click on the game's executable file in its directory (WA.exe for Armageddon, w2.exe for World Party Remastered), go to Properties -> Compatibility, and then tick the "Disable fullscreen optimizations" box. Apply, then OK.
Posted forever ago, but just what I was looking for. Thanks!
avatar
Plokite_Wolf: If you are on Windows 10 and get boxes in Worms Armageddon or World Party Remastered that you can't get rid of, the solution is simple (credit to UnluckyForSome from Steam). Just right-click on the game's executable file in its directory (WA.exe for Armageddon, w2.exe for World Party Remastered), go to Properties -> Compatibility, and then tick the "Disable fullscreen optimizations" box. Apply, then OK.
avatar
whatsthatsmell: Posted forever ago, but just what I was looking for. Thanks!
This is not a good solution! Then you have no frame limiter and get screen tearing.