It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Hey guys are you also having trouble with unlocking achievements in New Order. So far 3 (one story and 2 perk) of them didn't unlock for me. I also don't get the notifications about unlocking those do work. I'm also playing Hollow Knight and One Finger Death Punch 2 now and achievements work there perfectly so it's not something like firewall blocking galaxy.
I've completed the whole game now, and I've only had two perk achievements unlock. Seems to be pretty common with GOG Galaxy, but only with particular games.
Strange, because for me only two perk ones didn't unlock so far (although I didn't unlock all the perks yet). There's also a few achievements listed as having 0% unlock rate so they might be bugged. Oh well the game is awesome and achieves are just a bonus.
Also have some issues with achievements. First few gaming sessions they've been logged at the end of the session, when i left game and galaxy was syncing. Then they've stopped logging, for a while. But one day i've got something like 10 of them, including those i've unlocked previus week. Now i'm on last Chapter and should have like ~60-65% of achievements, but galaxy showing only 30%.

Other game acting strange is Pillars Of Eternity. Completed game 3 times on variuos difficulties. ZERO achievments.
Same for me, the achievements seem broken. Not sure but it might be related to the hotfix (v

I started playing before and had the long loading times issue, but at this time achievements where unlocking. And now they don't anymore, maybe it's related.
Interesting find Djomanix. I think that for me it was the same, before the hotfix achievements were unlocking, but after that nothing. Also it's worth noting that until recently a lot of achievements had 0% unlock rate, but now they all have been unlocked by some players.
Edit: I rolled back to pre hotfix version and then solved the first enigma code. Once I exited the game the achievement for it appeared. So yeah I think that it's the hotfix that broke achievements. Unfortunately they don't unlock retroactively. The story ones are not the problem since I'll be going through the game anyway (wyatt timeline this time), unfortunately for the perk ones I would have to start all over and frankly speaking I don't know if I want to go through the game for the third time.
Post edited March 09, 2020 by Ravinius
completed whole game, and didn't unlocked any achievements.
Same here.
Gog should fix this.
Post edited March 18, 2020 by Pyromancer138
I opened a support ticket last week, they are looking into it, but no news so far, we are doing back and forths.
Post edited March 19, 2020 by Djomanix
Got something curious last week. I've decided to run through some chapters to pickup few collectibles I left. 1 letter, 4-6 golden items, ~3 enigmas. Picked all collectibles. At the end of the session got "The Lives of Others" and few tactical perk-achivements, but no "Heart of Gold". Weird.

Interesting that this time i've played uninterrupted, whithout "alt+TAB'ing" to check e-mails or answer my buds on Discord.

P.S. is there any way i could reset my collectibles in game to make another totally fresh run?
Post edited March 25, 2020 by JacobShockIII
Only by deleting your saves and turning cloud saving off.
Post edited March 21, 2020 by Ravinius
In my case it worked fine until I got 50% of the achievements, after that no other achievement was registered unfortunately (especially when playing through the game on Über-Difficulty).
Just finished the game and did not get a single achievement. lol
Well this sucks, was really looking forward to playing TNO again. Posting to bump this post.
at least this kinda works
wtno.jpg (81 Kb)