It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
avatar
Magmarock: I don't actually have Ultima I'm just interested in MT32 and weather or not it's worth using for other games.
avatar
Arkose: Oh, well the quality of implementation depends on the game. Some games were built with the MT-32 in mind so sound great with it while others were aimed at general MIDI and so support the MT-32 but don't make full use of it. There are even a few games where the MT-32 is listed in the sound setup program but doesn't actually work in-game (e.g. Daggerfall, which will crash at launch if the MT-32 is selected).
What's weird and I'm not sure if I'm doing something wrong. But I installed an MT32 emulator and it seems to work I have access to it from control panel. But my does games can't detect the MT32. When MT32 is set as default from control panel the game does sound different when use general midi and if I use MT32 in the game's settings, it just sounds weird and buggy.
In the .conf file, for Dosbox to find Munt you MUST change these:

device=
config=

to

mididevice=
midiconfig=

then you have to change the midiconfig to match Munt, in my case it was 3.

All I had to do was to modify those two lines, and UW2 ran properly and used Munt.

Another thing I found out is, and this is true for Might and Magic III also, the MT32 ROMs don't sound right.. I had to use CM32L_PCM.ROM and the CM32L control ROM.

EDIT: Same works with UW1, just change those two lines, and it works perfectly with Munt.

I'm using Windows 7 Home Premium, btw.
Post edited June 18, 2013 by UrielDagda
Here's an alternative to MUNT: http://www.gog.com/forum/krondor_series/guide_to_betrayal_at_krondor_music_and_sound_effects_settings
(for Underworld 1)
WIth this config you'll have soundblaster music and also voices during the cutscenes:

4 -1 -1 -1 sound
2 -1 -1 -1 speech
0 cuts
Post edited November 22, 2013 by otmsan
I'm using the custom dosbox from ykhwong's page with MT-32 emulation and it sounds like this for UU2 :

https://www.youtube.com/watch?v=CApmtm58_V4
For those who are using the Ultima Patcher for Ultima Underworld 1 and are still hearing weird noises (doors, swimming,etc). You have to use a CM-32L ROM. For whatever reason, Underworld 1 uses the CM-32L for certain sounds and while using a MT-32 you won't get those sounds.

Edit (again): The foot step sound seems fine, but when a door closes shut it make a bang noise, I'm not sure if that's the correct sound or not.
Post edited January 11, 2014 by MystifiedFire
avatar
Magmarock: I've been trying this for a little while now and I can't seem to get it to work. Sound comes out but it's wired, sounds like an IRQ error or something.
avatar
Arkose: Ultima Patcher can be used to set up MT-32 support. Try that and see how it goes.
This worked perfectly for me and was easy to do, thanks!
avatar
UrielDagda: In the .conf file, for Dosbox to find Munt you MUST change these:

device=
config=

to

mididevice=
midiconfig=
Device didn't seem to matter for me, but changing the config variable name (and value) was certainly required. Having the emulated driver set as standard midi output for the OS didn't help at all (works with midi files, but not for dosbox).

The alternate ROMs helped a lot with the sound effects as well.
To everyone who have problems with MT-32 emulation in Ultima Underworld after using Pix's Ultima Patcher (greatest thing for auto-patching and upgrading GOG Ultima games, I might say) - I recommend you to turn off emulation, turn on SB Pro sound, then revert to MT-32, and make sure you are using CM32L ROM files only. These actions fixed glitchy sound and performance issues with sound and with game overall.
thanks, it worked.
I knew to use the CM-32 roms because on my intitial research in using Munt, I found a list of games that used MT-32 on Wiki and it shows that Underworld 1 and 2 were recorded using the Roland CM-series soundcards. Also a few other games, just google MT-32 games on Wikipedia and click the CM-series column, the ones that have Y in it use the CT roms on. I can't post links or I'd post one to it lol.

Also the easiest way to use Munt, is to download the munt 1.5.0.exe on SourceForge, as I said I can't post links for some reason. Then after installing that and loading "Munt MT-32 Sound Module Emulator", you'll get a black music note icon on your program bar. Click that, and go to Options/Rom Configuration. Select your MT-32 ROM directory, and from there you can switch between MT-32 and CM ROMs, just check the ones you want to use and uncheck the others.

As mentioned though, you also have to make sure for each game DOSBox config, under the [midi] tab, there's a midiconfig=(put your MT-32 device number here). To find out your device number, load DOSBox and type mixer /listmidi

It will show your MIDI devices, the one labelled "MT-32 Synth Emulator" is the number you want. Mine is 2, so my [midi] section for my games has midiconfig=2. Hope that helps people.
Post edited July 06, 2015 by Sean38FL
Could not get the original U5 midi upgrade patch working on my own, but thanks for mentioning Ultima Patcher. It's now working perfectly with my physical MT-32!
Hey guys, I have Ultima Underworld configured in Dosbox to use MT-32 Roland sound, and it's working perfectly (no piano sounds or other weirdness). I'm using munt, with the CML roms loaded, and everything sounds great- except that Roland music is drowning out the sound effects!

The Mt-32 music is so loud, that the sound effects are so difficult to hear in comparison which really affects gameplay. Is there any way to re-balance the Roland music volume with the sound effects so as to create a balanced game play experience?
Post edited July 30, 2015 by The_Atomik_Punk
avatar
The_Atomik_Punk: The Mt-32 music is so loud, that the sound effects are so difficult to hear in comparison which really affects gameplay. Is there any way to re-balance the Roland music volume with the sound effects so as to create a balanced game play experience?
I prefer to just turn off the music. Music in a first person view single character game breaks the immersion for me.
avatar
The_Atomik_Punk: The Mt-32 music is so loud, that the sound effects are so difficult to hear in comparison which really affects gameplay. Is there any way to re-balance the Roland music volume with the sound effects so as to create a balanced game play experience?
avatar
PetrusOctavianus: I prefer to just turn off the music. Music in a first person view single character game breaks the immersion for me.
Wow, I normally agree with 99% of what PetrusOctavianus says, but not this :)

The Ultima Underworld music is excellent, it's worth trying a few things to get it working nicely. Sorry I can't help with the actual fix.