It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
So I'm running Win7 x64 w/SP1 installed , have downloaded the MuntSetup.exe from the vogons link, have the 2 .rom files in the dir and put the Putzlowitschs .cpl in the proper directory, but when I run the MuntSetup, at the end of it, I get unable to write registry value required, so it fails out. Any other installation suggestions?
Attachments:
midimap.jpg (40 Kb)
muntdir.jpg (99 Kb)
Post edited September 08, 2011 by StarZan
avatar
StarZan: when I run the MuntSetup ... I get unable to write registry value required, so it fails out. Any other installation suggestions?
Right click MuntSetup and choose "Run as administrator". That should sort it out.

You'll know it has worked for sure if you see a new MT-32 entry in Putzlowitschs MIDI mapper.
avatar
StarZan: when I run the MuntSetup ... I get unable to write registry value required, so it fails out. Any other installation suggestions?
avatar
Arkose: Right click MuntSetup and choose "Run as administrator". That should sort it out.

You'll know it has worked for sure if you see a new MT-32 entry in Putzlowitschs MIDI mapper.
So I tried that and I still get the same error. I even tried some compatibility mode settings to no avail. I appreciate the suggestion though. =(
avatar
StarZan: So I tried that and I still get the same error. I even tried some compatibility mode settings to no avail. I appreciate the suggestion though. =(
Hmm. The likely explanation then is that Munt is trying to write to a MIDI ID already taken by the X-Fi synthesisers. The installer is meant to jump to the next available MIDI ID but this probably hasn't been fully tested (most users will only have Microsoft's synthesiser).

Fortunately there's an easy way to free up the MIDI IDs:

1. Download and run Autoruns (right click, run as administrator).
2. On the Codecs tab find the X-Fi synth entries.
3. Uncheck both X-Fi synth entries and close Autoruns.

Doing this will free up the MIDI IDs Munt tries to write to so it should be able to install.

Note that doing this will completely disable the X-Fi synthesisers. If you happen to use them for something there is a way to have both coexist with some further fiddling. Let me know if that's the case and I'll provide further instructions. :)

Anyway, hopefully this workaround will work. :)
Er, I did as you said, but I really don't know which of these codecs would map the creative midi synth into place. (See picture) . Perhaps Creative loads them up a different way. So you figure that the Munt installer only tries to map to device 1,2,3 or else fails out? It seems strange that the installer refuses to write an entry to the registry.
Attachments:
autoruns1.jpg (417 Kb)
Post edited September 10, 2011 by StarZan
Thanks to BurntSoul, I got Roland emulation going. But the sound still crackles in Ultima 6 almost constantly.
avatar
StarZan: Er, I did as you said, but I really don't know which of these codecs would map the creative midi synth into place. (See picture)
I didn't realise there would be so much Creative stuff to dig through. :(

In the far left column (Autorun Entry) the entries you're wanting will include the word midi (midi2, midi3, etc.); you can use find (Ctrl+F) to jump to the keyword "midi" if you can't spot them.

Anyway I hope that makes more sense. :)

avatar
riddleofsteel: Thanks to BurntSoul, I got Roland emulation going. But the sound still crackles in Ultima 6 almost constantly.
I don't have it on GOG yet but one thing you could check is GOG has set the game to cycles=max; to check this simply run the game and switch to windowed mode (Alt+Enter); if it lists a certain number of cycles instead you could try setting it to max to see if it helps, or experiment with your own custom cycle number. There are various other things to try but this would be the first on my list.

Also note that more complicated DOS games require a powerful CPU, so if you're running on a lower-end or old system it's possible that your computer isn't powerful enough to cope with the game at full speed; even running slightly below full speed can be enough to cause audio problems.
Post edited September 10, 2011 by Arkose

I didn't realise there would be so much Creative stuff to dig through. :(

In the far left column (Autorun Entry) the entries you're wanting will include the word midi (midi2, midi3, etc.); you can use find (Ctrl+F) to jump to the keyword "midi" if you can't spot them.

Anyway I hope that makes more sense. :)

Yep, there is nothing that says MIDI unfortunately. I guess that I'm just beat. Thanks for the help, Arkose.
Dear all, if I start gog's UU it plays midi music but if I use dosbox and the cd version I can install the game setting the Sound Blaster Pro and the music is better. How can I set up well also the gog version? I've tried with the cfgs but nothing change.
avatar
Max_R: Dear all, if I start gog's UU it plays midi music but if I use dosbox and the cd version I can install the game setting the Sound Blaster Pro and the music is better. How can I set up well also the gog version? I've tried with the cfgs but nothing change.
So you have the CD version currently installed? Copy UW.CFG from the DATA folder of your CD version's install to the UNDEROM1\DATA folder for the GOG version's install. If you made changes to the DOSBox configuration file for your CD version you'll also need edit dosboxULTIMA1.conf and make the appropriate changes there.
avatar
Arkose: you'll also need edit dosboxULTIMA1.conf and make the appropriate changes there.
But how?
avatar
Arkose: you'll also need edit dosboxULTIMA1.conf and make the appropriate changes there.
avatar
Max_R: But how?
With Notepad. On Vista and newer you'll need to run Notepad as an administrator first and then open the configuration file from within it; alternately, drag the file to the desktop or whatever, make the changes there, then drag it back (confirming replacement when prompted).
Of course, I know, but do you remember what and how to change?
avatar
Max_R: Of course, I know, but do you remember what and how to change?
Well, whatever changes you applied to the one for your CD install. if you didn't make any changes there you probably won't need any for the GOG version either. Try just copying over the UW.CFG and see if it sounds right.
Unable to write registry value required.

Arkose suggestion doesn't work.
Intro sound but no music in game and only a few sounds.

6 bux for a 20 year old game.

LOL.
Was it EA that wanted to charge this?

Bloody EA.
Post edited December 02, 2011 by Smasha