It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Okay so ive had bother with this and its a bit annoying. Ive been searching around for help so i thought id come to the source.
Ive bought this off a different site and still getting the same problem so i came here and bought it because my brother got it from here and it works fine.

Does anyone know how to fix this? Ive tried finding my DirectX settings but i have no idea where to find them.

Cheers
Foxy
Attachments:
You are playing a mod like ESC, Mayhem or Zero? Or do you use the community patch 3.9.02? If so you will need the hotfix available on tauniverse.com
I've got this problem as well.

I've got an Nvidia 980Ti with the latest drivers and Windows 10 64 bit with 16GBs of RAM.

I installed TA as normal and then followed these instructions to patch it up to the latest version and install the Escalation mod. I also installed the hot fix but nothing seems to fix the issue. Alas I can't post any links at the moment for some stupid reason (probably a spam filter of some type) but if you Google this:

"getting gog total annihilation working on windows 10"

and click on the fourth link down you'll find the instructions I used to install all the patches (the link goes to a Steam user community post).

Can anyone suggest a solution as I'm stumped. As far as I am aware I should have the absolute latest version of everything available.
For me error "0xc0000022" got fixed by enabling DirectPlay found in Control Panel --> Programs and Features --> Turn Windows features on or off --> Legacy Components --> DirectPlay. Then got "Error: Environment Initialization failed. Check Direct X settings" and fixed by adding -d to TA shortcut to run in window mode. The menu screen does show in window mode but when the game starts it is full screen.

System:
Windows 10 Creator Build
HP Pavilion Laptop with both Nvidia Geforce GT and Intel HD Graphics
Intel Core i5
Hi there,

so adding the -d works to get it started, but is there a way to make it go back to full screen mode after that? it's very small on my screen now.
avatar
fireone: For me error "0xc0000022" got fixed by enabling DirectPlay found in Control Panel --> Programs and Features --> Turn Windows features on or off --> Legacy Components --> DirectPlay. Then got "Error: Environment Initialization failed. Check Direct X settings" and fixed by adding -d to TA shortcut to run in window mode. The menu screen does show in window mode but when the game starts it is full screen.

System:
Windows 10 Creator Build
HP Pavilion Laptop with both Nvidia Geforce GT and Intel HD Graphics
Intel Core i5
avatar
foxarwolfen: Hi there,

so adding the -d works to get it started, but is there a way to make it go back to full screen mode after that? it's very small on my screen now.
Is the in-game resolution 640x480? Change it in the game options
Thank you so much! This is a major improvement. Any chance of getting one that works for Secret Forces?