It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
Hi, I just recently finished installing or "setting" up the game. I used the "browser" way to download the game, "package-by-package".

I downloaded the setup first, then the seven or so .bin setup files, then the patch. After running the non-.bin setup file it seemed to work just fine, no errors, nothing. I then ran the patch, that of which worked just fine as well, no apparent issues.

Then, I tried playing by clicking the shortcut placed on my desktop... and nothing. All it does is open something in the background called Witcher 3 and close it five seconds later (as seen from the Task Manager when checking).

I'm 'assuming' this is to do with some weird thing with something like that patcher not made properly to accommodate for people who don't install the game into a specific place (that of which they don't seem to tell you about). This is what I read about someones registry post on it (which really didn't help me resolve the issue to be honest - but it was vague in explaining what to do anyways).


I'm running on an i5, and a GTX 970 with Win8.1. I have downloaded the latest drivers, have tried compatibility modes, and tried running as admin. I tried applying this "patch" three times (once from the gog site, two from that random play.witcher etc etc site). Nothing has worked.

My C drive is an SSD, and it's not very large, so there's no way I'm going to install it on that thing... So it's installed on my 1TB D drive. The directory it shows is "D:\The Witcher 3 Wild Hunt\bin\x64"

Please, if anyone can help me to just play the game, that'd be great.
I have the same problem, I also have an i5 and gtx 970 but I think that is a coincidence.
avatar
zotoli: I have the same problem, I also have an i5 and gtx 970 but I think that is a coincidence.
Hm, maybe. It is a common setup.
Have you tried all the steps here?

1) If you have GOG Galaxy Client, uninstall it.

2) Then click start button -> type "cmd" -> right click "cmd.exe" and click "run as administrator"

Type :

sc delete GalaxyClientService
sc delete GalaxyCommunication

So the GOG background services are removed from you PC.

3) Then,
Go to the game folder / bin / x64 and delete or rename galaxy.dll... Launch the game, a error dialog will pop out but the game actually runs.

4) If all fails, reboot PC, some found this worked for some of us.
Thanks for the suggestion, this didn't work for me :( still not responding black screen...
avatar
Hycinthus: Have you tried all the steps here?

1) If you have GOG Galaxy Client, uninstall it.

2) Then click start button -> type "cmd" -> right click "cmd.exe" and click "run as administrator"

Type :

sc delete GalaxyClientService
sc delete GalaxyCommunication

So the GOG background services are removed from you PC.

3) Then,
Go to the game folder / bin / x64 and delete or rename galaxy.dll... Launch the game, a error dialog will pop out but the game actually runs.

4) If all fails, reboot PC, some found this worked for some of us.
Yep, it actually worked for me. Sorry for the semi-late reply to this.

Thanks!
avatar
Hycinthus: Have you tried all the steps here?[...]
Thank you very very much!
avatar
Hycinthus: Have you tried all the steps here?

1) If you have GOG Galaxy Client, uninstall it.

2) Then click start button -> type "cmd" -> right click "cmd.exe" and click "run as administrator"

Type :

sc delete GalaxyClientService
sc delete GalaxyCommunication

So the GOG background services are removed from you PC.

3) Then,
Go to the game folder / bin / x64 and delete or rename galaxy.dll... Launch the game, a error dialog will pop out but the game actually runs.

4) If all fails, reboot PC, some found this worked for some of us.
Thanks that worked for me.
avatar
Hycinthus: Have you tried all the steps here?

1) If you have GOG Galaxy Client, uninstall it.

2) Then click start button -> type "cmd" -> right click "cmd.exe" and click "run as administrator"

Type :

sc delete GalaxyClientService
sc delete GalaxyCommunication

So the GOG background services are removed from you PC.

3) Then,
Go to the game folder / bin / x64 and delete or rename galaxy.dll... Launch the game, a error dialog will pop out but the game actually runs.

4) If all fails, reboot PC, some found this worked for some of us.
This did the trick for me, thank you. Too bad software nowadays comes out with breaking bugs, even from CD Projekt :(
I'm so glad this solution worked, at least helped 4 or 5 of you made my day.

I was struggling with this earlier this morning, and people helped me, so wanted to return the favor.
Done the above, still no luck, It runs the process but doesn't open a window
Hey guys, if you still can't run the game here's what you can do:

-Open the Witcher 3 instalation folder
- Go to the bin folder
- Acess the x64 folder
- Delete galaxy.dll

When you start the game an error will appear saying that galaxy.dll is missing, but the game will run and save just fine!
I've tryied everything else and only this worked for me

Hope this helps, game is amazing!
avatar
nico19908: Hey guys, if you still can't run the game here's what you can do:

-Open the Witcher 3 instalation folder
- Go to the bin folder
- Acess the x64 folder
- Delete galaxy.dll

When you start the game an error will appear saying that galaxy.dll is missing, but the game will run and save just fine!
I've tryied everything else and only this worked for me

Hope this helps, game is amazing!
Done that, game runs process but no windows appear.
It worked for me, but I did download the game manually from GOG and patched by myself. Delete Galaxy, it sucks honestly.
Also, try installing the game in the Default folder, which is C:/GOG games/The Witcher 3 Wild hunt

By the way, Nvidia has a new driver just for this game! be sure to update
Post edited May 19, 2015 by nico19908
The program can't start because Galaxy.dll is missing from your computer. Try reinstalling the program to fix this problem