It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Let's say gamma value can be changed from 0.1 to 1.9 in game, and take 1 for standard value.

I have a monitor with 2560 x 1440 (16:9) screen resolution. For my rig it's too much to have game running smoothly on high settings, so I lower the resolution to 1920 x 1080. But then gamma settings shift to some higher values, so that the picture becomes overexposed, colours become pale and the games loses much of its charm. By shifting I mean that in-game gamma values map to some higher “real gamma” values. Subjectively 0.1 becomes 1.5 and 1.9 – much more (really doesn't matter in this case). So the lowest value for gamma I can set is around 1.5 and the picture looks good to me at 0.8 – 1.0.

For almost any other resolution (didn't check them all) there is no such problem, gamma values don't shift, colours are ok. Also I have TW3 installed on the other machine and there is no problem at all with any resolution. Native resolution for the second machine is 2560 x 1600 (16:10).

The only difference between these two machines I can think of apart from GPU and drivers is on the first “problematic” machine I have monitor calibrated with Datacolor Spyder3. Not sure if it's so important. None of the machines has the latest Nvidia TW3 adapted driver.

Why of all resolutions do I have problems only with the one I need? Murphy's law...

EDIT: It looks like the problem is not with gamma settings. Gamma can be easily tweaked like , the problem will persist. I believe it has something to do with colour management, because even with very low gamma values (negative as well) black colour doesn't look black at all, it's way too bright. And I have no idea how to modify colour curves for in-game graphics. There's [url=https://www.gog.com/forum/the_witcher_3_wild_hunt/witcher_3_another_game_that_ignores_colour_management_rant]this topic, but it doesn't give the answer. There was a suggestion to use CPKeeper, I've tried it but to no avail.

EDIT-2: Have tried the latest NVidia driver (352.86 at the moment) to no avail.
Post edited May 25, 2015 by green.anger
No posts in this topic were marked as the solution yet. If you can help, add your reply
I'm probably not clear on your setup, but are you saying that the gamma is shifting in Borderless windowed mode (which should be impossible?), when you change the resolution?

When in this mode, if you change the resolution, it simply shrinks the window since it isn't in full screen mode. It should not be able to change your custom gamma settings.

If it is in fullscreen mode, the Witcher 3 just discards your ICC profile...

This is pretty weird, i'm thinking it may be something to do with the monitor, perhaps you can have custom settings for different resolutions, though...it still doesn't really explain how you can even be using your ICC profile with The witcher 3 in fullscreen mode (maybe you have some utility that can force it?).
avatar
Jamie.monro: I'm probably not clear on your setup, but are you saying that the gamma is shifting in Borderless windowed mode (which should be impossible?), when you change the resolution?

When in this mode, if you change the resolution, it simply shrinks the window since it isn't in full screen mode. It should not be able to change your custom gamma settings.

If it is in fullscreen mode, the Witcher 3 just discards your ICC profile...

This is pretty weird, i'm thinking it may be something to do with the monitor, perhaps you can have custom settings for different resolutions, though...it still doesn't really explain how you can even be using your ICC profile with The witcher 3 in fullscreen mode (maybe you have some utility that can force it?).
All this happen in full screen mode only, and only for 1080p (weird). Switching to borderless windowed mode in 1080p just shrinks the window, you're right, so this is not the solution.

The biggest question is if TW3 discards ICC profile why does the picture in 1080p so much differ from other resolutions? Black is not black anymore, it's grey.

I think for now I juts switch to 1440p and medium settings. For this resolution it looks good for both full screen and borderless windowed modes. Eventually I hope to find a solution to my 1080p "pale" problem.
I'm sorry, I wasn't able to figure out anything.

I tried playing around with colour settings within catalyst and applying them at different resolutions but I could not recreate the same problem.

I did manage however to fix my AMD colour profile settings not being applied within Witcher 3 by using Power strip. It unfortunately only works on AMD hardware.

You probably already have, but did you try looking at your monitor menu colour settings while running at a different resolution to see if they were any different than when running in fullscreen?
avatar
Jamie.monro: I'm sorry, I wasn't able to figure out anything.

I tried playing around with colour settings within catalyst and applying them at different resolutions but I could not recreate the same problem.

I did manage however to fix my AMD colour profile settings not being applied within Witcher 3 by using Power strip. It unfortunately only works on AMD hardware.

You probably already have, but did you try looking at your monitor menu colour settings while running at a different resolution to see if they were any different than when running in fullscreen?
Oh, thanks a lot for your research. I think my problem is really hard to recreate due to its weirdness, I cannot even think of where it came from and what causes it.

My monitor doesn't have any different colour settings for different resolutions, it's always the same, double checked.

And it's really unfortunate your solution works for AMD only, I've got NVidia. But still glad you could solve the issue for yourself, your research was not in vain.

It's just a bit sad I'm forced to use 1440p on mid/high with ~30fps, when I could drop to 1080p on high/ultra with 40-45fps.
OK, I've found a workaround. I wonder why I didn't think about it in the first place, silly me... Instead of changing in-game resolution and going into full screen mode with all its colour profile problem, I just changed OS resolution and kept borderless windowed mode. It's not as sharp as with native resolution even with sharpening post processing on high, but at least I have solid 40-45 fps on all ultra except for foliage visible distance and shadow quality which are on high and HW off.
Post edited May 25, 2015 by green.anger
avatar
green.anger: OK, I've found a workaround. I wonder why I didn't think about it in the first place, silly me... Instead of changing in-game resolution and going into full screen mode with all its colour profile problem, I just changed OS resolution and kept borderless windowed mode. It's not as sharp as with native resolution even with sharpening post processing on high, but at least I have solid 40-45 fps on all ultra except for foliage visible distance and shadow quality which are on high and HW off.
Well that sounds like a decent solution. I'm even humming and harring about using Powerstrip. It does work quite well, but the way it interprets the colour profile introduces some amount of banding (not really noticable in games, but still a pain as I need to switch between colour sustainer and powerstrip).

I am consistently below 60fps (After tweaks i'm running around 34(min)-45fps (Negative LOD and increasing the shadow distance to improve quality)), so having vsync not working isn't too noticable.
avatar
green.anger: OK, I've found a workaround. I wonder why I didn't think about it in the first place, silly me... Instead of changing in-game resolution and going into full screen mode with all its colour profile problem, I just changed OS resolution and kept borderless windowed mode. It's not as sharp as with native resolution even with sharpening post processing on high, but at least I have solid 40-45 fps on all ultra except for foliage visible distance and shadow quality which are on high and HW off.
avatar
Jamie.monro: Well that sounds like a decent solution. I'm even humming and harring about using Powerstrip. It does work quite well, but the way it interprets the colour profile introduces some amount of banding (not really noticable in games, but still a pain as I need to switch between colour sustainer and powerstrip).

I am consistently below 60fps (After tweaks i'm running around 34(min)-45fps (Negative LOD and increasing the shadow distance to improve quality)), so having vsync not working isn't too noticable.
Finally I've found the cause of this colour issue! It's only applicable for NVidia GPU as these wise guys make some weird drivers. I'd always thought ATI drivers were awful, now I'm not quite sure. For some reason NVidia drivers I used prior to having solved the issue (if I'm not mistaken prior to 347.09 of 23 Dec 2014) consider resolutions 1080p and 720p to be of TV output, not PC. And for RGB colour format TVs have limited dynamic range, something like 16-236 comparing to full 0-255. So every time TW3 changed full screen resolution NVidia shrank the range and all effort to bring contrast back didn't yield great results, the picture stayed dull. After 347.09 driver release they added option to choose dynamic range, so I just updated driver (again, for some reason when I updated it before and didn't know about the option, default value was "limited range") and selected right option for colour dynamic range. Have found that prior to this driver people struggled with the issue and used someone's small program to tweak Win registry entries to get the same results. It was back in 2012 and I'm sure even earlier. NVidia f***rs just ignored the problem for more than 5 years, some people claimed it was 8+!! This is ridiculous... I'm thinking of posting a separate thread to address this issue and provide links and screenshots in case others have the same problem. Though this one wasn't so popular and it seems to be a rare case, I'd spent a lot of time on the net searching for a solution.
Might be how it interprets the capabilities of the display? I will out to either my 1080p monitor or my 1080p television. Only the television offers the additional control of setting it to 0-255 in the nvidia control panel.
I have the same problem. Do you perchance have a monitor from Asus? See the thread here:
forums.cdprojektred.com/threads/45734-gamma-too-bright-only-in-1080p?p=1749471
Instead of the ingame option and/or the NVidia settings I used the monitor adjustments (LG 24") with best results.
I've found the solution and it was in all games, not only Whitcher.

1. Open NVidia control panel
2. Change desktop resolution to 1920x1080, hit "Apply"
3. Change "output dynamic range" to "full". Hit "Apply" again
4. Change resolution back to your monitor native.

Done!
avatar
soulburner: I've found the solution and it was in all games, not only Whitcher.

1. Open NVidia control panel
2. Change desktop resolution to 1920x1080, hit "Apply"
3. Change "output dynamic range" to "full". Hit "Apply" again
4. Change resolution back to your monitor native.

Done!
Sir, I was googling this problem and found your solution. I literally have had this problem for 3 years now and you are the one that solved it. I had to log in to thank you.