It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
avatar
juantamad: OK, I just figured it out. You have to set the game in fullscreen instead of the default borderless window in the graphics setting. Then the Gamma setting will come out.

This is really annoying hiding the gamma option like that.
avatar
Ciris: Just wanted to confirm that is the correct solution to the issue. Sorry for not catching the thread sooner to help out!

Edit: in terms of explanation, as GingerNaTT said:

avatar
GingerNaTT: Please bear in mind that every game running on windows, when choosing windowed/bordeless window option will draw gamma from desktop. Gamma option is only available in fullscreen mode. Nvidia cards have an option to choose gamma for specific aps so you can adjust there (do not know if it works for every card tho). Also do not know if AMD cards have the same option.
avatar
Ciris: So this is not a technical error, as it may seem at first, but rather an element of design not of the game, but of the way hardware and software or various types of software share responsibilities for certain settings. :)
It is just how Windows handles gamma. ; ) It's not the problem of the witcher game itself.
In case someone feels the range of gamma values is still limited in full screen mode, there's a way to tweak it.

In folder \The Witcher 3 Wild Hunt\bin\config\r4game\user_config_matrix\pc open file "rendering.xml". By default the 5th row looks like this:

<Var id="GammaValue" displayName="gamma" displayType="GAMMA;0.1;1.9;90" tags="nonLocalized"/>

You'll have to replace "GAMMA;0.1;1.9;90" with your own values like this "GAMMA;x;y;z" where:
x < y,
z = (y -x) * 50.
[for z it's only assumption based on the default values and examples I've come across]

So for instance if your screen is too bright even with minimised gamma slider, replace gamma values with something like this:
"GAMMA;-4;1;250". And yes, x and y may be less than 0.
Post edited May 21, 2015 by green.anger
avatar
green.anger: In case someone feels the range of gamma values is still limited in full screen mode, there's a way to tweak it.

In folder \The Witcher 3 Wild Hunt\bin\config\r4game\user_config_matrix\pc open file "rendering.xml". By default the 5th row looks like this:

<Var id="GammaValue" displayName="gamma" displayType="GAMMA;0.1;1.9;90" tags="nonLocalized"/>

You'll have to replace "GAMMA;0.1;1.9;90" with your own values like this "GAMMA;x;y;z" where:
x < y,
z = (y -x) * 50.
[for z it's only assumption based on the default values and examples I've come across]

So for instance if your screen is too bright even with minimised gamma slider, replace gamma values with something like this:
"GAMMA;-4;1;250". And yes, x and y may be less than 0.
Blast, for a second I had hope!

The issue i'm looking for is a way to disable gamma completely in fullscreen mode so that my colour calibrated ICC profile is not overrided in fullscreen mode. At the moment I need to run the game in borderless fullscreen mode otherwise everything becomes very reddish (My monitor is a Wide gamut type), but of course I miss out on vsync. I ranted about this here:

http://www.gog.com/forum/the_witcher_3_wild_hunt/witcher_3_another_game_that_ignores_colour_management_rant

I played around with removing those variables, but no go, is isn't going to be that simple it seems...ahh well
avatar
green.anger: In case someone feels the range of gamma values is still limited in full screen mode, there's a way to tweak it.

In folder \The Witcher 3 Wild Hunt\bin\config\r4game\user_config_matrix\pc open file "rendering.xml". By default the 5th row looks like this:

<Var id="GammaValue" displayName="gamma" displayType="GAMMA;0.1;1.9;90" tags="nonLocalized"/>

You'll have to replace "GAMMA;0.1;1.9;90" with your own values like this "GAMMA;x;y;z" where:
x < y,
z = (y -x) * 50.
[for z it's only assumption based on the default values and examples I've come across]

So for instance if your screen is too bright even with minimised gamma slider, replace gamma values with something like this:
"GAMMA;-4;1;250". And yes, x and y may be less than 0.
avatar
Jamie.monro: Blast, for a second I had hope!

The issue i'm looking for is a way to disable gamma completely in fullscreen mode so that my colour calibrated ICC profile is not overrided in fullscreen mode. At the moment I need to run the game in borderless fullscreen mode otherwise everything becomes very reddish (My monitor is a Wide gamut type), but of course I miss out on vsync. I ranted about this here:

http://www.gog.com/forum/the_witcher_3_wild_hunt/witcher_3_another_game_that_ignores_colour_management_rant

I played around with removing those variables, but no go, is isn't going to be that simple it seems...ahh well
Yeah, I've seen your topic. Even provided a link to it in my own. I've got weird behaviour with one particular resolution. If you have a minute, could you look at the issue I described? Anyway it looks like for now we don't have a reasonable solution to our problems.
Post edited May 21, 2015 by green.anger