It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

blammy314568: Hey people,

This saved me. Thank you.

Just as juice for search engines, here are the errors I was getting:

./configurator failed to start due to the following dependancy problems: => (0xf770c000)
[...] => not found

./witcher2 failed to start due to the following dependancy problems: => (0xf776c000) => /usr/lib32/nvidia-375/ (0xf76d1000) => not found => not found
I just had the same issue on Fedora 25, dnf install SDL2*.i686 solved the problem. It would be nice if Witcher 2 installer could search for unsatisfied dependencies and tell it to the user just before installation. Or if Launcher app could throw a error message instead of doing nothing.
bobsobol: I think this is the same issue we resolved here:-

As stated, I really think GOG packagers should include this in the, 64bit Linux doesn't provide fully featured 32-bit environment the way Windows does with WoW6432, and nobody in their right mind, wanting to play video games on their PC is running a 32-bit OS these days.

When you say Ubuntu 14.04, you're probably not talking about the ARM, DEC, or ia64 builds, but in gaming, you're also more likely to be using x86_64 than i386. (unless you're using GOG because you have a shitty rig and can't play contemporary stuff...)

Short version,the line that got all the libraries I needed going was:-
sudo apt-get install libsdl2-2.0-0:i386 libsdl2-image-2.0-0:i386 libcurl3-gnutls:i386

@miwioa sounds like you're missing the multiarch to me? If so, to correct the typo in earlier posts on this thread:-
sudo dpkg --add-architecture i386 && sudo apt-get update

Which should be run before the first.
Many thanks!

Agreed it seems odd that these are not included in the sh script at install as majority of linux users are now 64bit.
Thanks nyxs, and you're welcome. I personally think that blammy314568 answer looks more complete, and should hit a wider range of Debian based systems than mine. As Linux moves on, the version numbers in these instructions will be superseded by something new. (making the default inclusion by GOG even more valuable ... I hope they take notice)

I'm very pleased to see other's adapting the information I've shared and passing on what they learn. Which was the problem with the OP by shurtagul which I originally replied to, asking for help. Their comment "Sorry, solved with installing 32bit libraries." is of very little use to others, presenting more questions than answers. ;) "Which 32bit libraries, and how did you do that?" I thought. But it was enough to get me started with some terms to search, so I should also say thanks, even just for that. :)
I had same issues with Xenonauts (from GOG). I am running Linux Mint. Big Thanks!
I did have allot of issue to install the_witcher_2
it compain missing of allot of stuff

I am runing debian sid

for installer to work fine
apt install gtk2-engines gtk2-engines-murrine murrine-themes

for the game
for thuse that does not have i386 for 64 bits install
sudo dpkg --add-architecture i386
sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade

This packages I was missing , I do not known which sdl2 packages I did miss, so did install all. and revert back thuse that was for 64bits direcly after.

sudo apt install libgtk2.0-0:i386
sudo apt-get install -y libsdl2.*:i386
sudo apt-get install -y libsdl2.*
sudo apt-get autoremove

do not forget to install mesa3d for i386 as well. I already have it install for crosvoer so I do not need install it.
after that I did not have any issue at all.