}

It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
But it is installed
/usr/lib/x86_64-linux-gnu/libSDL2-2.0.so.0
/usr/lib/x86_64-linux-gnu/libSDL2-2.0.so.0.2.0

Any hint? I think I have to symlink them somewhere but I don't know where The witcher is expecting them.

I am using ubuntu 14.04 64bits

Thanks.
avatar
enboig: But it is installed
/usr/lib/x86_64-linux-gnu/libSDL2-2.0.so.0
/usr/lib/x86_64-linux-gnu/libSDL2-2.0.so.0.2.0

Any hint? I think I have to symlink them somewhere but I don't know where The witcher is expecting them.

I am using ubuntu 14.04 64bits

Thanks.
You need the i386 libs. If you activated the multiarch, just do a:
sudo aptitude install libsdl2-2.0-0:i386

To activate multiarch:
sudo dpkg --add-architecture i386
sudo aptitude update
avatar
enboig: But it is installed
/usr/lib/x86_64-linux-gnu/libSDL2-2.0.so.0
/usr/lib/x86_64-linux-gnu/libSDL2-2.0.so.0.2.0

Any hint? I think I have to symlink them somewhere but I don't know where The witcher is expecting them.

I am using ubuntu 14.04 64bits

Thanks.
avatar
masaru20100: You need the i386 libs. If you activated the multiarch, just do a:
sudo aptitude install libsdl2-2.0-0:i386

To activate multiarch:
sudo dpkg --add-architecture i386
sudo aptitude update
I'm having the same problem and using the same OS.

This is output to terminal.

~$ sudo dpkg --add-architecture i386
~$ sudo aptitude update
sudo: aptitude: command not found
~$


The overall problem I'm trying to fix is missing library’s:

@chell:/opt/GOG Games/The Witcher 2 Assassins Of Kings/game$ ldd witcher2 | grep not
libSDL2-2.0.so.0 => not found
libcurl.so.4 => not found
libSDL2-2.0.so.0 => not found
@chell:/opt/GOG Games/The Witcher 2 Assassins Of Kings/game$

I'm new to linux and I'm having trouble finding out how to install the library's. Any help is appreciated!
@Matchu010

Find out how to install aptitude and use it to download libsdl2 (i386) and libcurl (i386)
Alternative, find deb files and install them manually, or get libs from steam runtime, or compile libs from source.
I tried to compile them and I have 64bit compatibility packages now, except for SDL2_image which does not build.
Witcher package should probably provide required libs in a patch, but it currently does not.
high rated
sudo apt-get install libc6:i386 libasound2:i386 libasound2-data:i386 libasound2-plugins:i386 libgtk2.0-0:i386 libsdl2-2.0-0:i386 libsdl2-image-2.0-0:i386 libfreetype6:i386 libcurl3:i386
..should install all needed packages.
avatar
Matchu010: This is output to terminal.

~$ sudo dpkg --add-architecture i386
~$ sudo aptitude update
sudo: aptitude: command not found
Should be:
sudo dpkg --add-architecture i386
sudo apt-get update

UPD: More appropriate advice: http://www.gog.com/forum/the_witcher_2/the_witcher_2_complains_cannot_open_libsdl220so0/post5
Post edited November 26, 2014 by MassterJedi
Thanks for all the answers. Now it works, but I just discovered my computer isn't powerful enough to run the game :(
avatar
enboig: Thanks for all the answers. Now it works, but I just discovered my computer isn't powerful enough to run the game :(
I've made a small patch that solves most Witcher 2 linux problems on Ubuntu and Mint: https://docs.google.com/file/d/0Bw5Xv02Yq2HrbEZWVkZZSVpzV2s

With Mint it works out of the box but Ubuntu might require the Multiarch libraries.
avatar
Ganni1987: I've made a small patch that solves most Witcher 2 linux problems on Ubuntu and Mint: https://docs.google.com/file/d/0Bw5Xv02Yq2HrbEZWVkZZSVpzV2s

With Mint it works out of the box but Ubuntu might require the Multiarch libraries.
Thanks for the easy fix, works fine in Mint 17.1
Post edited December 30, 2014 by khasneh
Hi all.
I had the same problems using Gentoo Linux. I just wanted to state that there is a solution and Witcher 2 runs smoothly under Gentoo. For the solution see the Gentoo forum.

I am not allowed to post links, (Why is this?) so I'll try to split up the address in two lines.
htt
ps://forums.gentoo.org/viewtopic-t-1007130-highlight-witcher.html

Just in case somebody else is looking for this. Finding this out by myself was quite a pain in the neck...

Happy gaming.
Post edited April 03, 2015 by m-raven
avatar
enboig: Thanks for all the answers. Now it works, but I just discovered my computer isn't powerful enough to run the game :(
avatar
Ganni1987: I've made a small patch that solves most Witcher 2 linux problems on Ubuntu and Mint: https://docs.google.com/file/d/0Bw5Xv02Yq2HrbEZWVkZZSVpzV2s

With Mint it works out of the box but Ubuntu might require the Multiarch libraries.
Thanks :)
I've been trying for hours to get this to work...

I've tried the patch fix that was listed in the thread...and have tried installing everything listed here but I get this error:

" The following packages have unmet dependencies:
libsdl2-2.0-0:i386 : Depends: libwayland-egl1-mesa:i386 (>= 10.0.2) but it is not going to be installed or
libwayland-egl1:i386
E: Unable to correct problems, you have held broken packages. "
I think this is the same issue we resolved here:-
www.gog.com/forum/the_witcher_2/dependencies_problem

As stated, I really think GOG packagers should include this in the postinstall.sh, 64bit Linux doesn't provide fully featured 32-bit environment the way Windows does with WoW6432, and nobody in their right mind, wanting to play video games on their PC is running a 32-bit OS these days.

When you say Ubuntu 14.04, you're probably not talking about the ARM, DEC, or ia64 builds, but in gaming, you're also more likely to be using x86_64 than i386. (unless you're using GOG because you have a shitty rig and can't play contemporary stuff...)

Short version,the line that got all the libraries I needed going was:-
sudo apt-get install libsdl2-2.0-0:i386 libsdl2-image-2.0-0:i386 libcurl3-gnutls:i386

@miwioa sounds like you're missing the multiarch to me? If so, to correct the typo in earlier posts on this thread:-
sudo dpkg --add-architecture i386 && sudo apt-get update

Which should be run before the first.
Post edited December 07, 2015 by bobsobol
avatar
enboig: Thanks for all the answers. Now it works, but I just discovered my computer isn't powerful enough to run the game :(
avatar
Ganni1987: I've made a small patch that solves most Witcher 2 linux problems on Ubuntu and Mint: https://docs.google.com/file/d/0Bw5Xv02Yq2HrbEZWVkZZSVpzV2s

With Mint it works out of the box but Ubuntu might require the Multiarch libraries.
This is simple fix for Mint 17.3 also, Thanks

BTW, this thread should be posted in Witcher forum also
Post edited January 08, 2017 by armandhaa
Hey people,

I ran into this issue too on LinuxMint 18.1 Cinnamon 64bit. Having bought several Humble Indie Bundles before, it didn't occur to me that GOG would not include any dependencies for this game in the install package. But it does indeed state it on the product page in the system requirements section. Here's what I did to get it running, courtesy of information I found in this forum.

Open a terminal and run the following commands. Each command separated by a blank line. The 'sudo' command gives it root, or administrator privilege so it will ask for your administrator password. If you can't use sudo, try 'su' without the quotes, press enter, and then enter the root password. This switches to root privilege for the terminal. Then enter each command minus the sudo command.

sudo dpkg --add-architecture i386

sudo apt update

sudo apt install libc6:i386 libasound2:i386 libasound2-data:i386 libasound2-plugins:i386 libgtk2.0-0:i386 libsdl2-2.0-0:i386 libsdl2-image-2.0-0:i386 libfreetype6:i386 libcurl3:i386

Some of these libraries were already installed, so don't be surprised if only a few install.
It should run after this. Mine runs beautifully.

What tripped me up is that you have to add the 32 bit architecture, which is the first command. And then I typically do this sort of things through Synaptic Package Manager. What I found out is that Synaptic does NOT show all the :i386 files you need. You have to do this through the terminal commands to install the dependencies.

Good luck!