It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Patch seems to be running okay except for one thing. It stopped the configuration utility that showed up when starting the game from appearing. I have wrong settings currently (windowed and wrong resolution). Any way to open the config utility again?

Nevermind. Just used DxWnd and I can fix it from there.
Post edited February 16, 2019 by idbeholdME
Hey, I gave up on getting alchemy to work, work around is too much of a pain to bother with. Any luck getting the reverb to work without it?
Something not right with the 1.04 patch. I keep getting freezes over and over again with it. But the previous version working fine without problems.
Post edited March 30, 2019 by sk3leton91
I CANT SEEM TO SEE ANYTHING BUT SHADOWS TOO! its crazy i cant see any character!
Hi guys.

I wanted to leave some feedback about the patch and The Suffering Prison Is Hell.

1st problem I noticed were crashes. Absolutely random and maybe every hour or so. I tried tons of things but nothing seems to have fixed it, including setting affinity but from what I am reading this patch already has such fixes anyway. However, I did read that deleting the dsound files fixed it for some people. Sadly read that too late and finished the game but might replay it anyway and test this. There is also DSOAL 3D Audio mod that actually might work with the game and add HRTF but maybe it causes crashes too? Maybe I will test all this if I get around to it. I also play Suffering 2 later.

2nd problem I noticed were autosave checkpoints. They didnt work whatsoever but this problem is also listed on the PC Gaming Wiki. Not even the patch here seems to fix it. Needed to make manual saves all the time. Maybe the patch author could fix the autosave checkpoints? Seem to be mainly a issue on modern OS systems.

3rd problem was that in 4K resolution (used it for downsampling Anti Aliasing, game looks amazing with it!) the notes were way too small to read. Workaround is to change resolution to 1080p, read notes, and then change back.

4th problem was that the weapon inventory GUI is broken and doesn't display weapons properly. But author seems to be aware of that since it is in the notes. No fix available?

Just thought I might leave some feedback for the mod author. Thanks a lot for this patch! Really makes the game enjoyable again. Minus the crashes... But that might not even be the authors fault, more like GOGs for including dsound files. If those are really the reason for the crashes.

Didn't they initially add those files to fix sound issues with the game? I remember this as workaround years ago to fix missing sounds and low audio channels and such stuff. From what I am seeing this patch fixes those issues anyway, no?

Oh btw, saw some people complaining about the setup not showing up again.
To run the setup box again, make a shortcut of the game exe and add -setup as commandline.
Like this: "C:\Games\The Suffering\SUFFERING.EXE" -setup
Post edited July 04, 2019 by xXPostalDudeXx
hello I have a question about the patch. First thing it work really well but the problem is I cannot launch the game on GOG Galaxy, The only way I can play the game it when I go to the folder and launching there it work.So the question is to play the game do I have to always go to the folder of the game to launch it or is there a way to launch it on GOG with the patch.Thank if someone can help me
I'd still like to try to address some of the issues, just haven't found the time yet. Widescreen code was ported from ThirteenAG's widescreen fix and baked directly into executable files, but it's a bit buggier than I knew initially. I fixed the bug with 1600x900 resolution and there was also a small bit taken from the the very first widescreen fix that ever existed for the game. I have to remember to credit the person in the next version's changelog, without that bit, it craps out at higher resolutions, such as 3840x2160. I haven't noticed 1280x1024 resolution's broken as well...and there's the thing with broken weapon inventory icons in the first game.

Regarding version 1.04, from what I remember, it had some cosmetic fixes only visible when you read its code. Don't see how it could cause freezes compared to previous version. Maybe it's something inherent from the original game combined with some undetermined system specific.

Regarding patch stopping showing configuration dialog at startup; that's actually a good thing as it was intended to show by itself only when settings couldn't be read from the system, which most of the time can happen due to permission issues since the original game stores them in the part of Windows registry where only admins have write access. Windows has some compatibility workaround for such cases, but they could fail under certain circumstances.

Autosave checkpoints; I've no idea how they fail to work for some people. I don't think it has anything to do with Windows version, they work on my end on anything from Windows XP to Windows 10.

Small notes at high resolution; it's strange that they don't scale like other elements do. No idea how to fix.

dsound.dll included with GOG version is older version of IndirectSound, which happens to have some issues. It's not needed to fix issues with missing and dropping sounds as those are addressed in the patch. The only reason to use it (latest version, of course) would be if you like the way it mixes sounds better compared to Microsoft's implementation. I think an actual surround system is needed to hear the difference.

Finally, regarding GOG Galaxy, I've never used it and can't tell why launching patched game through it wouldn't work. Can anyone test if renaming dinput.dll in game folder to something else makes it launch? It'll partially cripple the patch; redirection of user file read/writes operations to user specific folders and settings in Torque.ini won't work. If it helps, then it should be fixable.