It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
Hi all, I posted this in another thread but makes more sense here...
I really want to pick this game up but --
Is there a way to force it into a window, or is it fullscreen only? I've downloaded the demo from Steam before and couldn't find a way to force it into a window. Pretty painful looking at 600x800 on a 24" monitor.
I don't know...I didn't mod it when I played it. Either way, don't let the visuals dissuade you from embarking on.....The Longest Journey. lol
You could try adding -windowed to the Target line (Right-click on .exe > Propeties)
I tried changing the bool_StartFullscreen option from 1 to 0 in the preferences.ini file, but that didn't work. Please, help!
avatar
soujiro14: I tried changing the bool_StartFullscreen option from 1 to 0 in the preferences.ini file, but that didn't work. Please, help!

There's "another" preferences.ini -file hidden, you can access it by entering folder "%appdata%\the longest journey" (no quotes). Add/edit the line there and it should take effect.
In win7 the preferences.ini file that needs to be edited is in:
C:\users\<user>\AppData\Roaming\The Longest Journey.
I had to add this two lines to get windowed mode:
[DirectX]
bool_StartFullscreen=0
avatar
blackbow: Is there a way to force it into a window, or is it fullscreen only? I've downloaded the demo from Steam before and couldn't find a way to force it into a window. Pretty painful looking at 600x800 on a 24" monitor.

Actually... There is. I have a 24'' monitor myself and find that both unnecessary and counter-immersive but - if you want it that bad...
1* Download Direct3D Windower
2* Unpack ALL FILES to some nice folder
3* Run the .exe file.
4* Click the "+" sign.
5* Browse into the TLJ folder and choose "game.exe", press "Open".
6* Once you have "Game" on the list, close D3DWindower.
7* Open it again and double-click "Game"
8* (this is the annoying part) At this point, your cursor will become "stuck". You'll know what I mean when you see it. However - all you have to do to unstick it is grab TLJ's title bar and wiggle it around (or at least move it) a bit.
Whenever you wish to play it windowed again, simply repeat 7-8 ;).
Edit: scratch that, didn't know about the hidden .inis when I wrote this (that'll teach me not to post something I've written a few hours ago without checking for replies first x_x). Then again - you can run almost anything using my way...
Edit 2: Adding "[DirectX]
bool_StartFullscreen=0" works great, as long as I don't want to move the game's window (which I'd prefer in the center if I even bother playing it windowed). Once I do that and try to click on "End the Journey" it all goes to hell... So - my way still has some merit.
Post edited September 18, 2009 by Vestin
Awesome, thanks everyone.
I'm going to pick it up tonight or tomorrow and try your suggestions out; looking forward to playing this.
While I like to play fullscreen (windowed is an athmo-killer for me) I don't like the fact that TLJ can only be play stretched on my Macbook.
Is there anyway to "force" the game to the correct resolution while still being fullscreen?
I'd imagine that I have big black bars at the sides, but thats cool with me.
avatar
Suro: While I like to play fullscreen (windowed is an athmo-killer for me) I don't like the fact that TLJ can only be play stretched on my Macbook.
Is there anyway to "force" the game to the correct resolution while still being fullscreen?
I'd imagine that I have big black bars at the sides, but thats cool with me.

Are you booting Windows to play the game? In that case you can open your Intel/NVIDIA/ATI graphics control panel (depending on which graphics chip you have) and change the appropriate setting there.
For Intel, you'll find it at Display Settings - Aspect Ratio Options - Maintain Aspect Ratio. For NVIDIA, it's "Adjust desktop size and position" - "Use NVIDIA scaling with fixed-aspect ratio". Not sure about ATI, but someone else will know.
avatar
Suro: While I like to play fullscreen (windowed is an athmo-killer for me) I don't like the fact that TLJ can only be play stretched on my Macbook.
Is there anyway to "force" the game to the correct resolution while still being fullscreen?
I'd imagine that I have big black bars at the sides, but thats cool with me.
avatar
tor: Are you booting Windows to play the game? In that case you can open your Intel/NVIDIA/ATI graphics control panel (depending on which graphics chip you have) and change the appropriate setting there.
For Intel, you'll find it at Display Settings - Aspect Ratio Options - Maintain Aspect Ratio. For NVIDIA, it's "Adjust desktop size and position" - "Use NVIDIA scaling with fixed-aspect ratio". Not sure about ATI, but someone else will know.

Ohhh goodie!
Works like a charm! Thank you so much!
For the germans here:
NVIDIA Systemsteuerung -> Flachbildschirm-Skalierung ändern -> NVIDIA-Skalierung mit festem Seitenverhältnis verwenden
Don't know about the exact english menu points, but tor should have pointed you into the right direction :D
The game is not existent in the Appdata Folder.
avatar
Mick-alterbaer: The game is not existent in the Appdata Folder.
im usin win10. here "the longest journey" stores its settings and savegames in the game-folder. when i change the fullscreen-setting in the "preferences.ini" it works.

by default u cant force this old game to give u something else than 640x480. fullscreen in a higher resolution (4:3 or 16:9) is always streched by your graphics card. so if u want to force 4:3 or 16:9 u need to change the graphics card settings like tor explained.
avatar
Mick-alterbaer: The game is not existent in the Appdata Folder.
avatar
Cattie: im usin win10. here "the longest journey" stores its settings and savegames in the game-folder. when i change the fullscreen-setting in the "preferences.ini" it works.

by default u cant force this old game to give u something else than 640x480. fullscreen in a higher resolution (4:3 or 16:9) is always streched by your graphics card. so if u want to force 4:3 or 16:9 u need to change the graphics card settings like tor explained.
Thanks. I tries this already with no success. On my main computer I have the same settings in "preferences.ini" and everything is full screen, on the laptop it's not, Win 10 64 Bit both.
avatar
Mick-alterbaer: Thanks. I tries this already with no success. On my main computer I have the same settings in "preferences.ini" and everything is full screen, on the laptop it's not, Win 10 64 Bit both.
there are different versions of the game, gog, cd, steam... no idea if they use different ini paths.
so if the ini file is ok and theres no other ini somewere else its maybe your laptop graphic card not switching to 640x480.
a work around for u could be my post about the dgvoodo tool. theres a switch for fullscreen.
https://www.gog.com/forum/the_longest_journeydreamfall_series/tlj_better_resolution_for_animated_parts_of_the_graphics