It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
I'm not using the greatest laptop in the world, but a game this ancient shouldn't have as much slow down as it does. Granted it usually happens when I'm walking through steam shooting out of pipes, but its still kind of annoying. And I've applied SHTUP texture mod, though that didn't seem to hurt anything. I also tried using the rebirth mod, but my framerate just dies whenever I look at an enemy or corpse

Is there any tweaks out there that could improve things a bit?
disable multisampling, that really kills the performance when a slow or integrated gpu is used.
Also check that postprocess is disabled in cam_ext.
I'm playing the game on a 2007 laptop with very poor GMA X3100 integrated graphics, and the game runs fine in the native 1400x1050!
advanced effects are disabled by default, so unless he was messing with the config files, they should be still off.
There are numerous tips in the included troubleshooting guide (in the "doc" folder) for improving performance.