It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Hello fellow Linux gamers!

Here you’ll find scripts allowing you to build packages for Debian, Arch Linux and any derivative (Ubuntu, Manjaro, Linux Mint, etc.) from your GOG installers for System Shock games.
You will then be able to easily install these packages with you favourite packages manager.

Download links and usage instructions can be found on the following pages:
System Shock 2

We hope you’ll enjoy the ease-of-use provided by these scripts as much as we enjoy writing and tweaking them ;)

Here you go for more supported games!

-----

Salut camarades Linuxiens !

Vous trouverez ici des scripts vous permettant de construire des paquets pour Debian, Arch Linux ou n’importe quelle distribution dérivée de celles-ci (Ubuntu, Manjaro, Linux Mint, etc.) à partir de vos installeurs GOG pour la série System Shock.
Ces paquets pourront ensuite être installés facilement via votre gestionnaire de paquets habituel.

Les liens de téléchargement et les instructions d’utilisation se trouvent sur les pages suivantes :
System Shock 2

Nous espérons que vous apprécierez le confort apporté par ces scripts autant que nous nous amusons à les écrire et les améliorer ;)

Pour plus de jeux, rendez-vous par ici !
Post edited January 14, 2018 by vv221
Got The game to install but everytime I run it it puts the screen way too big and to the right of my taskbar: can’t see any menu buttons

There are 2 CFg files and I’ve set the resolution on both ; I’ve tried different combinations of use_d3d_display and force_windowed but still no difference.
100% sure that changing the resolution in cam.cfg will actually change it.
As I’ve said , I’ve set game_screen_size 1280 800 I’m both cfg files but nada; it won’t play nice with Linux
you can always set the install up on a windows pc and then just move it to the linux pc. also, some screenshots maybe?

if you set the resolution low (800*600) and force windowed, it should start fine. and I wouldn't try to set the resolution in all cfg files you can get your hands on, cam.cfg is where it belongs.
Post edited January 10, 2018 by voodoo47
avatar
bignickel1: Got The game to install but everytime I run it it puts the screen way too big and to the right of my taskbar: can’t see any menu buttons
Thanks for the report, I’m going to look into this,
I checked cam.cfg and it already has it set to 800 600; set it to force windowed but same results. The 2 files I was setting were both ext_cam.cfg. I saw a thread that said that that would be the culprit. Anyhoo ,!have tried settings in all 3 files
avatar
bignickel1: (…)
Does it run any better if you set up a virtual desktop with WINE?
You do it by running 'system-shock-2_winecfg', then checking "Emulate a virtual desktop" under the tab "Graphics". You can set your real desktop screen resolution in the fields "Desktop size".

-----

By the way, make sure you are editimg the .cfg files under ~/.config/system-shock-2
The files under /usr/local/share/games/system-shock-2 (Debian and derivatives) or /usr/local/share/system-shock-2 (Arch Linux and derivatives) are read only the first time you run the game.
Post edited January 14, 2018 by vv221
Both of your suggestions work vv221; By finding the hidden cam_ext.cgf in the .config/ folder and turning off use_d3d_display the game runs full windowed. And your tip about winecfg put it into a neat window
avatar
bignickel1: (…)
Thanks for the feedback, in the next script update I will tweak it so it uses a WINE virtual desktop on first launch (should work on any screen/GPU combination).
note that disabling use_d3d_display is not without consequences, and should be a last resort thing.
avatar
voodoo47: (…)
That’s why I chose to include the virtual desktop tweak into the script, and not the disabling of Direct3D 9 ;)
I can put d3d back on but is there any way to make the window bigger? I set desktop to 1280 800 but that did nothing.
I'm still not quite sure what the problem is. can you perhaps post a screenshot?

last time I've tried SS2 on wine I indeed had issues with the resolution, but was able to work around them either by forcing windowed temporarily, or enabling virtual desktop - both allowed me to set the proper (same as desktop) resolution from within the game, and all was fine after that.
Post edited January 14, 2018 by voodoo47
avatar
bignickel1: I can put d3d back on but is there any way to make the window bigger? I set desktop to 1280 800 but that did nothing.
The virtual desktop resolution won’t change the resolution of the game window, it is actually the maximum size the window can be (a good rule of thumb is to use your desktop real resolution).