It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I've just installed System Shock v1.1.7 (the latest version of the source port) onto my laptop, and it won't work, instead I just get the error:

Kex Assertion Failure

Assertion failed.

Condition: index < m_dwSize
File: e:\projects\systemshockex\kex3_sekhmet\source\framework\array.h

The directory mentioned in the error message doesn't exist, and not should it since I've installed the game to:


Afterwards, I did install the game to E:\wingames\SSSP (in case C:\SSSP was somehow the problem), but it still gives the same error. Note that I've included a JPG of the error message in case I've typed anything wrong (don't you wish Windows would let you copy & paste error message text?).

The laptop (a Hewlett Packard G6 1331) is running Windows SP1, and I've tried the suggestions in the System Shock Enhanced Edition mini FAQ thread, so I've installed:

* Win7 platform update, if you have Windows7.
* Windows SDK and KB4019990, if you have Windows8.
* Net Framework 4.7.2
* VC++2015

as recommended, and disabled my virus killer, but I just keep getting that same error message, which appears when I start the game, it doesn't show the intro movies, or anything. The source port works fine on my desktop (Windows 7), so it's not that the game installation file is corrupt.

The earlier version of the source port loads and runs fine on the laptop (and desktop). And the other games I've tried work fine on the laptop, it's just v1.1.7 of the System Shock source port that throws up this error and refuses to run.

Any help or advice would be much appreciated, thanks.
Axemeleon (from Discord) manage to diagnose and fix the problem in less than ten minutes. The solution was for me to copy the three folders "mods", "missions" and "localization" from the game's folder into the 'System Shock EE' folder inside the %appdata% folder.

For some reason, one or more of the files inside the %appdata%\Nightdive Studios\System Shock EE\ folder had either become corrupt or deleted, and this was fixed by copying all of the files from their original folders in the game's folder into the %appdata%\Nightdive Studios\System Shock EE\ folder.

Many thanks to Axemeleon for his invaluable help, and also to Janet Computerface, Voodoo, and everyone else for their time and patience in helping so much in narrowing down the cause of the problem, it's very much appreciated.
GOG still has to fix this game cause I have a similiar issue on version 1.1.8 now.
error.jpg (319 Kb)
Post edited November 14, 2018 by 508Cult
nope, this looks like you don't have a few required software packages installed, check the FAQ.
voodoo47: nope, this looks like you don't have a few required software packages installed, check the FAQ.
Many thanks. I have a metered internet connection so I don't have Windows Updates enabled.