It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
At least, I think it's new.

I got SS2 running very nicely on my MacPro with OSX 10.6.8, except for one thing. When you first start the game, step off the train, and head for the grav chutes, there's a grate venting steam just around a corner on your right. Mine looks like the image, as though the steam has no texture file. I tried removing all the mod files from DataPermMods, then putting them back, but it made no difference either way.

Any ideas? I've been hunting for answers for a couple of days, but I haven't found anything similar yet. I don't actually know how many more things like this there may be, because I haven't gone any further in the game. I want to get this sorted out before I continue.
Attachments:
Post edited June 28, 2013 by UniversalWolf
This question / problem has been solved by voodoo47image
apply this fix: http://www.gog.com/forum/system_shock_2/major_graphics_bug_black_screen_with_small_square/post2
Thanks again, voodoo. That definitely led me to the answer.

For anyone else reading this thread, the solution was to uncomment the line:

d3d_disp_no_rgb10_buf

in the "cam_ext.cfg" file.

It even fixed multisampling, which prior to uncommenting that line just made everything look blue.

It was remarkably easy to get it running in OSX 10.6.8, BTW, for anyone who wants to try. This was the only problem I had.
that just means your gpu does not support enhanced precision. I will ask the GOG support to disable it by default for the MAC version of the game.

one thing, can you tell me what engine version is the MAC release using? check for release_notes.txt, and when you open it, you should see "System Shock 2 v2.42 update".
Post edited June 29, 2013 by voodoo47
You are correct.

"System Shock 2 v2.42 update"

From the first line of release_notes.txt.

Also, I'm running OSX 10.6.8 and a Radeon HD 5770.