It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Well, it definitely sounds like your problem is the traditional issue with Swat 3's movies.

The "-nointro" work around of course is only a good way to troubleshoot and confirm that this is the problem. There are a few missions that trigger the playing of movies depending on success or failure. They would of course crash your game unless you can find a more permanent fix like those listed in this thread.
i have this problem too. very frustrating. i've tried literally everything i could find on the internet and still get the same error. i can bypass the intro vid using -nointro but eventually ill click on something on accident and itll try to play a vid and crash and ill lose all my progress.

ive had this problem for years running windows 7 64 bit. im convinced now that there is no solution.

i replaced all the video files with the xvid codec ones and i can watch them in media player classic, but if they try to play in-game i still get dderr generic.

i've spent more time trying to fix this problem than all the time in my life spent playing all the swat games combined. no result.
Have you tried dgVoodoo since it's a wrapper for old directx on modern OS and this sounds like a directx error? I use it for tons of old games like Swat 3 and it hasn't failed me yet but I didn't get this error before using dgVoodoo either, only really shit performance and the inability to set resolutions the game didn't support. If you need instructions ask, but it's super easy to use generally.
Post edited January 30, 2017 by Al3xand3r
What exactly are these videos? Are they just for the tutorial?
Because you open up the video files in the gog folder and they play fine
Just fyi, if you're using the Last Resort launcher, you NEED to have compatibility for the launcher set to XP SP3. Just doing the swat.exe files won't work.